[B2G][V1.2_RIL][Crash Reporting] The crash report will stay on submitted folder when user turns on the "Airplane mode"

RESOLVED WORKSFORME

Status

Firefox OS
General
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: whsu, Unassigned)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: burirun1)

(Reporter)

Description

5 years ago
* Description:
  This case reproduced on Buri device. Other devices are not yet confirmed.
  If you turn on WIFI and Airplane mode at the same time, the crash report is moved to the "Submitted" folder after system/apps crashed.
  In a general user story, if user turns on WIFI and Airplane mode at the same time, the crash report should stay on "Pending" folder after system/apps crashed.

* Test case: #6147 (https://moztrap.mozilla.org/manage/cases/?filter-id=6147)

* Reproduction steps:
  1. Launching calender app.
  2. Type following commands on command line
     - adb root
     - adb shell ps | grep b2g
     - adb shell kill -11 #calender PID#
  3. Navigating to the following directory on the phone.
     Please type the following commands.
     $ cd  /data/b2g/mozilla/Crash Reports/
  4. Using list directory command to list all folders.
     root@android:/data/b2g/mozilla/Crash Reports/submitted # ls -a

* Expected result:
  The "Pending" folder is created and the crash report is in pending folder.

* Actual result:
  Pending/submitted folders are created and the crash report is in submitted folder.

* Reproduction build:
 - Gaia:     a13c76f8d3c617ee57c302c103da04ed1a6298d1
 - Gecko:    http://hg.mozilla.org/releases/mozilla-aurora/rev/b34384409be6
 - BuildID   20130924004002
 - Version   26.0a2
 - Vendor Build: US_20120912_QC211.cfg

Thanks!

Updated

5 years ago
Keywords: regression, regressionwindow-wanted

Updated

5 years ago
blocking-b2g: --- → koi?

Updated

5 years ago
QA Contact: sarsenyev

Comment 1

5 years ago
Unable to reproduce this bug, I tried 3 different scenarios from the TC#6147
Behavior is as expected.
1) Turning on Wi-Fi data is off, after crashing the app, the crashing report status in pending
2) When turning Wi-Fi on and then turning on airplane mode,the "airplane" mode automatically turns off Wi-Fi, the status of the crash report in pending
3) When turning off Wi-Fi and airplane mode OFF but the data is on and then crash the app, the crashing report in pending
 
When the Airplane mode is on, user is able to turn on Wi-Fi manually, and then the crash report will be submitted, because to submit the report, Wi-Fi needs to be on even with airplane mode on

Build ID: 20130924004002
Gecko: http://hg.mozilla.org/releases/mozilla-aurora/rev/b34384409be6
Gaia: a13c76f8d3c617ee57c302c103da04ed1a6298d1
Platform Version: 26.0a2
Keywords: regressionwindow-wanted
William - Can you double check your STR per comment 1?
blocking-b2g: koi? → ---
Flags: needinfo?(whsu)
(Reporter)

Comment 3

5 years ago
Hi, Jason and  Sarsenyev,

Thanks for the help and reminder.

I forgot to add a precondition on the reproduction steps.
Please turn on the WIFI after you turned on the airplane mode.

The WIFI will be automatically turned off after you turned on airplane mode


Actually, I am confused that why the WIFI and airplane can be turned on at the same time.
Flags: needinfo?(whsu)
Retry the regression window against new information in comment 3
blocking-b2g: --- → koi?
Keywords: regressionwindow-wanted
(Reporter)

Comment 5

5 years ago
Sorry for the uncompleted reply.
-------------------------------------------
The WIFI will be automatically turned off after you turned on airplane mode.
But you can manually turn on WIFI again.

Comment 6

5 years ago
William,
Check the Invalid bugs for the similar issues
https://bugzilla.mozilla.org/show_bug.cgi?id=833242
https://bugzilla.mozilla.org/show_bug.cgi?id=833242

It's by design,after "Airplane mode" turned on a user is able to turn on Wi-Fi and Bluetooth manually,
and as I mentioned before, the crash report will be submitted when turning on Wi-Fi 
Removing the regression window as far I don't see the issue here
Keywords: regressionwindow-wanted
(Reporter)

Comment 7

5 years ago
Hi, Sarsenyev,

Could I double check a problem with you?
I saw the submitted folder was created.
But, I didn't see that the crash event was submitted to the following site while the WIFI and airplane mode are turned on at the same time.
https://crash-stats.mozilla.com/

Did you encounter the same problem?
Many thanks!
Flags: needinfo?(sarsenyev)

Comment 8

5 years ago
Hi William,
I didn't encounter the same issue as you do.
Here the steps have been taken.
1) Flash to the Build ID: 20130924004002
2) Turn on "Airplane" mode
Airplane mode automatically turns off Wi-Fi and Bluetooth
3) Manually turn on Wi-Fi
4) Launch the "calendar app"
5) Crash the "calendar" app with the command "adb shell kill -11 #calender PID#" (without quotes)
6) Run the command root@android:/data/b2g/mozilla/Crash Reports/submitted # ls -a
or navigate from "Eclipse" (data/b2g/mozilla/Crash Reports/submitted)
7) From "Eclipse" app click on the "pull a file from device" (icon in the right)
8) Save it to a desired folder
9) Open the "crash report" in the "notepad" from the folder 
10) Copy the "crash ID"
11) Paste into the search field on the website https://crash-stats.mozilla.com/

I checked with two crashes: one with airplane mode on and wi-fi on, the second with Wi-Fi on but airplane mode off, both worked as expected.
If it helps here is my crash ID's: Crash ID: bp-6bf31105-c148-4be9-9184-eccaa2130926, Crash ID: bp-cf12a966-23ec-484b-8380-0525a2130926

The result:
All crash reported are submitted
Flags: needinfo?(sarsenyev)
(Reporter)

Comment 9

5 years ago
Hi, Sarsenyev,

Thanks for your prompt help and detailed information.

So wired. I did the same reproduce steps above again.
Now, it works as expected.
After turning on the WIFI and airplane at the same time, the "submitted" folder can be created and the crash report was sent out.

I would like to close this bug.
Many thanks!
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME

Updated

5 years ago
blocking-b2g: koi? → ---
You need to log in before you can comment on or make changes to this bug.