citropia.net - Pretty JavaScript Mouse Trailer Fails

RESOLVED WONTFIX

Status

P4
major
RESOLVED WONTFIX
17 years ago
3 years ago

People

(Reporter: tommybee99, Unassigned)

Tracking

Details

(Whiteboard: [DYNAMICDRIVE][aok], URL)

(Reporter)

Description

17 years ago
My friend seems to think that her JavaScript rocks and Netscape sucks.  I think
she just doesn't code well.  *grin*

Expected:  A butterfly in the clouds trailing the cursor.

Actual:  The images all stack up in the upper left corner of the page.

Strangely enough, in Netscape Communicator 4.78, the cursor trail appears just
fine, but the page won't display at all.
Over to DOM0.

This is a dup, but I can't find the original.

The code uses a construct like this:

var foo = new dot(i)
function dot(i) {
  this.obj = document.getElementById("dot"+i).style;
}

The point is, it tries to create a new property by just setting it and this
fails. (put an 'alert(this.obj);' in the dot constructor to see that the setting
of this.obj does not work....
Whiteboard: DUPEME

Comment 2

17 years ago
This site uses insufficient browser-sniffing for Mozilla/N6, and 
non-W3C-compliant HTML. The site credits and uses the cursor-trail code 
from dynamicdrive.com:

      http://www.dynamicdrive.com/dynamicindex13/trailer2.htm


This code is valid for NN4.x, but not for a W3C-compliant browser
like Mozilla/N6.


EXAMPLES

1. the browser-sniffing: 

       var isNetscape = navigator.appName=="Netscape";

Without also including navigator.appVersion, you can't distinguish 
Mozilla/N6 from NN4.x


2. accessing elements like 

<div id="dot0" style=etc.>
  <img src="cloud1.gif" height=51 width=81>
</div>


is attempted as follows: 


function dot(i) 
{
    this.X = Xpos;
    this.Y = Ypos;
    this.dx = 0;
    this.dy = 0;
    if (isNetscape) {	
        this.obj = eval("document.dot" + i);  <<<<<<<<<< NOT IN MOZILLA/N6 !!!
    } else {
        this.obj = eval("dot" + i + ".style");
    }
}


To see this, key this into the Mozilla URL bar after loading the site :

    javascript: alert(typeof document.dot0);  ---> undefined

That's because in a W3C-compliant browser, you have to use this:

    javascript: alert(typeof document.getElementById("dot0"));  ---> object



etc. 
etc.
 

Comment 3

17 years ago
Reassigning to Evangelism component. The bigger fish here is the site
indicated above: 

                    http://www.dynamicdrive.com

Template code provided here gets utilized by many sites. If it doesn't work 
in Mozilla/N6, none of those sites will, either. The specific template

             http://www.dynamicdrive.com/dynamicindex13/trailer2.htm 

is the one being used here...
Assignee: rogerl → bclary
Status: UNCONFIRMED → NEW
Component: Javascript Engine → Evangelism
Ever confirmed: true
QA Contact: pschwartau → zach

Comment 4

17 years ago
Raising severity to major because of the influence of dynamicdrive.com
Severity: normal → major
Whiteboard: DUPEME → DUPEME Note: cursor-trail template is from dynamicdrive.com

Comment 5

17 years ago
Ok, putting dynamicdrive on the radar...
Blocks: 32221

Updated

17 years ago
Blocks: 92725

Comment 6

17 years ago
changed dynamicdrive tracking bug 92725
No longer blocks: 32221

Comment 7

17 years ago
All Evangelism Bugs are now in the Product Tech Evangelism. See bug 86997 for
details.
Component: Evangelism → US English
Product: Browser → Tech Evangelism
Version: other → unspecified

Updated

17 years ago
Priority: -- → P4
Summary: Pretty JavaScript Mouse Trailer Fails → citropia.net - Pretty JavaScript Mouse Trailer Fails

Updated

17 years ago
Whiteboard: DUPEME Note: cursor-trail template is from dynamicdrive.com → [DYNAMICDRIVE][aok]

Comment 8

17 years ago
Mass reassign of all tech-evangelism us general bugs assigned to bc to 
doron except bc's P1 bugs. You may search for this mass reassign (it is 
305 bugs) by searching for the keyword 'greeneggsandham'
Assignee: bclary → doronr

Comment 9

15 years ago
URL is 404 - does this site still have a problem?

Comment 10

15 years ago
tech evang june 2003 reorg
Assignee: doron → english-us
QA Contact: zach → english-us

Comment 11

14 years ago
The Citropia site no longer exists, and the only remaining valid evangalism is
against Dynamicdrive, which is tracked in bug 92725.  Can we resolve this bug
please?

Comment 12

14 years ago
Resolving Won't Fix
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WONTFIX
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.