Pages are blank with "Don't keep activities" enabled after opening page from Settings

RESOLVED DUPLICATE of bug 922329

Status

()

Firefox for Android
General
RESOLVED DUPLICATE of bug 922329
4 years ago
4 years ago

People

(Reporter: TeoVermesan, Assigned: bnicholson)

Tracking

27 Branch
ARM
Android
Points:
---

Firefox Tracking Flags

(firefox25 unaffected, firefox26 affected, firefox27 unaffected)

Details

(Reporter)

Description

4 years ago
Build: Firefox for Android 27.0a1 (2013-09-25)
Device: LG Nexus 4
OS: Android 4.2.2

Steps to reproduce:
1. Set "Don't keep activities" developer option to ON
2. Open Firefox and load any about:page (e.g about:telemetry)

Expected:
- about:pages should be displayed correctly

Actual:
- about:pages are blank
(Reporter)

Updated

4 years ago
status-firefox25: --- → unaffected
status-firefox26: --- → affected
status-firefox27: --- → affected
(Reporter)

Comment 1

4 years ago
Any other page besides about:home is affected. 
Please see the following video: http://www.youtube.com/watch?v=UEb-HKfvAqE

Updated

4 years ago
tracking-fennec: --- → ?

Updated

4 years ago
tracking-fennec: ? → 26+
Assignee: nobody → bnicholson
Keywords: regressionwindow-wanted
(Assignee)

Comment 2

4 years ago
Updating to reflect comment 1.

I've tried this on multiple devices, but I can't reproduce. It's been several weeks since this bug was filed; Teodora, are you still able to reproduce this?
Flags: needinfo?(teodora.vermesan)
Summary: about:pages are blank with "Don't keep activities" enabled → Pages are blank with "Don't keep activities" enabled
(Assignee)

Comment 3

4 years ago
Hm...well I can't reproduce this on Nightly, but I can reproduce on Aurora.

STR:
1) Enable Don't Keep Activities
2) Go to Settings
3) Click something that opens a page (Mozilla > About Aurora, Mozilla > View my Health Report, etc.)

After these STR, no page will be drawn (including non-about: pages).
status-firefox27: affected → unaffected
Summary: Pages are blank with "Don't keep activities" enabled → Pages are blank with "Don't keep activities" enabled after opening page from Settings
(Assignee)

Comment 4

4 years ago
This shows up in logcat following the STR:

[JavaScript Error: "TypeError: aJSON is null" {file: "chrome://browser/content/HelperApps.js" line: 136}]

Looks like a dupe of bug 922329.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 922329
(Assignee)

Updated

4 years ago
Flags: needinfo?(teodora.vermesan)
tracking-fennec: 26+ → ---
Keywords: regressionwindow-wanted
You need to log in before you can comment on or make changes to this bug.