Mail crashes on startup, bad memory reference

VERIFIED WORKSFORME

Status

SeaMonkey
MailNews: Message Display
--
critical
VERIFIED WORKSFORME
17 years ago
14 years ago

People

(Reporter: sidesinger.3, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0b; Windows NT 5.0)
BuildID:    2001072003

When I load mail, it loads the screen and then dies,
VC++ gives me this:
The instruction at "0x0012f73c" referenced memory at "0x000000000". The memory 
could not be "written".

If I run the VC++ debugger, a message window pops up and says:
Unhandled exception in mozilla.exe: 0xC00000005: Access Violation.

You have had this bug in the last few nightly builds.

I am running WIN2k Server w/ service pack 2.

Reproducible: Always
Steps to Reproduce:
1.Open mail
2.Wait about 10ns
3.Watch program die

Actual Results:  Program crashes hard.

Expected Results:  I get my mail and news.

runtime stack:
0012F71F   add         byte ptr [eax+32h],dl
0012F722   add         edi,dword ptr [eax-1]
0012F725   ???
0012F726   ???
0012F727   inc         dword ptr [esi]
0012F729   add         byte ptr [edx],dl
0012F72B   add         byte ptr [ecx],al
0012F72D   add         byte ptr [eax],al
0012F72F   add         byte ptr [eax],bl
0012F731   add         byte ptr [eax],al
0012F733   add         byte ptr [ebx+edx+67800h],ch
0012F73A   add         byte ptr [eax],al
CRASH!!!-->0012F73C   add         byte ptr [eax],al
0012F73E   add         byte ptr [eax],al
0012F740   imul        esp,dword ptr [eax+edx*8],60h
0012F744   cmp         al,0F7h
0012F746   adc         al,byte ptr [eax]
0012F748   push        es
0012F749   add         dword ptr [ebp+2],edx
0012F74C   add         byte ptr [eax],al
0012F74E   add         byte ptr [eax],al
0012F750   lock inc    eax
(Reporter)

Updated

17 years ago
OS: Windows NT → Windows 2000

Comment 1

17 years ago
added talkback log for this (I'm experiencing the same problems)

ACCIDENT ID: TB34359946e

Comment 2

17 years ago
i'm seeing crashes too on both aug 21 and 22 builds. I've submitted talkback
reports from both but don't have access to the stack yet
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 2000 → All

Comment 3

17 years ago
this happens for me on linux.
adding crash keyword
Keywords: crash

Comment 4

17 years ago
I just realized this was filed a month ago. I suspect both j.houwing and I have
a different crash than the original filer. I went back to an august 1 build
and mail works fine for me. (on linux).

Comment 5

17 years ago
I returned to august 17, and it works. But going to a august 21+ build crashes
my mail (3 mail, 4 news accounts).

Jesse
(Reporter)

Comment 6

17 years ago
This problem no longer occurs for me (reporter).

Comment 7

17 years ago
Isn't this a duplicate of bug 96282?

Comment 8

17 years ago
Problem doesn't occur for me either anymore...

Comment 9

17 years ago
resolving as worksforme based on previous comment.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
worksforme using build 2001-08-27-03 on Windows 2000.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.