Closed Bug 920588 Opened 6 years ago Closed 6 years ago

[B2g][Keyboard] Keyboard does not display when a text box is selected

Categories

(Firefox OS Graveyard :: Gaia::Keyboard, defect, blocker)

ARM
Gonk (Firefox OS)
defect
Not set
blocker

Tracking

(blocking-b2g:1.3+)

VERIFIED FIXED
blocking-b2g 1.3+

People

(Reporter: amaxwell, Assigned: GaryChen)

References

Details

(Keywords: regression, smoketest)

Attachments

(1 file)

22.01 KB, application/vnd.oasis.opendocument.text
Details
Attached file LogCat of issue
Description:
When user selects any text box the keyboard is not displayed and user is not able to write, search, or send using text

Repro Steps:
1) Updated to Buri Build ID: 
2) From homescreen select SMS and a recipient
3) Tap message box

Actual:
Keyboard is not displayed and user is unable to type a message

Expected:
Keyboard is displayed and user is able to type a message and send to recipients

Environmental Variables:
Device: Buri master/m-c Mozilla RIL
Build ID: 20130925040201
Gecko: 68d279364a8b
Gaia: 9c418e409b50f4d5526cefd70fecefdd6b4c7c23
Base Image: 20130912

Notes:
-Browser and all other text baxes are affected as well
-does not repro on v1.2
Seeing this as well on my device. Escalating to blocker level as this makes it almost impossible to smoketest the device.
Severity: normal → blocker
Rudy, is it something that you can help? Thanks!
Flags: needinfo?(rlu)
Regression window:

Keyboard Works:

Gaia   a22ba4a3a9efd99f94adf9ece8a2b391d4df295b
SourceStamp 1fda74e33e06
BuildID 20130924040201
Version 27.0a1

Keyboard Broken:

Build ID: 20130925040201
Gecko: 68d279364a8b
Gaia: 9c418e409b50f4d5526cefd70fecefdd6b4c7c23
Version 27.0a1
Can someone help with the backout here ?
fwiw, I can't repro with current b2g-inbound and gaia master. Could we merge inbound to m-c and respin?
(In reply to Marcia Knous [:marcia] from comment #3)
> Regression window:

https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=1fda74e33e06&tochange=68d279364a8b

The b2g-inbound -> m-c merge (rev c65a4d588933) does show some keyboard-related changes in the Gaia Pushbot pushes. Hopefully the bustage comes from that and not the 124-cset inbound merge below it...

(In reply to Fabrice Desré [:fabrice] from comment #5)
> fwiw, I can't repro with current b2g-inbound and gaia master. Could we merge
> inbound to m-c and respin?

b-i was closed for Gu bustage all morning. The backout is on b-i now and I will merge it to m-c as soon as Gu goes green. I'll update the bug when I do.
Naoki thinks bug 920394 might be the cause of this bug.
(In reply to Jason Smith [:jsmith] from comment #7)
> Naoki thinks bug 920394 might be the cause of this bug.

Or the fix for the issue, rather I mean.
Clarification - likely caused by bug 913782, fixed in bug 920394.
Blocks: 913782
If my analysis in comment 9 is right, then close this bug out.
Just merged b2g-inbound to m-c. Feel free to request new nightlies off m-c tip.
Just emailed rel eng to ask for a respin.
I just spot checked the build that came out in the nightly directory: https://pvtbuilds.mozilla.org/pvt/mozilla.org/b2g_ril/hamachi-mozilla-central-20130925174530-ril01.02.00.019.056.zip

name="platform_build" path="build" remote="b2g" revision="02dfd85cef0be11e3e08628ea317d70abaccb80f

The keyboard still is not functional in this build:

Gaia   7e42b4d690049709c62e8783910f16ab20869f42
SourceStamp fa0e6916f88c
BuildID 20130925174530
Version 27.0a1
so did the forward fix in bug 920394, not help here ?

I am NI, :GaryChen as well to see if we can help here.
Flags: needinfo?(gchen)
(In reply to bhavana bajaj [:bajaj] from comment #14)
> so did the forward fix in bug 920394, not help here ?
> 
> I am NI, :GaryChen as well to see if we can help here.

I confirm on the same build that marcia used in comment 13, that no keyboard appears.

09-25 18:32:52.349: E/GeckoConsole(139): [JavaScript Error: "TypeError: self.keyboardLayouts[group] is undefined" {file: "app://system.gaiamobile.org/js/keyboard_manager.js" line: 237}]
I cannot reproduce this with the build in Comment 13,
My steps:
  1. Download https://pvtbuilds.mozilla.org/pvt/mozilla.org/b2g_ril/hamachi-mozilla-central-20130925174530-ril01.02.00.019.056.zip
  2. run ./fullflash_gecko_ril_gaia.sh
  3. Try to click a input field => Can see the keyboard pop up

Still working with QAs to find out what build configuration might be different in my test.
Flags: needinfo?(rlu)
backout commit 4bbd185 and 51eb595 on gaia master
https://github.com/mozilla-b2g/gaia/commit/73460187f0db40198dee1592a441076b29f2c850
Assignee: nobody → gchen
Status: NEW → RESOLVED
Closed: 6 years ago
Flags: needinfo?(gchen)
Resolution: --- → FIXED
Hi all,

After checking the same build as stated in Comment 17, we can reproduce this issue with the following steps,

 1. Go to settings app > Keyboards 
 2. Click "Selected keyboards"
 3. Exit seetings app and find a input field, like in Browser app
    => The keyboard won't show up

This issue seems to be caused by bug 913782.

Gary helped to back out both bug 913782 and bug 920394 (a follow-up) and we're going to work on a fix for this issue.

Thanks and sorry for any inconvenience caused.
(In reply to Rudy Lu [:rudyl] from comment #19)
> Hi all,
> 
> After checking the same build as stated in Comment 17, we can reproduce this
> issue with the following steps,
> 
>  1. Go to settings app > Keyboards 
>  2. Click "Selected keyboards"
>  3. Exit seetings app and find a input field, like in Browser app
>     => The keyboard won't show up
> 
> This issue seems to be caused by bug 913782.
> 
> Gary helped to back out both bug 913782 and bug 920394 (a follow-up) and
> we're going to work on a fix for this issue.
> 
> Thanks and sorry for any inconvenience caused.

Thank you Rudy and Gary.   I'll see if we can spin up another m-c build so testers can resume with their work.
Flashing to a previous good build:
Gaia   9c418e409b50f4d5526cefd70fecefdd6b4c7c23
SourceStamp 68d279364a8b
BuildID 20130925040201
Version 27.0a1

and flashing to:
Gaia   fc222c4fb720d97ce3933e3f8891498c9c3f49b3
SourceStamp e85b0372cece
BuildID 20130926040202
Version 27.0a1

Keyboard functions normally when text boxes are selected.

Verifying issue as fixed.
Status: RESOLVED → VERIFIED
Blocking+ for smoketest regression
blocking-b2g: 1.3? → 1.3+
You need to log in before you can comment on or make changes to this bug.