Support HTML5 Gamepad events

RESOLVED DUPLICATE of bug 852935

Status

()

Firefox for Android
General
RESOLVED DUPLICATE of bug 852935
4 years ago
4 years ago

People

(Reporter: wesj, Assigned: Mina Almasry)

Tracking

Trunk
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
We should ship gamepad events from the system over to Gecko. Should be pretty simple, although our handling of gamepad events in java for panning may make for some strange interactions.
(Reporter)

Updated

4 years ago
Summary: Supper HTML5 Gamepad events → Support HTML5 Gamepad events
This is probably a straight up dupe of bug 852935
(Assignee)

Comment 2

4 years ago
I'm not sure I understand. Could you please elaborate what exactly is needed and where do I start with it? Thanks!
Flags: needinfo?(wjohnston)
Flags: needinfo?(bugmail.mozilla)
(Reporter)

Comment 3

4 years ago
(In reply to Kartikaya Gupta (email:kats@mozilla.com) from comment #1)
> This is probably a straight up dupe of bug 852935

I agree.

Mina, this bug would mean that we grab MotionEvent from gamepads in java and send them over to the Gecko widget layer where they could be converted to HTML5 Gamepad events and redispatched.  To see something similar, see how touch events are picked up in Java:
http://mxr.mozilla.org/mozilla-central/source/mobile/android/base/gfx/LayerView.java#165

then send over to widget:
http://mxr.mozilla.org/mozilla-central/source/widget/android/nsWindow.cpp#847

where they're eventually sent off into the wild blue yonder of the platform:
http://mxr.mozilla.org/mozilla-central/source/widget/android/nsWindow.cpp#1316

in this case you'd be generating gamepad events rather than mouse:
http://mxr.mozilla.org/mozilla-central/source/widget/BasicEvents.h#447
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(wjohnston)
Resolution: --- → DUPLICATE
Duplicate of bug: 852935
Flags: needinfo?(bugmail.mozilla)
(Assignee)

Updated

4 years ago
Assignee: nobody → malmasry
(Assignee)

Comment 4

4 years ago
Hehe wes I don't think you resolved this by providing the info for me needinfo flag :P
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Assignee)

Comment 5

4 years ago
oops nevermind
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 852935
You need to log in before you can comment on or make changes to this bug.