[B2G][Contacts] The text "No Contacts Found" will overlap contact names if a user types text into the search bar and clicks on a contact at the same time

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::Contacts
RESOLVED WORKSFORME
4 years ago
3 years ago

People

(Reporter: KTucker, Unassigned)

Tracking

(Blocks: 1 bug)

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g18 affected, b2g-v1.2 affected)

Details

(Whiteboard: burirun1)

Attachments

(1 attachment, 1 obsolete attachment)

Created attachment 810013 [details]
searchcontacts.wlmp

Description:
If a user quickly taps on a listed contact while inputting text into the search contacts text field, overlapping text will occur.

Repro Steps:
1)  Updated to Buri Build ID: 20130924004002
2)  Tap on the "Contacts" icon. 
3)  Add different contacts that being with the letter "a".
4)  After adding the contacts, type the letter "a" in the contact search text field.
5) Start typing random letters after the letter "a" into the search contacts text field but tap on a contact name in the list at the exact same time before the contact disappears from the list.

Actual:
Contact names will overlap the text "No Contacts Found".

Expected:
Contact names will not overlap the text "No Contacts Found" when doing a contact search and tapping on a contact on the list at the same time.

Environmental Variables
Build ID: 2013092400400
Gecko: http://hg.mozilla.org/releases/mozilla-aurora/rev/b34384409be6
Gaia: a13c76f8d3c617ee57c302c103da04ed1a6298d1
Platform Version: 26.0a2

Notes:
Repro frequency: (100%)
See attached: (video clip)
Created attachment 810134 [details]
searchcontacts.mp4
Attachment #810013 - Attachment is obsolete: true
This needs a simpler STR to block. Can you provide a simpler STR?

Updated

4 years ago
QA Contact: gbennett

Updated

4 years ago
QA Contact: gbennett

Updated

4 years ago
QA Contact: gbennett

Comment 3

4 years ago
- Does not repro - 6/24
Environmental Variables
Device: Buri 1.2 mozRIL
Build ID: 20130624031223
Gecko: http://hg.mozilla.org/mozilla-central/rev/76820c6dff7b
Gaia: 59c7f4a59157a0bc1c45d705294395f988c509b2
Platform Version: 24.0a1

- Does Repro - 7/1
Environmental Variables
Device: Buri 1.2 mozRIL
Build ID: 20130701031306
Gecko: http://hg.mozilla.org/mozilla-central/rev/d7553251cf43
Gaia: 1ab1a866549e7b8644a9f51ef76d984a82ea8612
Platform Version: 25.0a1

Builds between 6/24 and 7/1 have various blocking issues preventing repro.

Alternate repro step #3: Import facebook contacts (150+, I used my personal account)

While one can use the origional step #3, importing FB contacts has given me a 100% repro for this bug while before it was only around 40%.
Keywords: regressionwindow-wanted

Updated

4 years ago
Blocks: 921979
Can you double check if this reproduces on 1.1? The regression range seems to imply this could be present on 1.1.
Keywords: regression → qawanted

Comment 5

4 years ago
This issue is present on Leo 1.1 Moz RIL.

As stated in Comment 3, the repro rate does seem much higher when there are more contacts on the device.  I also reproduced the issue after importing contacts from Facebook. In total when combined with the contacts already on the device, there were around 200.

Environmental Variables:
Device: Leo v1.1 Mozilla RIL
BuildID: 20131015041203
Gaia: 680f3b86b1e4ff1411ece6ba397b8b0e56b4b31c
Gecko: 4bfd6a51cd05
Version: 18.0
Firmware Version: D300f10a
Keywords: qawanted

Updated

4 years ago
status-b2g18: unaffected → affected
I am not able to reproduce this one anymore
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
Resolution: INVALID → WORKSFORME
You need to log in before you can comment on or make changes to this bug.