Bouncer automated test suite is failing indicating a problem

RESOLVED FIXED

Status

Infrastructure & Operations Graveyard
WebOps: Product Delivery
--
blocker
RESOLVED FIXED
5 years ago
2 years ago

People

(Reporter: bsilverberg, Assigned: cturra)

Tracking

Details

(Reporter)

Updated

5 years ago
Severity: normal → blocker
(Assignee)

Comment 2

5 years ago
grabbing bug to triage.
Assignee: server-ops-webops → cturra
OS: Mac OS X → All
Hardware: x86 → All
(In reply to Bob Silverberg [:bsilverberg] from comment #1)
> Also a second failing test at:
> http://qa-selenium.mv.mozilla.com:8080/job/bouncer.prod/7408/testReport/
> junit/tests.test_redirects/TestRedirects/
> test_redirect_for_firefox_aliases_product_alias2_/

The test  has hardcoded links to some of the CDN's, it is failing because it thinks http://download-akamai.cdn.mozilla.net. We need to change the test to check the status code returned instead of checking the links.
(Assignee)

Comment 4

5 years ago
as discussed on irc, i think the test should use download.cdn.mozilla.net instead of the akamai direct cdn url because we actually load balancer our CDNs. can we update the test to use that?

i have been running some manual testing on my end and haven't been able to reproduce this myself - tho, my tests are nowhere near as complete as this test suite.
Submitted https://github.com/mozilla/bouncer-tests/pull/41. We already check that the correct status codes are returned so I removed the hard-coded link checks for download.cdn.mozilla.net and edgecast.net.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Product: Infrastructure & Operations → Infrastructure & Operations Graveyard
You need to log in before you can comment on or make changes to this bug.