Closed Bug 920807 Opened 9 years ago Closed 8 years ago

Panel shows insertion point in non-editable text

Categories

(Add-on SDK Graveyard :: General, defect, P3)

x86_64
Windows 7
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 980714

People

(Reporter: blakeyrat, Assigned: irakli)

Details

(Keywords: testcase)

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/29.0.1547.76 Safari/537.36

Steps to reproduce:

Using the AddOn API:

1) Create a simple AddOn that opens a Panel when the icon in the AddOn bar is pressed
2) Create simple HTML content for the Panel
3) Click the icon to open the Panel

In this case, the Panel HTML is as follows:

<!DOCTYPE html>
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
	<title>Settings Panel</title>
    
    <link href='https://fonts.googleapis.com/css?family=Open+Sans' rel='stylesheet' type='text/css'>
    
    <style>
        body{
            font-family: 'Open Sans', sans-serif;
            font-size: 15px;
            -moz-user-select: none;
        }
    </style>
</head>
<body>
	<input id="overlay-check" type="checkbox" /><label for="overlay-check">Overlay On</label>
	<br />
	<input id="heatmap-colors" name="headmap-radio" type="radio" checked="checked" disabled="disabled" /><label for="heatmap-colors"><img src="settings-icon-heatmap.png" />
		Heatmap</label>
	<br />
	<input id="heatmap-confetti" name="headmap-radio" type="radio" disabled="disabled" /><label for="heatmap-confetti"><img src="settings-icon-confetti.png" />
		Confetti</label>
	<hr />
	<input id="article-ranking-check" type="checkbox" /><label for="article-ranking-check"><img src="settings-icon-ranking.png" />
		Link Ranking</label>
	<hr />
	<input id="dashboard-check" type="checkbox" /><label for="dashboard-check"><img src="settings-icon-dashboard.png" />
		Dashboard</label>
</body>
</html>



Actual results:

The panel shows the insertion point, even though all of the text in it is read-only.

Also note that the Panel documentation says "Its content is specified as HTML", but an HTML page with the same content would not show an insertion point.


Expected results:

Since the text is not editable, there should be no insertion point.
Could you attach a testing add-on, so se wan test and debug.
Flags: needinfo?(blakeyrat)
Keywords: testcase-wanted
Here's a link (I think...?) to a public add-on created using the Add-on Builder website that demonstrates the issue: https://builder.addons.mozilla.org/user/10218413/

To repro the issue:
1. Press the "test" button to install the AddOn.
2. Click the red ladybug icon in the AddOn Bar.
3. Click some empty space in the Panel (clicking directly below the word "panel" works).
4. The insertion point will appear to the right of the word "no".

A workaround, if one exists, would also be greatly appreciated. This is driving my designer nuts, and no combination of HTML and CSS I can find can get rid of that damned insertion point.
Flags: needinfo?(blakeyrat)
Component: Untriaged → General
Product: Firefox → Add-on SDK
Version: 24 Branch → unspecified
Assignee: nobody → rFobic
Priority: -- → P3
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 980714
You need to log in before you can comment on or make changes to this bug.