Stuck on credit card page on Android

RESOLVED FIXED

Status

Marketplace
Payments/Refunds
P2
normal
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Andy McKay, Assigned: Keir Kettle)

Tracking

x86
Android
Points:
---

Details

Attachments

(3 attachments)

(Reporter)

Description

5 years ago
When buying an app on Android, I get stuck at the credit card page. The Buy button never activates (even after I've typed in all my details, which I didn't show).

http://www.flickr.com/photos/43096515@N00/9941338035/

I've connected a debugger, but don't see any javascript errors coming through.
(Reporter)

Updated

5 years ago
OS: Mac OS X → Android
Summary: Stuck on Buy page on Android → Stuck on credit card page on Android
(Reporter)

Updated

5 years ago
Priority: -- → P2

Comment 1

5 years ago
Andy, is this on Marketplace staging? I will go through this with Tom but could do with a little more info so I can recreate this scenario
FWIW, I was able to make a purchase on Android with carrier billing (using a Movistar SIM and Android ICS). I got up to bug 924693
I see the same thing here when attempting a credit card purchase on Android ICS
Here are the steps to reproduce this:

- Install Firefox Nightly on an Android device (use at least ICS)
- Install this add-on to activate payments prefs: http://mzl.la/19BZQCx, from https://addons.mozilla.org/en-US/firefox/addon/dev-marketplace/ (source: https://github.com/wesj/devMarketplace)
- Open https://marketplace.allizom.org in Firefox Nightly
- Type this special string in the search box: ':paid'
- Tap one of the apps with a price (not a free app). If you don't see any, here is an app to buy: http://bit.ly/1hAE0ll
- Log in with persona / verify email
- Create/Confirm a PIN code
- Go through the Bango Confirm your mobile phone screen
- Choose to pay with credit card

Comment 5

5 years ago
I asked Steve previously but he hasn't come back to me.

Kumar, I followed the steps to reproduce but when I searched for :paid it brought up one app that was free but refused to be downloaded (kept failing with installation failure). 

How do I see paid-for apps in order to reproduce this issue?
(Reporter)

Comment 6

5 years ago
Presuming you were trying: http://bit.ly/1hAE0ll, do you have any more information on the failure? Did you even get to the PIN screens?

Can I confirm that you installed: https://addons.mozilla.org/en-US/firefox/addon/dev-marketplace/ on Firefox Nightly?

That's required for you to get to the PIN screen.

What version of Android were you using?

Comment 7

5 years ago
No, I was never shown any paid-for apps. I was only shown 1 free app even though I searched :paid. As a result I didn't need to go through the payment flow but having said that, I didn't key in a PIN either. See attached screenshot of the issue I have with searching and also the resultant error downloading.

I am on android 4.1.2 on a Samsung Galaxy S3.

Comment 8

5 years ago
Created attachment 823429 [details]
Screenshot_2013-10-28-17-03-38.png

Comment 9

5 years ago
Created attachment 823430 [details]
Screenshot_2013-10-28-17-03-38.png

Comment 10

5 years ago
Created attachment 823431 [details]
Screenshot_2013-10-28-17-01-56.png
(Reporter)

Comment 11

5 years ago
Does this link as mentioned in comment 4 get you to a paid app: http://bit.ly/1hAE0ll

Comment 12

5 years ago
I can now replicate this issue so we will investigate as to why this is not working on Android. It is strange considering nothing has changed on CC and it still works on normal Mozilla devices.
Tom - 
Any progress on this one?
Flags: needinfo?(tom)

Comment 14

5 years ago
We are in the process of fixing this one. Not sure of a live date for this because we need to be certain it doesn't affect the rest of credit card transactions.

Updated

5 years ago
Flags: needinfo?(tom)
(Reporter)

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.