AssertionError: Section 'test_temporaryFilesRemoved.js' already found

RESOLVED DUPLICATE of bug 920418

Status

Firefox Build System
General
RESOLVED DUPLICATE of bug 920418
5 years ago
5 months ago

People

(Reporter: ISHIKAWA, Chiaki, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 810417 [details] [diff] [review]
Remove duplicate line at the end.

During configuration of thunderbird (comm-central), I get the following error.

AssertionError: Section 'test_temporaryFilesRemoved.js' already found in 'set(['test_bug235432.js', 'DEFAULT', 'test_attachment.js', 'test_smtpPasswordFailure2.js', 'test_sendMessageFile.js', 'test_nsMsgCompose2.js', 'test_detectAttachmentCharset.js', 'test_saveDraft.js', 'test_smtpPasswordFailure3.js', 'test_splitRecipients.js', 'test_temporaryFilesRemoved.js', 'test_sendMailAddressIDN.js', 'test_sendMessageLater2.js', 'test_smtpPasswordFailure1.js', 'test_bug155172.js', 'test_smtpPassword.js', 'test_nsSmtpService1.js', 'test_smtpURL.js', 'test_sendMailMessage.js', 'test_sendBackground.js', 'test_attachment_intl.js', 'test_smtpAuthMethods.js', 'test_smtpPassword2.js', 'test_nsMsgCompose1.js', 'test_mailtoURL.js', 'test_sendMessageLater.js', 'test_nsMsgCompose3.js', 'test_sendMessageLater3.js', 'test_smtpProtocols.js', 'test_staleTemporaryFileCleanup.js', 'test_bug474774.js'])'

It looks that the same test file is specified twice.

Patch is attached.
(Reporter)

Comment 1

5 years ago
After this patch, the configure proceeded.
But somehow it began regenerating the backend repeatedly and
it didn't proceed further.

   ....
Reticulating splines...
Finished reading 1216 moz.build files into 4379 descriptors in 1.64s
Backend executed in 1.62s
2403 total backend files. 0 created; 0 updated; 2413 unchanged
Total wall time: 5.21s; CPU time: 5.19s; Efficiency: 100%
Build configuration changed. Regenerating backend.
Reticulating splines...
Finished reading 1216 moz.build files into 4379 descriptors in 1.63s
Backend executed in 1.63s
2403 total backend files. 0 created; 0 updated; 2413 unchanged
Total wall time: 5.21s; CPU time: 5.19s; Efficiency: 100%
Build configuration changed. Regenerating backend.
Reticulating splines...
Finished reading 1216 moz.build files into 4379 descriptors in 1.65s
Backend executed in 1.61s
2403 total backend files. 0 created; 0 updated; 2413 unchanged
	.... this repeats forever ...

I am not sure if this is a particular issue on my own (improper version of python, etc.). 
If not, I will file a bug.

TIA

(PS:

ishikawa@debian-vbox-ci:/extra/ishikawa/download/TB-3HG/NEW-COMMSRC$ python --version
Python 2.7.5+

I tried to look into the issue, but it seems some scripts under mozilla directory (m-c) 
is doing something funny(?)
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 920418

Updated

5 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.