[Contacts] Export progress in inconsistent across sinks

RESOLVED INVALID

Status

Firefox OS
Gaia::Contacts
RESOLVED INVALID
5 years ago
4 years ago

People

(Reporter: Jose Manuel Cantera, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [u=commsapps-user c=contacts p=0])

(Reporter)

Description

5 years ago
The export progress screens are inconsistent across sinks. SIM export is using progress candy bar whilst Memory Card and Bluetooth seem to be using spinner.

I think they should be all progress candy bars indicating the number of items as it is progressing.

Updated

5 years ago
Whiteboard: [u=commsapps-user c=contacts p=0]
That has been done by design.

In the case of the SIM, we do have a progress, cause we iterate over the contacts as we save them to the sim card.

In the case of bluetooth, everything happens in a single operation, same than exporting to the sdcard.

That was added by design, having export mechanism that are deterministic (you know when and how many and when they finish), and other non deterministics (a single operation)
Just in case is not clear in comment 1, I don't think this is a bug :)
removing koi? tag per comment 2 and asking "ni?" to José Manuel to confirm that we all are in the same page. Thank!
blocking-b2g: koi? → ---
Flags: needinfo?(jmcf)
(Reporter)

Comment 4

4 years ago
oh yes. I talked yesterday to Francisco about this.
Flags: needinfo?(jmcf)
Per comment 1 and comment 4 marking this bug as RESOLVED INVALID
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.