All users were logged out of Bugzilla on October 13th, 2018

Call Status Bar. Polish layout

VERIFIED FIXED

Status

VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: vicky, Assigned: rik)

Tracking

unspecified
x86
Mac OS X

Firefox Tracking Flags

(blocking-b2g:koi+, b2g-v1.2 fixed)

Details

(Whiteboard: [u=commsapps-user c=dialer p=0] burirun2)

Attachments

(7 attachments, 1 obsolete attachment)

(Reporter)

Description

5 years ago
Created attachment 810606 [details]
Visual: callStatusbar withname

Call status bar implementation needs polish. Please follow this designs and specs
(Reporter)

Comment 1

5 years ago
Created attachment 810611 [details]
callStatusBar_withnumber_
(Reporter)

Comment 2

5 years ago
Created attachment 810612 [details]
Visual Design: callStatusbar onhold status
(Reporter)

Comment 3

5 years ago
Created attachment 810613 [details]
SPECS callstatusBar
(Reporter)

Comment 4

5 years ago
Created attachment 810615 [details]
Phone icons in the small size, please replace the previous ones with this.
(Reporter)

Updated

5 years ago
Whiteboard: [u=commsapps-user c=dialer p=0]
(Reporter)

Updated

5 years ago
Blocks: 920625
(Assignee)

Comment 5

5 years ago
Requesting koi? because this is about finishing the conference call user story. I'll work on it alongside bug 918534.
Assignee: nobody → anthony
Blocks: 908679
blocking-b2g: --- → koi?
No longer blocks: 920625
(Assignee)

Comment 6

5 years ago
We can't do the translucent bar for the moment because the apps are being resized to not be under the double-sized status bar. If we did translucent, pixels 1-20 would be the status bar, pixels 21-40 would be the phone background. Is it ok with a full black?

BTW, it's really useful to see the values of the spacing, fonts, color values.
(Reporter)

Comment 7

5 years ago
Hi Anthony,
Thats a good point. Full black doesn't sound the best option, if it needs to be opaque, please use #333333 (our darkest grey) as background color.

Thanks!
V
should this be a meta bug with smaller bug created per screenshot?
(Reporter)

Updated

5 years ago
Summary: Call Status Bar. Polish layout → [Meta] Call Status Bar. Polish layout
(Reporter)

Updated

5 years ago
blocking-b2g: koi? → ---
(Reporter)

Updated

5 years ago
Depends on: 923052
(Reporter)

Updated

5 years ago
Attachment #810615 - Attachment is obsolete: true
(Reporter)

Updated

5 years ago
Depends on: 923053
(Reporter)

Updated

5 years ago
Depends on: 923020
(Assignee)

Comment 9

5 years ago
For this particular bug, it's actually easier to work with only one bug so I'll gather all resources in this one and close the other bugs.
blocking-b2g: --- → koi?
(Assignee)

Updated

5 years ago
Duplicate of this bug: 923052
(Assignee)

Comment 11

5 years ago
Created attachment 813521 [details]
Call status bar ICONS.zip
(Assignee)

Updated

5 years ago
Duplicate of this bug: 923053
(Assignee)

Updated

5 years ago
Duplicate of this bug: 923020
(Assignee)

Comment 14

5 years ago
Created attachment 813523 [details]
blue_paused_callicon.zip
(Assignee)

Updated

5 years ago
No longer depends on: 923020, 923052, 923053
Summary: [Meta] Call Status Bar. Polish layout → Call Status Bar. Polish layout
(Assignee)

Comment 15

5 years ago
Created attachment 813630 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/12658

Pointer to Github pull-request
(Assignee)

Updated

5 years ago
Attachment #813630 - Flags: review?(etienne)
(Assignee)

Updated

5 years ago
Duplicate of this bug: 918534
Comment on attachment 813630 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/12658

r=me with the small naming nit addressed.
Attachment #813630 - Flags: review?(etienne) → review+
https://github.com/mozilla-b2g/gaia/commit/f1c62186e214febd92b72c148289c48b4bcff204
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Updated

5 years ago
Whiteboard: [u=commsapps-user c=dialer p=0] → [u=commsapps-user c=dialer p=0] burirun2
Not a release block, please ask for approval.
Flags: needinfo?(anthony)
Removing koi? flag per comment 19
blocking-b2g: koi? → ---
(Assignee)

Comment 21

5 years ago
Re-requesting koi+ since the status bar is in a very bad shape without this patch as can be seen in attachment 807469 [details].
blocking-b2g: --- → koi?
Flags: needinfo?(anthony)
(Assignee)

Updated

5 years ago
blocking-b2g: koi? → ---
Duplicate of this bug: 914917
rik - I'm confused here. The bug you duped to this is a blocker, but this isn't. How are we intending to fix bug 914917 if this isn't a blocker?
(Assignee)

Comment 24

5 years ago
Jason: I re-requested koi+ in comment 21 but with whatever magic voodoo, I cancelled that request 2 hours later… So I'm re-re-requesting :)
blocking-b2g: --- → koi?
(In reply to Anthony Ricaud (:rik) from comment #24)
> Jason: I re-requested koi+ in comment 21 but with whatever magic voodoo, I
> cancelled that request 2 hours later… So I'm re-re-requesting :)

Glitch with this weekends tracking flag migration on BMO that cause some flags to be cleared when duping bugs. Thanks for putting the flag back right for us.

dkl
blocking-b2g: koi? → koi+
oups mistake back to koi?
blocking-b2g: koi+ → koi?

Updated

5 years ago
Duplicate of this bug: 928025
blocking-b2g: koi? → koi+
Uplifted f1c62186e214febd92b72c148289c48b4bcff204 to:
v1.2: 30943bc9ba7c0eb4fb1859f62c4168c90e3f0831
status-b2g-v1.2: --- → fixed

Comment 29

5 years ago
Checked with Victoria.
Call status bar is shown correctly now.

Verified on 10/25 v1.2 build:
Gecko-9150851
Gaia-606517c
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.