[Devices][User Story] Camera viewfinder cropping

RESOLVED WONTFIX

Status

Firefox OS
Gaia::Camera
RESOLVED WONTFIX
5 years ago
4 years ago

People

(Reporter: bhuang, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User story:
As a user, I want the camera viewfinder to accurately reflect exactly what image will be captured so that I can line up my shots perfectly.
(Reporter)

Updated

5 years ago
Blocks: 905003
No longer blocks: 905003
It is by design that we fill the viewfinder with the preview stream. On some deices this will be the exact aspect ratio of the image, on others the preview stream will spill over the edges a small amount.

This is a configurable setting that can be changed in js/config/config.js under 'viewfinder'. Accepts 'fit' or 'fill'.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.