[basket] Send updated Mozillians.org email address to Exact Target

REOPENED
Assigned to

Status

Participation Infrastructure
Phonebook
REOPENED
5 years ago
3 years ago

People

(Reporter: Jessilyn Davis, Assigned: dpoirier)

Tracking

2014-04.4
Dependency tree / graph

Details

(Whiteboard: [kb=1129332] )

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Now that Mozillians can update their email address in their Mozillians account (Bug 909324) - we need to make sure that a vouched Mozillians's new email address is updated in Exact Target so they'll get the important Mozilla emails to their updated email address. Ideally, we'd get this in place shortly after the email update functionality is live so we don't lose people's email addresses in transition. 

When a vouched Mozillian changed their email address 2 API calls need to be made to basket + Exact Target:

1) Find the old email address, and change the MOZILLA_PHONE_FLG to N
2) Send the new email address to basket with the MOZILLA_PHONE_FLG to Y


Basket docs:
https://github.com/mozilla/basket/blob/master/README.rst

We're in #newsletter if you have any questions.

Thanks!

Jess

Updated

5 years ago
OS: Mac OS X → All
Hardware: x86 → All
Whiteboard: [kb=1129332]
Depends on: 920270
(Assignee)

Updated

5 years ago
Depends on: 742951
(Reporter)

Comment 2

5 years ago
Hey Dan - I thought we separated Bug 742951 as a separate process? This bug for mozillians updating email address would simply unsubscribe the old mozillian's email address, and subscribe the new email address as a mozillian. Since the whole process takes place behind a login, I don't think there needs to be the confirm process.
(Assignee)

Comment 3

5 years ago
Oh okay, unsub old and subscribe new address should work fine, I'll remove the dependency on 742951.
No longer depends on: 742951
Summary: Send updated Mozillians.org email address to Exact Target → [basket] Send updated Mozillians.org email address to Exact Target
(Assignee)

Comment 4

5 years ago
Adding dependency on 9481017 - this'll be much easier to implement if we can get back tokens immediately when we do subscriptions.
Depends on: 948017
(Reporter)

Updated

5 years ago
Duplicate of this bug: 977315
(Assignee)

Comment 6

5 years ago
Starting on this.
Assignee: nobody → dpoirier
Status: NEW → ASSIGNED
(Assignee)

Updated

5 years ago
Depends on: 977683
(Assignee)

Comment 7

5 years ago
Created attachment 8383244 [details] [review]
Pull request
Jessilyn,

to make sure that I understand correctly:
 
 * User has 3 subscriptions including a subscription to mozillians.org with email foo@example.com
 * User changes his email address on mozillians to bar@example.com
 * We should unsubscribe foo@example.com from mozillians.org 
 * We should subscribe bar@example.com to mozillians.org 
 * foo@example.com should still be subscribed to 2 newsletters

Is this correct?
Flags: needinfo?(jdavis)
Jessilyn can you please verify that what described in comment 8 is the expected behavior?
Duplicate of this bug: 995531
(Reporter)

Comment 11

4 years ago
Hello! I apologize for the delay. I had to think through this a few more times.

(In reply to Giorgos Logiotatidis [:giorgos] from comment #8)
> Jessilyn,
> 
> to make sure that I understand correctly:
>  
>  * User has 3 subscriptions including a subscription to mozillians.org with
> email foo@example.com
>  * User changes his email address on mozillians to bar@example.com
>  * We should unsubscribe foo@example.com from mozillians.org 
>  * We should subscribe bar@example.com to mozillians.org 
>  * foo@example.com should still be subscribed to 2 newsletters
> 
> Is this correct?

This is correct. This is not a perfect solution, but is the best/simplest fix for now. Otherwise, the only way to get a mozillian's email address updated and subscribed to the mozillians newsletter is to manually email me. And then I query, export, reimport, and confirm that it's been updated - which takes about 10 min per entry.

This is the caveat that will happen with this fix:

* bar@example.com will have a different token than foo@example.com
* the user will get mozillians emails to their new email address (bar@example.com), but will still get their other newsletters to their old (unused, possibly now bad) email address (foo@example.com)
* user will be able to unsubscribe their old email address from other newsletters
* user will be able to subscribe their new email address to other newsletters - unless it is Student Ambassadors, Mozillians, Marketplace, Firefox OS User, <insert more list/segments for the future>, as these lists are only allowed for signup at time of registration (you cannot subscribe to these programs from the email preference center, you can only unsubscribe from them if you are currently subscribed to them).


This caveat will be prevented/fixed when these bugs are solved:
Allowing update of email address from email preference center: Bug 742951 
Preventing dupes (right now token is the unique identifier and someone can have 1 email address associated with 2 different tokens): Bug 871774
Integration with CRM


(PS - Let me know if you're interested in helping me & pmac solve the data architecture problem with Basket + Exact Target + Mozillians & other email programs in the bugs listed above.)
Flags: needinfo?(jdavis)
Thanks for the confirmation Jessilyn.

Comment 13

4 years ago
Commits pushed to master at https://github.com/mozilla/mozillians

https://github.com/mozilla/mozillians/commit/b120034faeda3b12cc3570efb760ef5b7c84bec9
[bug 921107] Update email in exact target

When someone changes their email in Mozillians.org, move their exact
target subscriptions to the new email address.

Also take advantage of new basket subscribe(sync=Y) to simplify
the update tasks.

https://github.com/mozilla/mozillians/commit/49528984e279121b3d5435b9324d0805a60ba0f3
[fix bug 921107] Update email in Exact Target.

https://github.com/mozilla/mozillians/commit/796fe0d6088f4736327a0adbc5c48b14917b9abb
Merge pull request #872 from glogiotatidis/921107

[Fix bug 921107] Update email in exact target

Updated

4 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED

Updated

4 years ago
Version: other → next
I just changed my email address on staging and on prod. I have the same basket token on each environment. 

In both cases the email change worked fine.

In both cases, the basket API responded with the same information before and after the change. 

In neither case did the email change...
* cause my email to change in the basket API response
* cause a new token to appear in the basket API response

Here are the steps I took to test:

1) change email address in Mozillians profile edit screen
2) use httpie[0] to make a request like this: http --follow https://basket.mozilla.org/news/user/{{TOKEN}}/

{{TOKEN}} above and below is the basket token you can see when you visit a userprofile in /admin

Here's the response I got from basket:

{
    "confirmed": true,
    "country": "us",
    "created-date": "12/1/2012 7:29:27 PM",
    "email": "error@mozilla.com",
    "format": "H",
    "lang": "",
    "master": true,
    "newsletters": [],
    "pending": false,
    "status": "ok",
    "token": "{{TOKEN}}"
}

Based on this, I don't think the fix is doing what it should. But I have an imperfect understanding of this functionality. In any event, the fix doesn't seem to make things worse, so we could launch the current code and continue working on it.
Changing my email works(I get a new token, which correctly returns the new email). I don't, however, have a token that is associated with error@mozilla.com.

I'm not sure this is a problem with our code, it might be basket and those old tokens. I don't think this issue blocks release.
(Reporter)

Comment 17

4 years ago
(In reply to Andrei Hajdukewycz [:sancus] from comment #16)
> Changing my email works(I get a new token, which correctly returns the new
> email). I don't, however, have a token that is associated with
> error@mozilla.com.


Interesting. For what it's worth, there MANY "error@mozilla.com" + unique token combos in Master_Subscribers (I know, it makes me cringe too). It might be better to try to change it to a youremailaddrss+12345uniquecombohere@mozilla.com combo to see if you can get the right info. 

Then you can go to:

1) www.mozilla.org/newsletter/existing/NEW_ADDRESS_TOKEN - to see if your new email address is subscribed to Mozillians
2) www.mozilla.org/newsletter/existing/OLD_ADDRESS_TOKEN to see if has been unsubscribed from Mozillians.
Based on comment 16, I think this bug is verified.
Status: RESOLVED → VERIFIED
Version: next → 2014-04.4
Has it been fixed into prod?
Because I still get mozillians email on my _old address_ (today's emails about town hall and newsletter). But when I click on the link to manage my subscriptions, the email address displayed is my _new address_.
That's just weird...
Flore,

do you remember whether you changed your email address more than a month ago (i.e. before this gets fixed on prod?)
(In reply to Giorgos Logiotatidis [:giorgos] from comment #20)
> Flore,
> 
> do you remember whether you changed your email address more than a month ago
> (i.e. before this gets fixed on prod?)

Hey Giorgios
I changed my mozillian email in september 2013. So well before the fix.
My old email is bugzilla@ophiuchus.org, it's not present in the database anymore (I checked once again on http://www.mozilla.org/en-US/newsletter/recovery/).
Excerp of the email headers I got yesterday:

>Received: by mta2.e.mozilla.org id hfq62o163hsh for <bugzilla@ophiuchus.org>; Thu, 22 May 2014 17:45:02 -0600 (envelope-from <bounce-100_HTML-11534005-709096-1065730-1@bounce.e.mozilla.org>)
>From: "Mozilla" <Mozilla@e.mozilla.org>
>To: <bugzilla@ophiuchus.org>
>Subject: INVITATION: Mozillians Town Hall - 2014 Goals - Marketplace/Apps

On april 24th, I checked that my email was the correct one (new address) and subscribed to the Firefox newsletter, but I also get it on the old address.
(Reporter)

Comment 22

4 years ago
(In reply to Flore Allemandou from comment #21)

Hello Flore,

I can help solve this mystery. Can you forward me the full email you received for "INVITATION: Mozillians Town Hall - 2014 Goals - Marketplace/Apps" to jdavis@mozilla.com ?

I have a theory as to what's going on, but I need the full email to confirm.

Thanks!

Jess
(In reply to Jessilyn Davis from comment #22)
> (In reply to Flore Allemandou from comment #21)
> 
> Hello Flore,
> 
> I can help solve this mystery. Can you forward me the full email you
> received for "INVITATION: Mozillians Town Hall - 2014 Goals -
> Marketplace/Apps" to jdavis@mozilla.com ?
> 
> I have a theory as to what's going on, but I need the full email to confirm.
> 
> Thanks!
> 
> Jess

Done! I hope we finally manage to solve this :-)
(Reporter)

Comment 24

4 years ago
Flore and I connected and all is well. Thanks!
Great, thanks! 

Jessilyn is there something we can fix on mozillians.org or the issue was that we landed this fix after Flore changed email addresses?
(In reply to Giorgos Logiotatidis [:giorgos] from comment #25)
> Great, thanks! 
> 
> Jessilyn is there something we can fix on mozillians.org or the issue was
> that we landed this fix after Flore changed email addresses?

Apparently, this happens because both addresses (new and old) are redirection to the same address (on gmail.com). Not sure if you can do anything on mozillians.org.
It's not really a problem for me. I just wanted to make sure that it was really fixed for people who changed their address on the site.
Aha! Thanks for clarifying Flore and for taking the time to report in the first place.
I am still receiving the mozillians email on my old email address (which I did not delete just because of that) and it is still bothering me. On the latest email sent to mozillians (Firefox OS in 2015 and beyond), I clicked (out of curiosity) on the "update profile" link and was redirected to an URL like "http://click.e.mozilla.org/profile_center.aspx?s=XXXXXXXX" and guess what? The email address registered is my old email address. And that is why I still receive mails on that old email address...
Of course, I can not change my email address there. But it proves that there is still an issue. I'm probably not alone in that situation. And for people whose address does not exist anymore, they probably miss these emails.

I think it is very important to fix that issue, that's why I'm reopening this bug...
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
(Reporter)

Comment 29

3 years ago
Hi Flore!

Thanks for reopening. We had an email infra SNAFU for the last send - it accidentally included the old footer/header info from our email tech that is connected to an email preference center that we do not use. That's why if you clicked the "update profile" link you were taken to a click.e.mozilla.org/profile_center URL that pulled from an old database with your old email address.

If you click on the link in the phrase: "If you do not wish to receive these updates, please unsubscribe here." it should take you to mozilla.org/newsletter/existing/XXXXXX  to show your updated email address and subscription information of the system that we *do* use. Can you follow that link and make sure it shows your correct info?

Thanks!

Jess
OK this link shows the correct info (my current email address).

But still, when I look at the headers, I can still see:

Delivered-To: ophiuchus.org-bugzilla@ophiuchus.org
Received: from localhost (HELO queue) (127.0.0.1)
	by localhost with SMTP; 22 May 2015 23:34:16 +0200
Received: from mta2.e.mozilla.org (68.232.195.239)
  by mx1.ovh.net with SMTP; 22 May 2015 23:34:14 +0200
Received: by mta2.e.mozilla.org id hbugdc163hss for <bugzilla@ophiuchus.org>; Fri, 22 May 2015 15:34:12 -0600 (envelope-from <bounce-100_HTML-11534005-2443007-1380506-1@bounce.e.mozilla.org>)
From: "Mozillians" <mozillians@mozilla.com>
To: <bugzilla@ophiuchus.org>


And bugzilla@ophiuchus.org is the old email address while the new one is on a different server (mozfr.org). I know that both redirect to the same gmail account. But it does really annoy me that "bugzilla@ophiuchus.org" is still somewhere present in the mozillians.org address book. Because I have the feeling that there is a bug that we can't put our fingers on and I don't like that...
(Reporter)

Comment 31

3 years ago
Herm. Okay - let's do this to see if we can make sure our system is working as it should. 

Do you mind helping test?

Steps to test:

1) Change your email address in mozillians.org to the old address.
2) Change your email address in mozillians.org to your new address.
3) Email me directly, or put into this bug, both email addresses and let me know which one is old, and which one is new.
4) I'll then check to see that the old one is unsubscribed, and the new one is subscribed.
You need to log in before you can comment on or make changes to this bug.