DNS stops resolving after a period of time

RESOLVED DUPLICATE of bug 84580

Status

()

Core
Networking
RESOLVED DUPLICATE of bug 84580
17 years ago
15 years ago

People

(Reporter: Stephen Wettone, Assigned: neeti)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.2) Gecko/20010628
BuildID:    2001062815

After a certain amount of time, which I'm not sure about but is in the region of
2 or 3 weeks, Mozilla fails to resolve the DNS of my intranet server. Mozilla
continues to work on all other sites I try, and other browsers (Netscape 4.7, IE
5.5) can still see the intranet.

I've tried clearing the cache, restarting Mozilla, getting rid of the cookies
the server has previously sent, all to no avail. The only thing that makes it
work again is a reboot. (The PC very rarely gets rebooted otherwise.)

I don't think this is a duplicate of bug 84580, that seemed to be something
happening after a few minutes, but in my case Mozilla can run very happily for
weeks. I've had this symptom happen twice so far.

Reproducible: Didn't try
Steps to Reproduce:

Comment 1

17 years ago
This could be really hard to reproduce :)

My gut says that we should probably have you turn of DNS caching and see if the
problem stops manfesting. This feature is new, so there might be other good
ideas that someone could suggest.

Gordon?

Comment 2

17 years ago
Ben, I don't think turning off the DNS cache will have any effect.  The DNS
cache is purely transient (in memory only), we do not persist any entries to
disk for use between runs.  So, if he still has problems after quiting mozilla
and relaunching, it can't be the DNS cache.

Stephen, it would be interesting to try creating and using a new profile the
next time you are able to reproduce this problem.  It seems like there must be
some persistent state that is getting saved somewhere (profile? OS?), and we
might be able to isolate it by checking the same app (mozilla) with different
profiles.

Comment 3

17 years ago
I misread the bug. I thought it was one incredibly long session, which it's not.

Besides some system level stuff, the only other thing I can think of that
changes on a reboot is temp files...
(Reporter)

Comment 4

17 years ago
That's right, it's not one incredibly long session, although I do use that turbo
mode pref. So I guess that means there are some Mozilla libraries hanging around
for ages. I'll leave that analysis to those of you who know what they're talking
about. :)

I'll let you know next time it goes wrong. The last time I rebooted was a few
hours before I reported the bug.

Having looked again at bug 84580 I'm not so sure now that this isn't a
duplicate. The comments from matt adam at 2001-07-24 22:44 are exactly what I'm
getting too, and it only happens on the intranet (as far as I've noticed).

Some images simply stop appearing and the page never finishes loading. This
happens to me every day, after a couple of hours of using Mozilla. Could they be
related?

Comment 5

17 years ago
I should have asked. That would explain a lot. The next time it happens try
clearing the caches via prefs.

If you are getting stuck in the "resolving <hostname>" state, that actually can
be a variety of non-DNS activites that are holding up your browser window.

Comment 6

17 years ago

*** This bug has been marked as a duplicate of 84580 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 7

15 years ago
gordon: does DNS cache stay up when switching profiles in turbo mode?
You need to log in before you can comment on or make changes to this bug.