Closed Bug 921205 Opened 6 years ago Closed 6 years ago

[B2G][Contacts]User unable to add picture from gallery to New Contact consistently

Categories

(Core :: Graphics, defect, P2)

26 Branch
ARM
Gonk (Firefox OS)
defect

Tracking

()

RESOLVED WORKSFORME
blocking-b2g koi+

People

(Reporter: mclemmons, Assigned: sotaro)

References

Details

(Keywords: perf, regression, Whiteboard: [MemShrink:P2][fromAutomation][xfail] [c=memory p= s= u=1.2] burirun3)

Attachments

(4 files)

Description:
User attempt to add picture from gallery to New Contact in Contact App yields a black screen within the Crop area of the image upload section, preventing the image to be uploaded for that contact

Repro Steps:
1) Updated Buri to Build ID: 20130926040202
2) Select plus sign for New Contact in upper right
3) Select add picture icon
4) Select Gallery button
5) Select photo


Actual:
Photo doesn't appear on next screen. Crop appears in text header atop screen with checkmark that cannot be deselected

Expected:
Photo appears on next screen allowing user to crop image or not crop

Environmental Variables
Build ID: 20130926040202
Gecko: http://hg.mozilla.org/mozilla-central/rev/e85b0372cece
Gaia: fc222c4fb720d97ce3933e3f8891498c9c3f49b3
Platform Version: 27.0a1

Notes:
Repro frequency: (16/20, 80%)
Test Suite Name: (Contacts)
See attached: (logcat)
Optional extra notes: Appears to be more consistently displaying the error for new contact. 

For existing contacts, the percentage declines and device works more as expected.

Tried on two distinct Buri devices using the same build. 

Unable to reproduce behavior in trying to add image from camera.
blocking-b2g: --- → koi?
Component: Gaia::Contacts → Gaia::Gallery
Is this an OOM issue?? We can find lots OOM message in attached log:

09-26 14:01:18.539: E/msm7627a.gralloc(139): gralloc failed err=Out of memory
09-26 14:01:18.539: W/GraphicBufferAllocator(139): alloc(320, 480, 1, 00000133, ...) failed -12 (Out of memory)
09-26 14:01:18.539: E/memalloc(139): /dev/pmem: No more pmem available
09-26 14:01:18.539: E/msm7627a.gralloc(139): gralloc failed err=Out of memory
09-26 14:01:18.539: W/GraphicBufferAllocator(139): alloc(320, 480, 1, 00000133, ...) failed -12 (Out of memory)
09-26 14:01:19.189: E/memalloc(139): /dev/pmem: No more pmem available
09-26 14:01:19.189: E/msm7627a.gralloc(139): gralloc failed err=Out of memory
09-26 14:01:19.189: W/GraphicBufferAllocator(139): alloc(320, 480, 1, 00000133, ...) failed -12 (Out of memory)
09-26 14:01:19.209: E/memalloc(139): /dev/pmem: No more pmem available
09-26 14:01:19.209: E/msm7627a.gralloc(139): gralloc failed err=Out of memory
09-26 14:01:19.209: W/GraphicBufferAllocator(139): alloc(320, 480, 1, 00000133, ...) failed -12 (Out of memory)
09-26 14:01:19.929: E/memalloc(139): /dev/pmem: No more pmem available
09-26 14:01:19.929: E/msm7627a.gralloc(139): gralloc failed err=Out of memory
09-26 14:01:19.929: W/GraphicBufferAllocator(139): alloc(320, 480, 1, 00000133, ...) failed -12 (Out of memory)
09-26 14:01:19.929: E/memalloc(139): /dev/pmem: No more pmem available
09-26 14:01:19.929: E/msm7627a.gralloc(139): gralloc failed err=Out of memory
09-26 14:01:19.929: W/GraphicBufferAllocator(139): alloc(320, 480, 1, 00000133, ...) failed -12 (Out of memory)
I met similar issue at the same build in buri. But the outcome is different. The I got black in crop screen but checkbox is useable. I sometimes got all black screen at selection screen. In console, I got lots OOM message during that.
Okay. Let's bounce this over to gfx and see what they think - the log statements above seem to point to a gfx memory regression.
Blocks: GFXB2G1.2
Component: Gaia::Gallery → Graphics
Product: Boot2Gecko → Core
Version: unspecified → 26 Branch
I'm pretty sure we know about the root cause for this, I'll let Sotaro confirm.
Flags: needinfo?(sotaro.ikeda.g)
QA Contact: jzimbrick
Whiteboard: [MemShrink]
Keywords: perf
(In reply to Milan Sreckovic [:milan] from comment #4)
> I'm pretty sure we know about the root cause for this, I'll let Sotaro
> confirm.

Yeah, the bug seems to be caused by "out of pmem". By using ROM applying patches in Bug 905882, I did not see this problem.
Flags: needinfo?(sotaro.ikeda.g)
Depends on: 905882
Looks like it is a regression from 1.1
 
Issue does not reproduce on v1.1 Buri build
Build ID: 20131001041206
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/c630289d6388
Gaia: 02b975e6ce12922928c74276ac7d19432a03f126
Platform Version: 18.1

This issue reproduces on the very first v1.2 Buri build
Build ID: 20130621031231
Gecko: http://hg.mozilla.org/mozilla-central/rev/7ba8c86f1a56
Gaia: e2f19420fa6a26c4287588701efaec09a750dba1
Platform Version: 24.0a1
QA Contact: jzimbrick → mdavydova
Tracking as this is a regression and hoping that the patches in Bug 905882 will fix this issue once resolved per comment #5.
Assignee: nobody → sotaro.ikeda.g
blocking-b2g: koi? → koi+
Whiteboard: [MemShrink] → [MemShrink][fromAutomation]
Blocks: 801898
Blocks: 925852
No longer blocks: 801898
Whiteboard: [MemShrink][fromAutomation] → [MemShrink][fromAutomation][xfail]
Whiteboard: [MemShrink][fromAutomation][xfail] → [MemShrink:P2][fromAutomation][xfail]
Status: NEW → ASSIGNED
Whiteboard: [MemShrink:P2][fromAutomation][xfail] → [MemShrink:P2][fromAutomation][xfail] [c=memory p= s= u=1.2]
Should be working now with the dependency fixed. Can we retest?
Keywords: qawanted
Adding a picture from gallery to a new contact is almost consistent with the latest 1.2 build. I had a 9/10 success rate with the failure being the selected image not loading, but the user still being able to select Check-Mark button to add the picture to the contact. I'll provide a screenshot of the screen. Otherwise the pictures loaded consistently.

Device: Buri v 1.2 Moz RIL
BuildID: 20131101004000
Gaia: e717aec947571f5daf923c040a82f9f0719bb526
Gecko: 54de309e18a9
Version: 26.0
Firmware Version: 20131015
Keywords: qawanted
QA Contact: mdavydova → nkhristoforov
That sounds like we've improved on the implementation with the dependency, but it isn't entirely fixed.
I can add a photo to a contact but we can't see the 'OK' button in the crop screen 

also a screen notifying about a a duplicate contact appears That's for sure a bug
Bug 934537 - [Contacts] Trying to edit a contact generates a "Duplicate found" message
Bug 905882 was fixed on hamachi. But need to update libgralloc and libhwcomposer to apply the fix.
Depends on: 934602
(In reply to Sotaro Ikeda [:sotaro] from comment #14)
> Bug 905882 was fixed on hamachi. But need to update libgralloc and
> libhwcomposer to apply the fix.

Need to update a base image. Bug 934602 is a bug for it.
Whiteboard: [MemShrink:P2][fromAutomation][xfail] [c=memory p= s= u=1.2] → [MemShrink:P2][fromAutomation][xfail] [c=memory p= s= u=1.2] burirun3
Priority: -- → P2
On the OEM build, the image does show, having said that a crash occurred.
Can't see the crash stack since wifi is busted.


Gaia   2ef9bc3c7a6de228b63e6ba3613eb0c0dd639c59
BuildID 20131105151351
Version 26.0a2
1.2 Buri

Will retest on our own gecko/gaia on top of OEM build after finishing further OEM testing
Attached file crash.zip
Crash files from OEM 1.2 build
Adding qawanted to test this with gecko/gaia on top of the OEM build.
Keywords: qawanted
Gaia:     377eb71506d8790d3c3280d82ac007ff4525b7e0
Gecko:    c15f5d7e0d7ebff5f8edef0745f144cd1552e34c
BuildID   20131112123250
Version   28.0a1
Base Build : US_V1.2_20131111.cfg
Buri

Crash doesn't occur with our build; having said that, the exact steps for this can be done with showing the expected results.  

There's an offshoot bug where if you crop the image before trying to send the image back to contacts will not cause the image to appear:

11-12 14:09:26.519: W/memalloc(137): Falling back to ashmem
11-12 14:09:26.579: I/Gecko(1522): SharedSurface_Gralloc::Create: success -- surface 0x43996100, GraphicBuffer 0x441baa80.
11-12 14:09:27.779: I/Gecko(137): ###!!! [Parent][MessageChannel] Error: Channel error: cannot send/recv
11-12 14:09:28.019: I/Gecko:ProcessPriorityManager(137): [Gallery, child-id=20, pid=1522] Scheduling reset timer to fire in 1000ms.
11-12 14:09:28.039: I/Gecko:ProcessPriorityManager(137): [Gallery, child-id=20, pid=1522] ScheduleResetPriority bailing; the timer is already running.
11-12 14:09:28.039: I/Gecko:ProcessPriorityManager(137): [child-id=20, pid=-1] Destroying ParticularProcessPriorityManager.
11-12 14:09:28.349: E/copybit(137): copyBits failed (Invalid argument)
11-12 14:09:28.349: E/copybit(137): 0: src={w=0, h=1217636992, f=1217457952, rect={1217457952,1121590480,1075253320,1217743024}}
11-12 14:09:28.349: E/copybit(137):     dst={w=320, h=480, f=14, rect={319,20,1,460}}
11-12 14:09:28.349: E/copybit(137):     flags=00000100
11-12 14:09:28.349: E/msm7627a.hwcomposer(137): hwc_set: Copybit layer draw failed!
11-12 14:09:28.369: D/HwcUtils(137): Skip layer
Note: I'm not sure whether it's due to the fallback and then the copy or something else...  Sotaro-san, please see log in comment 19
Flags: needinfo?(sotaro.ikeda.g)
Never mind.  bug 918062 covers the cropping issue.  I will post the logcat in there.
Flags: needinfo?(sotaro.ikeda.g)
Unable to reproduce on the Buri 1.2 Build ID: 20131115004003

Gaia   a6484b1e6fc07cf6bd8d6fcf9aeebb14b7e8869d
SourceStamp ff2c7c9d01d6
BuildID 20131115004003
Version 26.0
Base: 20131115

Also, unable to reproduce on Buri 1.3 Build ID: 20131115040200

Gaia   ac42cb33f21b3f13595432c965f44615daae2225
SourceStamp b2fab608772f
BuildID 20131115040200
Version 28.0a1
Base: 20131115
Keywords: qawanted
Sounds like then this is a works for me - this is resolved with the 1.2 base image.
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → WORKSFORME
No longer blocks: 925852
You need to log in before you can comment on or make changes to this bug.