Vivo shelf not shown in Marketplace using a Vivo BR SIM

RESOLVED FIXED in 2013-10-14

Status

P1
critical
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: simon.callan, Assigned: cvan)

Tracking

2013-10-14
Points:
---

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_8_3) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/29.0.1547.65 Safari/537.36

Steps to reproduce:

Use a Vivo SIM go into Marketplace and you see Movistar Recommends NOT the Vivo Shelf



Expected results:

Should see the Vivo shelf not the Movistar Shelf
(Reporter)

Updated

5 years ago
Severity: normal → critical
Priority: -- → P1

Updated

5 years ago
Component: General → Consumer Pages
Product: Boot2Gecko → Marketplace
Version: unspecified → 1.0

Comment 1

5 years ago
Please submit logs for the issue following these instructions:

https://github.com/mozilla/ashes#submitting-logs

Comment 2

5 years ago
We need more information to be able to diagnose the cause of this issue. Please submit logs or we will be unable to determine the cause of the problem.
Flags: needinfo?(simon.callan)

Comment 3

5 years ago
b3eb6

Comment 4

5 years ago
Created attachment 812195 [details]
screenshot_marketplace_VIVO_SIM_BR.png

Comment 5

5 years ago
The MCC/MNC in your logs shows 724,10. That's the tuple for the Vivo brand, but mobilenetwork.js shows that the carrier is Telefonica.

https://github.com/mozilla/fireplace/blob/master/hearth/media/js/mobilenetwork.js#L84

It would seem to me that this is a curation issue. The Brazil-Telefonica operator shelf should be Vivo and not Movistar. This seems like an issue for Adora maybe?

We also don't have a logo for Vivo, so we'll need them to provide an SVG for that operator shelf as well.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(simon.callan)
(Assignee)

Comment 6

5 years ago
(In reply to Matt Basta [:basta] from comment #5)
> The MCC/MNC in your logs shows 724,10. That's the tuple for the Vivo brand,
> but mobilenetwork.js shows that the carrier is Telefonica.
> 
> https://github.com/mozilla/fireplace/blob/master/hearth/media/js/
> mobilenetwork.js#L84

All these MCC/MNC pairs correspond to telefonica/movistar/vivo:

724 - 006
724 - 010
724 - 011
724 - 023

Should all of these pairs match *only* Vivo? Telefonica is the parent brand, the carrier.

movistar-br is the only operator shelf we have in Brazil.

Let me know - thanks!

> It would seem to me that this is a curation issue. The Brazil-Telefonica
> operator shelf should be Vivo and not Movistar. This seems like an issue for
> Adora maybe?
> 
> We also don't have a logo for Vivo, so we'll need them to provide an SVG for
> that operator shelf as well.

Comment 7

5 years ago
I think movistar-br should become vivo-br. All telefonica:br carrier/region pairs should be vivo and not movistar (afaik; someone please correct me if i'm wrong)

Comment 8

5 years ago
Any update of this issue? it is still showing Movistar Recomienda!

Comment 9

5 years ago
We can change the name (Lisa Brewster? Wil Clouser?) but AFAIK we're still waiting on Vivo to provide a vector icon because they haven't sent it to us in the right format.
(Reporter)

Comment 10

5 years ago
what format do you need?

Comment 11

5 years ago
Any vector format, preferably SVG. That means, though, that they can't simply wrap a PNG or a JPG in an SVG (that defeats the point). This allows us to rescale the logo for different areas and devices without pixelation or scaling artifacts.

Comment 13

5 years ago
No Notification of an update for the MarketPlace so it is still the Movistar Recomienda.
(Reporter)

Comment 14

5 years ago
with a BR SIM and BR build this is STILL NOT FIXED
(Assignee)

Comment 15

5 years ago
This is not in production yet. Just on -dev. This will go live on Tuesday, October 14 at 11.00 PDT. Please test this using the Marketplace Dev app - https://marketplace-dev.allizom.org/app/marketplace?region=worldwide

During the past few months we have rewritten our operator shelves to use collections. Forgive the slowness, as we've been waiting for that to go live.

Comment 16

5 years ago
This shows up on the desktop just fine @ https://marketplace-dev.allizom.org/

However, I don't see the operator shelf on my phone when I set my region = Brazil. Are we checking for a brazilian SIM on the phone?

Comment 17

5 years ago
Yes I am using a BR SIM. just checked and the name has changed but uses the same icon as the All Categories

Comment 19

5 years ago
aa5a2
(Assignee)

Comment 20

5 years ago
(In reply to Jaime Vega from comment #19)
> aa5a2

As stated in comment 15, this is not in production yet. That means that you will not see this update in the Marketplace production app (the one that is preloaded with Gaia on the Firefox OS phones).

On Tuesday, 10/14, you will see the icons live. If you would like to test the Marketplace Dev app, feel free to install the Dev certificates and install the packaged app here:  https://marketplace-dev.allizom.org/app/marketplace?region=worldwide

Alternatively, you can view the updated Vivo graphic by navigating to our Dev Marketplace from your browser: https://marketplace-dev.allizom.org/?mcc=724&mnc=10

Let me know if you have any additional questions.
You need to log in before you can comment on or make changes to this bug.