app submit screen shot api, how do I use it?

RESOLVED INVALID

Status

RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: ecritian, Unassigned)

Tracking

Points:
---

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_8_5) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/29.0.1547.76 Safari/537.36

Steps to reproduce:

/ api/v1/apps/preview /? app = (int: app_id) & _user = token or
/ api/v1/apps/preview /? app = (int: app_id)

Submit a screenshot using the above api 401 error occurs in

What is the api to use?


Actual results:

401 error
A 401 would indicate that you are unauthorized to perform that action.

Can you provide more information about the request? If you can email me the HTTP verb and specifics about the application you're attempting to modify and some authentication details (don't post them publicly) I would be happy to look into it.
Flags: needinfo?(ecritian)
(Reporter)

Comment 2

5 years ago
Check this late.
How to use the token value in trying to authenticate using oauth change is in the way.
Language is a ruby, in part as follows: use get_access_token 401 error occurs.

site = 'https://marketplace.firefox.com'
token = '/oauth/token/'

@consumer = OAuth::Consumer.new(key, secret,
                     {:site => site,  :request_token_path => token, :access_token_path=> token , :sign_in => true})

Problems using the wrong url indeut'd api oauth path of the document provided by the change, but the resolution is not being seen by.

Thank you for this answer.
Flags: needinfo?(ecritian)
We're still not 100% clear what the problem is. Could you possibly provide a concise ruby script that highlights the problem that we can run ourselves?  Thanks.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.