[Buri][MMS]Video will repeat after unlock the screen

RESOLVED WORKSFORME

Status

P1
normal
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: sync-1, Unassigned)

Tracking

unspecified

Firefox Tracking Flags

(b2g18 affected, b2g-v1.1hd affected, b2g-v1.2 unaffected, b2g-v1.3 unaffected)

Details

Attachments

(1 attachment)

337.70 KB, text/plain
Details
(Reporter)

Description

5 years ago
Firefox os  v1.1
 Mozilla build ID:20130916041201
 
 Created an attachment (id=527185)
 JRDLOG
 
 DEFECT DESCRIPTION:
 Video will repeat after unlock the screen
 
  REPRODUCING PROCEDURES:
 1.Receive a mms include a video
 2.View the video 
 3.Lock the screen
 4.Unlock the screen, found the video play again--KO
 
  EXPECTED BEHAVIOUR:
 KO:the video should stop
 
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:Medium
 
  REPRODUCING RATE:5/5
 
 
  For FT PR, Please list reference mobile's behavior:
(Reporter)

Comment 1

5 years ago
Clone from brother
(Reporter)

Comment 2

5 years ago
Created attachment 810921 [details]
JRDLOG
Component: Gaia::SMS → Gaia::Video
This is a correct behavior. We close the open activity when it is hidden. When you lock the screen, the open activity will receive a visibility change event and it is closed.

When you unlock the device, we can press "view" again to open it again.
John, if I understand correctly the description, I think this is exactly what the reporter thinks that it doesn't work
Julien, 

Ok, I see. I had check it in Inari with m-c version. I can't reproduce it. I will use b2g18 to test it. Thanks for your information.

Comment 6

5 years ago
Hi, Is there any advance?

Comment 7

5 years ago
(In reply to John Hu [:johnhu] from comment #3)
> This is a correct behavior. We close the open activity when it is hidden.
> When you lock the screen, the open activity will receive a visibility change
> event and it is closed.
> 
> When you unlock the device, we can press "view" again to open it again.

> When you lock the screen, the open activity will receive a visibility change
> event and it is closed. 
So does the visibility change event work or not?  And why the video play again?
Sorry, I am currently busy on other bugs. Once they are cleared, I will be back to fix this one.

To reply your question, we will have a small delay, about 3 sec, to receive the visibility change event. If we lock and unlock very soon, the event may not be received. If master branch doesn't have this problem, we may have a patch for it. That needs time to find it.

Comment 9

5 years ago
(In reply to John Hu [:johnhu] from comment #3)
> This is a correct behavior. We close the open activity when it is hidden.
> When you lock the screen, the open activity will receive a visibility change
> event and it is closed.
> 
> When you unlock the device, we can press "view" again to open it again.

The statement of visibility change event is  wrong position in view.js file.When you lock the devices, the process of visibility change event can not be called.So when you unlock the device, we can not press "view" again to open it again.Just play video again.
John, if you can't reproduce in 1.2, does it mean it's been fixed by another bug ? Maybe we already have a patch ?

Liangxin, is it really a blocker for you in 1.1 ? Or can we just close this if this is fixed in 1.2 ?

QA: can you test in 1.1 and 1.2 and report the results ? The problem (if I understood correctly) is that the video automatically resumes playing when unlocking the screen whereas it should not.
Keywords: qawanted

Updated

5 years ago
QA Contact: sparsons

Comment 11

5 years ago
I am unable to reproduce this issue on the Buri 1.2 Aurora Build ID: 20131016004005

Gaia   5ef3535021286ccab7af639897feaaf5955720a0
SourceStamp 75b0b968f3ed
BuildID 20131016004005
Version 26.0a2

Also unable to reproduce on Leo 1.1 Build ID: 20131016041201

Gaia   680f3b86b1e4ff1411ece6ba397b8b0e56b4b31c
SourceStamp 3cbd02abb840
BuildID 20131016041201
Version 18.0

The video does not continue play after the device is unlocked.
Keywords: qawanted
Reporter, see question in comment 10.

Also, can you confirm you still reproduce it with current builds ?
Flags: needinfo?(sync-1)

Comment 13

5 years ago
(In reply to Julien Wajsberg [:julienw] from comment #12)
> Reporter, see question in comment 10.
> 
> Also, can you confirm you still reproduce it with current builds ?

Yes, I can reproduce it with current builds.
Firefox os  v1.1
Mozilla build ID:20130916041201
I want to know how do you resolve this issue on V1.2?
Do you resolve this issue like that when you unlock the device, press "view" again to open it again?
build id 20130916041201 <= does not look like a recent build to me...

when it's locked, the "video" app is still displayed, but the video is not playing.
In the build 20130916041201, it does reproduce this bug. This is caused by the visibilitychange event is not fired.
I had tested multiple version of v1.1 including the latest 2013-12-11-04-12-01. This bug is still existed in v1.1.
Alive,

This is an old bug. Do you know which patch fix this one? V1.1 is affected but 1.2 is not.
Flags: needinfo?(alive)
Liang, do you still need this information?
Flags: needinfo?(liang.xin)
status-b2g18: --- → affected
status-b2g-v1.1hd: --- → affected
status-b2g-v1.2: --- → unaffected
status-b2g-v1.3: --- → unaffected

Comment 19

5 years ago
(In reply to Julien Wajsberg [:julienw] from comment #18)
> Liang, do you still need this information?

Yes,I need patch.
I don't know which bug Sorry. There're plenty of bugs may be related.
Possibility#1: The audio-channel-active doesn't reflect video is playing in v1.2
closing as this seems fixed in master and we won't fix anything in 1.1 now
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(sync-1)
Flags: needinfo?(liang.xin)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.