[Homescreen] When selecting app in homescreen, app is not launched

RESOLVED DUPLICATE of bug 911643

Status

P1
critical
RESOLVED DUPLICATE of bug 911643
6 years ago
6 years ago

People

(Reporter: leo.bugzilla.gaia, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:leo+)

Details

Attachments

(2 attachments)

4.57 MB, video/3gpp
Details
198.62 KB, text/plain
Details
(Reporter)

Description

6 years ago
1. Title : When selecting app in homescreen, app is not launched
2. Precondition : 
3. Tester's Action : Drag and drop app icon serveral times >> Select icon
4. Detailed Symptom : App is no launched
5. Expected : App is launched
6. Reproducibility: Y
1) Frequency Rate : 100%

When this issue is shown, "this.olist.getAttribute('disabled')" value is always true in page.js
(Reporter)

Updated

6 years ago
blocking-b2g: --- → leo+
Priority: -- → P1
(Reporter)

Comment 1

6 years ago
Created attachment 810965 [details]
VID_0011.3gp
(Reporter)

Comment 2

6 years ago
Created attachment 810966 [details]
logcat
(Reporter)

Comment 3

6 years ago
And, when I close app via card view, below log is occured

E/GeckoConsole(  135): [JavaScript Error: "TypeError: currentCard.addEventListener is not a function" {file: "app://system.gaiamobile.org/js/cards_view.js" line: 528}]
Hi reporter,

How do you get the screen into the initial state in the video? Was it done via the STR in bug 911643?
(Reporter)

Comment 5

6 years ago
We don't have any STR. So, we are finding STR
(Reporter)

Comment 6

6 years ago
We have one question.
Does't device execute "setTimeout" function in specific time?

We saw that "this.olist.getAttribute('disabled')" value is always true.
We think below "setTimeout" function is not run in specific time.

https://github.com/mozilla-b2g/gaia/blob/v1-train/apps/homescreen/js/page.js#L810

Because "setTimeout" function is not run, "this.olist.getAttribute('disabled')" value is true...

So, please check this question.
need info Cristian here for comment 6
Flags: needinfo?(crdlc)
please change time || this.DISABLE_TAP_EVENT_DELAY -> 600. If the callback is not fired it shouldn't be because of homescreen
Flags: needinfo?(crdlc)
BTW, it is working in my leo device. It seems a problem related to build what you are checking because this code was landed several months ago
(Reporter)

Comment 10

6 years ago
Sorry, I write wrong frequency.

It is hard to reproduce. So, I change frequency rate

1) Frequency Rate : 100% -> rarely
(Reporter)

Comment 11

6 years ago
We think that if "this.olist.getAttribute('disabled')" value is true, change "this.olist.getAttribute('disabled')" value to false not using "setTimeout" function.(We guess "setTimeout" function have some errors)
(Reporter)

Comment 12

6 years ago
(In reply to Cristian Rodriguez (:crdlc) from comment #8)
> please change time || this.DISABLE_TAP_EVENT_DELAY -> 600. If the callback
> is not fired it shouldn't be because of homescreen

what effect to the homescreen or setTimeout if it's not homescreen problems?

We hope to get the reason why this issue is happened.
It's rarely to reproduce but we should find the root cause. 
Please check again.
This video doesn't make sense and as you can see there are scaled icons and it is due to drag problems. So the test is not valid and suffer from bug 911643. Please apply this bug 911643 comment 42

Thanks
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 911643
(Reporter)

Comment 14

6 years ago
We think that this issue is different from Bug-911643. When we reproduce Bug-911643, we can touch the app icon and launch it. But this issus is reproduced, we can't touch the app icon and launch it. Please consider it. 

Regarding the attached video contents,
1. Already happened about app launch issue. Can’t launch any apps
2. Drag and release the icon and then the icon is overlapped with other icons
3. Repeat step 2
4. No action about touch event.
Status: RESOLVED → REOPENED
Flags: needinfo?(crdlc)
Resolution: DUPLICATE → ---
(In reply to Leo from comment #14)
> We think that this issue is different from Bug-911643. When we reproduce
> Bug-911643, we can touch the app icon and launch it. But this issus is
> reproduced, we can't touch the app icon and launch it. Please consider it. 
> 
> Regarding the attached video contents,
> 1. Already happened about app launch issue. Can’t launch any apps
> 2. Drag and release the icon and then the icon is overlapped with other icons
> 3. Repeat step 2
> 4. No action about touch event.

I think what Cristian is saying here is that at the point of reproduction of the bug, the phone is in a bad state with a known bug. That might mean other areas of functionality might not work by caveat, which could up the severity of the root cause bug. The best way to figure out if this is truly a separate bug is to confirm a fix for the other bug (bug 911643). Then, retest this to see if it still happens. If it does, then yes, it's a separate bug.

Could you try Cristian's suggestion in comment 13? Try applying his patch, see if it fixes bug 911643. If it does and you can still reproduce this bug, then this could be a separate problem found here.
Exactly Jason, I meant that. According to recorded video the phone is in a bad state with a known bug.

(In reply to Jason Smith [:jsmith] from comment #15)
> (In reply to Leo from comment #14)
> > We think that this issue is different from Bug-911643. When we reproduce
> > Bug-911643, we can touch the app icon and launch it. But this issus is
> > reproduced, we can't touch the app icon and launch it. Please consider it. 
> > 
> > Regarding the attached video contents,
> > 1. Already happened about app launch issue. Can’t launch any apps
> > 2. Drag and release the icon and then the icon is overlapped with other icons
> > 3. Repeat step 2
> > 4. No action about touch event.
> 
> I think what Cristian is saying here is that at the point of reproduction of
> the bug, the phone is in a bad state with a known bug. That might mean other
> areas of functionality might not work by caveat, which could up the severity
> of the root cause bug. The best way to figure out if this is truly a
> separate bug is to confirm a fix for the other bug (bug 911643). Then,
> retest this to see if it still happens. If it does, then yes, it's a
> separate bug.
> 
> Could you try Cristian's suggestion in comment 13? Try applying his patch,
> see if it fixes bug 911643. If it does and you can still reproduce this bug,
> then this could be a separate problem found here.
Flags: needinfo?(crdlc)
Is this possible to reproduce on 1.2? That will help figure out if bug 885625 fixes this issue as well.
Keywords: qawanted

Updated

6 years ago
QA Contact: sparsons

Comment 18

6 years ago
Unable to reproduce on the Buri 1.2 Aurora Build ID: 20131001004003

Device: Buri
Build ID: 20131001004003
Gecko: http://hg.mozilla.org/releases/mozilla-aurora/rev/5689e4237ab7
Gaia: 5e0d0df6a762cf1e1812eeb735fba72e2539dc0c
Platform Version: 26.0a2
Keywords: qawanted
Given the testing above and the comment I made above, I'm going to move this back to a dupe. If something similar reproduces post a fix of bug 911643, let's open a new bug with STR not in relation to bug 911643.
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 911643
You need to log in before you can comment on or make changes to this bug.