Closed Bug 921327 Opened 6 years ago Closed 6 years ago

[Flatfish][homescreen] show 6 icons in a row on tablet

Categories

(Firefox OS Graveyard :: Gaia::Homescreen, defect)

Other
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:-, b2g-v1.2 fixed, b2g-v1.3 fixed)

RESOLVED FIXED
blocking-b2g -
Tracking Status
b2g-v1.2 --- fixed
b2g-v1.3 --- fixed

People

(Reporter: gasolin, Assigned: gasolin)

References

Details

Attachments

(4 files, 4 obsolete files)

According to UX request, we'd show 6 icons in a row on tablet, instead of currently 5 in a row on tablet.

The dock should align with grid in default 6 icons case.
helen, please attach new homescreen UX spec here
Blocks: flatfish
blocking-b2g: --- → koi?
Flags: needinfo?(hhuang)
Adding tim for flatfish blocking triage.
Flags: needinfo?(timdream)
Not blocking v1.2 minimal tablet support.
blocking-b2g: koi? → -
Flags: needinfo?(timdream)
Flags: needinfo?(hhuang)
juwei, currently we have 5 apps (calendar, email, browser, gallery, music) on the dock.

What are the suggest default 6 apps on the dock?
Flags: needinfo?(jhuang)
Assignee: nobody → gasolin
Attached image WIP screenshot (obsolete) —
helen, here's the first version of six icons.

It looks not quite like the spec though but I can't distinguish that. Could you point out which detail not fit the requirement.
Flags: needinfo?(hhuang)
Hi Fred,

Sorry for the late reply. After internal discussion, the 6 icon should order as:

Browser/ Email/ Gallery/ Music/ Contacts/ Calendar

Thanks,


(In reply to Fred Lin [:gasolin] from comment #4)
> juwei, currently we have 5 apps (calendar, email, browser, gallery, music)
> on the dock.
> 
> What are the suggest default 6 apps on the dock?
Flags: needinfo?(jhuang)
Attached image screenshot with 6 icons (obsolete) —
helen, per offline discussion, please help check the detail of layout, thanks!
Attachment #813785 - Attachment is obsolete: true
Fred, the distance between rows should be the same as columns, it looks too close now.
Flags: needinfo?(hhuang)
Attached image screenshot with 6 icons - 2 (obsolete) —
update with 3 row apps
Attachment #818296 - Attachment is obsolete: true
Attached image screenshot with 6 icons - 3 (obsolete) —
Attachment #818314 - Attachment is obsolete: true
looks more close now
Attachment #818922 - Attachment is obsolete: true
Attached image homescreen_spec
attach homescreen design spec
Attachment #819560 - Flags: review?(crdlc)
Comment on attachment 819560 [details]
pull request redirect to github

There is a new comment on github and please rebase the pull request. Ask again when it will be ready, thanks a lot
Attachment #819560 - Flags: review?(crdlc)
Comment on attachment 819560 [details]
pull request redirect to github

fixed comments on github. please kindly review it again
Attachment #819560 - Flags: review?(crdlc)
Comment on attachment 819560 [details]
pull request redirect to github

Please review the tests that are broken, thanks. The code looks good to me :)
Attachment #819560 - Flags: review?(crdlc) → review+
Cristian, unittest fixed. 
But while test on real device I found the strange behavior that after swipe right then left to the first screen, the icons are not hidden correctly. (it not happens on nightly)

I think I might missing something in grid.js, any thought?
Flags: needinfo?(crdlc)
Hi, does it happen with or without you patch? only for flatfish? thx
Flags: needinfo?(crdlc)
Hi, it's only for flatfish. With or without my patch, it happens :/
Sorry but I don't have idea
I'd merge this then create a followup to fix issues that only happens in recent real device build (landscape)

master-gaia https://github.com/mozilla-b2g/gaia/commit/128c8a9a8a3499ddbc9ef3cd94e4687a076f06ba

thanks!
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Blocks: 930306
Comment on attachment 819560 [details]
pull request redirect to github

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment] CSS changes for tablet layout, not affect phone layouts
[Bug caused by] (feature/regressing bug #):
[User impact] if declined: old 5 icons layout still in 1.2, means we'd fix 1.2 specific tablet layouts bugs (if any)
[Testing completed]:
[Risk to taking this patch] (and alternatives if risky): low
[String changes made]: None
Attachment #819560 - Flags: approval-gaia-v1.2?
Attachment #819560 - Flags: approval-gaia-v1.2? → approval-gaia-v1.2+
I was not able to uplift this bug to v1.2.  If this bug has dependencies which are not marked in this bug, please comment on this bug.  If this bug depends on patches that aren't approved for v1.2, we need to re-evaluate the approval.  Otherwise, if this is just a merge conflict, you might be able to resolve it with:

  git checkout v1.2
  git cherry-pick -x -m1 128c8a9a8a3499ddbc9ef3cd94e4687a076f06ba
  <RESOLVE MERGE CONFLICTS>
  git commit
Flags: needinfo?(gasolin)
slight modified(remove new e.me related patch) and uplifted to 1.2 2ad615234dfde72b69bd4ac397e6dd898076bcab

thanks
Flags: needinfo?(gasolin)
Blocks: 930858
You need to log in before you can comment on or make changes to this bug.