zffos1.1 CallLog The call log can not show the call rejected.

RESOLVED DUPLICATE of bug 922238

Status

Firefox OS
Gaia::Dialer
RESOLVED DUPLICATE of bug 922238
5 years ago
5 years ago

People

(Reporter: ji.chen5, Unassigned)

Tracking

({regression})

unspecified
regression

Firefox Tracking Flags

(blocking-b2g:koi+, b2g18 unaffected, b2g-v1.2 affected)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; CIBA; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; InfoPath.2; .NET4.0C; .NET4.0E; .NET CLR 3.5.30729; TCO_20130927083405)

Steps to reproduce:

1. Check the call log is clean.
2. Call the phone with the number 1234567.
3. Hang up the call without answering.
4. Check the call log.


Actual results:

There is no call log with number 1234567.


Expected results:

There should be a call log with number 1234567.
(Reporter)

Updated

5 years ago
Blocks: 899451

Comment 1

5 years ago
Please help to check if this is regression.
Keywords: qawanted
(Reporter)

Comment 2

5 years ago
Hi Ivan:

  I have asked my colleague. The bug seemed to be there recently. We did not found it before.

Updated

5 years ago
QA Contact: gbennett

Updated

5 years ago
QA Contact: gbennett
QA Contact: ktucker
I could not reproduce this issue following the exact steps above but could reproduce this issue on the latest Buri v 1.2.0 COM Ril build following these new steps:

1. Press the "Power/Lock" button on the test device.
2. Call the test device from another phone.
3. Reject the call from the lockscreen. 

Actual:
The rejected call will not show in the call log if the user rejects the call from the lockscreen.

Expected:
The rejected call from the lockscreen shows in the call logs.

Environmental Variables
Device: Buri v 1.2.0 COM RIL
Build ID: 20131001004003
Gecko: http://hg.mozilla.org/releases/mozilla-aurora/rev/5689e4237ab7
Gaia: 5e0d0df6a762cf1e1812eeb735fba72e2539dc0c
Platform Version: 26.0a2

I could not reproduce this issue following the old or new steps on the Leo v 1.1.0 COM RIL

Environmental Variables
Device: Leo v 1.1.0 COM RIL
Build ID: 20131001041206
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/c630289d6388
Gaia: 02b975e6ce12922928c74276ac7d19432a03f126
Platform Version: 18.1
RIL Version: 01.01.00.019.240
status-b2g18: --- → unaffected
status-b2g-v1.2: --- → affected
Keywords: qawanted → regression

Updated

5 years ago
blocking-b2g: --- → koi?
Keywords: regressionwindow-wanted

Updated

5 years ago
Component: Gaia::Contacts → Gaia::Dialer
Assignee: nobody → ktucker
Call log worked properly with the phone locked on the 9/20 1.2 build. Broken on the 9/21 1.2 build. Tested on Buri device.

-Works-
Device: Buri v 1.2.0 COM RIL
Build ID: 20130920004004
Gecko: http://hg.mozilla.org/releases/mozilla-aurora/rev/46b216260c1d
Gaia: 88e73da95f1c550f2fb0572480a40c989d37c997
Platform Version: 26.0a2
RIL Version: 01.02.00.019.056 

-Broken-
Device: Buri v 1.2.0 COM RIL
Build ID: 20130921004001
Gecko: http://hg.mozilla.org/releases/mozilla-aurora/rev/20fe34362674
Gaia: 7b6147372cbf560744a02be50e0a862a825caef6
Platform Version: 26.0a2
RIL Version: 01.02.00.019.056
Keywords: regressionwindow-wanted
Assignee: ktucker → nobody
triage: koi+, regresion
blocking-b2g: koi? → koi+
Couldn't reproduce. Tried with the phone locked and unlocked.
Might be buri comm RIL only, moving there.
Component: Gaia::Dialer → Vendcom
per comment 4, Commercial RIL is the same. Only gecko/gaia changed.
move to dialer so the proper teams can look at it
Component: Vendcom → Gaia::Dialer
(In reply to Joe Cheng [:jcheng] from comment #7)
> per comment 4, Commercial RIL is the same. Only gecko/gaia changed.
> move to dialer so the proper teams can look at it

Still need help reproducing it then.

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 922238
You need to log in before you can comment on or make changes to this bug.