UnicodeDecodeError: 'ascii' codec can't decode byte 0xa3 ... when running xpcshell-tests

RESOLVED FIXED in mozilla27

Status

Testing
XPCShell Harness
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: allstars, Assigned: allstars)

Tracking

unspecified
mozilla27
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

4 years ago
When I try to run xpcshell-tests for B2G Desktop,
I got following error

TEST-UNEXPECTED-FAIL | /home/allstars/src/github/mozilla-central/obj-x86_64-unknown-linux-gnu/_tests/xpcshell/dom/system/gonk/tests/test_ril_worker_icc.js | Process still running after test!
 0:00.27 >>>>>>>
 0:00.27 <<<<<<<
 0:00.27 INFO | Following exceptions were raised:
 0:00.27 Traceback (most recent call last):
  File "/home/allstars/src/github/mozilla-central/testing/xpcshell/runxpcshelltests.py", line 145, in run
    self.run_test()
  File "/home/allstars/src/github/mozilla-central/testing/xpcshell/runxpcshelltests.py", line 592, in run_test
    stdout, stderr = self.communicate(proc)
  File "/home/allstars/src/github/mozilla-central/testing/xpcshell/runxpcshelltests.py", line 207, in communicate
    self.process_line(line)
  File "/home/allstars/src/github/mozilla-central/testing/xpcshell/runxpcshelltests.py", line 471, in process_line
    self.report_message(line_string)
  File "/home/allstars/src/github/mozilla-central/testing/xpcshell/runxpcshelltests.py", line 457, in report_message
    self.on_message(line, message)
  File "/home/allstars/src/github/mozilla-central/testing/xpcshell/mach_commands.py", line 145, in <lambda>
    'on_message': (lambda obj, msg: xpcshell.log.info(msg)) \
  File "/home/allstars/src/github/mozilla-central/testing/xpcshell/runxpcshelltests.py", line 735, in wrapped
    fn(*args, **kwargs)
  File "/usr/lib/python2.7/logging/__init__.py", line 1148, in info
    self._log(INFO, msg, args, **kwargs)
  File "/usr/lib/python2.7/logging/__init__.py", line 1267, in _log
    self.handle(record)
  File "/usr/lib/python2.7/logging/__init__.py", line 1277, in handle
    self.callHandlers(record)
  File "/usr/lib/python2.7/logging/__init__.py", line 1317, in callHandlers
    hdlr.handle(record)
  File "/usr/lib/python2.7/logging/__init__.py", line 744, in handle
    rv = self.filter(record)
  File "/usr/lib/python2.7/logging/__init__.py", line 608, in filter
    if not f.filter(record):
  File "/home/allstars/src/github/mozilla-central/testing/xpcshell/mach_commands.py", line 37, in filter
    return not record.params['msg'].endswith("running test ...")
UnicodeDecodeError: 'ascii' codec can't decode byte 0xa3 in position 274: ordinal not in range(128)


I was still able to run xpcshell-test on b2g-desktop just a few days ago.
A similar bug was met before, Bug 847256, but it's for marionette tests.
(Assignee)

Comment 1

4 years ago
I just try latest m-c, commit 654bae448b07dc9fcb89303eea7ef16189ebb85d,
this problem is already fixed.

Sorry for the noise.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 2

4 years ago
Not sure what happened,
but now the error is back, even I use the commit mentioned in Comment 1.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(Assignee)

Comment 3

4 years ago
Seems Bug 921694 also for this.
(Assignee)

Comment 4

4 years ago
Created attachment 817743 [details] [diff] [review]
Patch
Assignee: nobody → allstars.chh
(Assignee)

Comment 5

4 years ago
Comment on attachment 817743 [details] [diff] [review]
Patch

Hi, gps
Can you help to review this for me ?

Thanks
Attachment #817743 - Flags: review?(gps)
Attachment #817743 - Flags: review?(gps) → review+
(Assignee)

Comment 6

4 years ago
Try:
https://tbpl.mozilla.org/?tree=Try&rev=6345646ca0df
(Assignee)

Updated

4 years ago
Duplicate of this bug: 921694
(Assignee)

Comment 8

4 years ago
At first there's a failure in OSX Marionette test, but re-run it twice, all green now.
Will push it right now.
(Assignee)

Comment 9

4 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/883941b3f927
(Assignee)

Comment 10

4 years ago
Regression: Mozilla-Inbound-Non-PGO - SVG-ASAP - Ubuntu HW 12.04 x64 - 8.06% increase
-------------------------------------------------------------------------------------
    Previous: avg 496.898 stddev 2.769 of 12 runs up to revision 440098bca4eb
    New     : avg 536.928 stddev 12.619 of 12 runs since revision 883941b3f927
    Change  : +40.031 (8.06% / z=14.459)
    Graph   : http://mzl.la/H3OJd8

Changeset range: http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=440098bca4eb&tochange=883941b3f927

Changesets:
  * http://hg.mozilla.org/integration/mozilla-inbound/rev/883941b3f927
    : Yoshi Huang <allstars.chh@mozilla.com> - Bug 921388 - UnicodeDecodeError: 'ascii' codec can't decode byte 0xa3 ... when running xpcshell-tests. r=gps
    : http://bugzilla.mozilla.org/show_bug.cgi?id=921388

Bugs:
  * http://bugzilla.mozilla.org/show_bug.cgi?id=921388 - UnicodeDecodeError: 'ascii' codec can't decode byte 0xa3 ... when running xpcshell-tests
That email is blaming the wrong changeset.   http://hg.mozilla.org/integration/mozilla-inbound/rev/ceb4bd44eb34 appears to be the real culprit.
Or maybe http://hg.mozilla.org/integration/mozilla-inbound/rev/a417424f9213

Regardless I think Yoshi's patch is not at fault.
https://hg.mozilla.org/mozilla-central/rev/883941b3f927
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla27
You need to log in before you can comment on or make changes to this bug.