Closed Bug 921409 Opened 6 years ago Closed 6 years ago

PDF viewer in Firefox 24 is broken (displaying just garbage) - version 23 and below were ok

Categories

(Firefox :: PDF Viewer, defect, P2)

24 Branch
x86_64
Windows 7
defect

Tracking

()

VERIFIED FIXED
Firefox 27
Tracking Status
firefox24 --- wontfix
firefox25 + verified
firefox26 + verified
firefox27 + verified

People

(Reporter: fst, Assigned: bdahl)

References

Details

(Keywords: regression, Whiteboard: [pdfjs-c-rendering][pdfjs-d-font-conversion][pdfjs-f-fixed-upstream] https://github.com/mozilla/pdf.js/pull/3750 [bugday-20131030])

Attachments

(5 files)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20100101 Firefox/24.0 (Beta/Release)
Build ID: 20130910160258

Steps to reproduce:

Opened one of my self-created PDF's
https://www.highdefinition.ch/pdf/open/xWmAMrfh/receipt_130919005.pdf


Actual results:

Version 23 of FF and below: ok
Version 24 of FF: just garbage


Expected results:

It should work as in version 23 of Firefox
Component: Untriaged → PDF Viewer
According to 'git bisect', this regressed upstream in: https://github.com/mozilla/pdf.js/pull/3187.
Regression range:
good=2013-05-17
bad=2013-05-18
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=ea767da526ff&tochange=6e2789a70f6b

Ryan VanderMeulen — Bug 871530 - Update pdf.js to version 0.8.169. r=dtownsend
and likely
#3187 Fix glyph selection for CID fonts that don't actually have CID font files.
Blocks: 871530
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
Attached file receipt_94659.pdf
For the record.
We are seeing the same thing for all our pdfs, worked perfectly in FF 23.
Definitely worth targeting a fix for FF25, given how recent this regression is. Brendan, would you mind taking a look?
Assignee: nobody → bdahl
Andreas, can you provide a link to some of your pdfs so I can confirm it is the same issue?
Flags: needinfo?(andreas.toom)
Priority: -- → P2
Whiteboard: [pdfjs-c-rendering][pdfjs-d-font-conversion]
An example PDF file that does not render properly in FF 24 but worked in FF 23 as requested by Brendan.

/Andreas
Flags: needinfo?(andreas.toom)
(In reply to Andreas Toom from comment #7)
> Created attachment 812589 [details]
> PDF version of a typical invoice that we present to our customers
> 
> An example PDF file that does not render properly in FF 24 but worked in FF
> 23 as requested by Brendan.
> 
> /Andreas

It's rendered fine on my side. Could you attach a screenshot of the bad rendering, please.
Flags: needinfo?(andreas.toom)
As requested, a screenshot of the pdf viewed inside FF 24.
Flags: needinfo?(andreas.toom)
> As requested, a screenshot of the pdf viewed inside FF 24.

This PDF is rendered correctly on my FF 24. It must be a different problem.
(In reply to Frederic Steinfels from comment #10)
> > As requested, a screenshot of the pdf viewed inside FF 24.
> 
> This PDF is rendered correctly on my FF 24. It must be a different problem.

Interestingly the pdf file you attached renders nicely on my FF, could it be something based on locale ?
(In reply to Andreas Toom from comment #9)
> Created attachment 812597 [details]
> Screenshot of customer pdf viewed in ff 24
> 
> As requested, a screenshot of the pdf viewed inside FF 24.

It's on Win XP SP3?
(In reply to Loic from comment #12)
> (In reply to Andreas Toom from comment #9)
> > Created attachment 812597 [details]
> > Screenshot of customer pdf viewed in ff 24
> > 
> > As requested, a screenshot of the pdf viewed inside FF 24.
> 
> It's on Win XP SP3?

No, Windows 7 Enterprise SP1
@Andreas please file a new bug, it seems to be a separate issue.
Whiteboard: [pdfjs-c-rendering][pdfjs-d-font-conversion] → [pdfjs-c-rendering][pdfjs-d-font-conversion][pdfjs-f-fixed-upstream] https://github.com/mozilla/pdf.js/pull/3750
[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 871530
User impact if declined: certain fonts will no longer render correctly
Testing completed (on m-c, etc.): in m-c
Risk to taking this patch (and alternatives if risky): low risk content js only
String or IDL/UUID changes made by this patch: none
Attachment #815067 - Flags: review?(ydelendik)
Attachment #815067 - Flags: approval-mozilla-aurora?
[Approval Request Comment]
see above
Attachment #815068 - Flags: review?(ydelendik)
Attachment #815068 - Flags: approval-mozilla-beta?
Attachment #815068 - Flags: review?(ydelendik) → review+
Attachment #815067 - Flags: review?(ydelendik) → review+
Keywords: checkin-needed
Woops, jumped the gun there, still needs approval.
Keywords: checkin-needed
Attachment #815067 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Attachment #815068 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Keywords: checkin-needed
I confirm the fix is verified on Latest Aurora 26 and FF25b8 on Windows 7 x64:

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0 
BuildID: 20131015004002

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:25.0) Gecko/20100101 Firefox/25.0
BuildID: 20131015052812
QA Contact: mihai.morar
Depends on: 928358
Bug 928358 updates pdf.js on trunk to a version containing this fix. It should be merged to m-c later today.
Status: NEW → RESOLVED
Closed: 6 years ago
Flags: needinfo?(ryanvm)
Resolution: --- → FIXED
Target Milestone: --- → Firefox 27
Depends on: 931246
Verified fixed with attachment 811159 [details]:
bug: firefox-24.0.en-US.linux64
WFM:
2013-10-20-03-02-02-mozilla-central-firefox-27.0a1.en-US.linux-x86_64
2013-10-29-03-02-01-mozilla-central-firefox-28.0a1.en-US.linux-x86_64
Status: RESOLVED → VERIFIED
Whiteboard: [pdfjs-c-rendering][pdfjs-d-font-conversion][pdfjs-f-fixed-upstream] https://github.com/mozilla/pdf.js/pull/3750 → [pdfjs-c-rendering][pdfjs-d-font-conversion][pdfjs-f-fixed-upstream] https://github.com/mozilla/pdf.js/pull/3750 [bugday-20131030]
Nothing from user feedback suggests this is widely being hit in ESR, which has been out for several months now, so we'll let this ride the trains to next ESR
You need to log in before you can comment on or make changes to this bug.