[helix][1.1HD] Camera stops functioning (black screen) when switching to the front camera

VERIFIED FIXED

Status

Firefox OS
Vendcom
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: nhirata, Unassigned, NeedInfo)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:hd+)

Details

(Whiteboard: [POVB])

Gaia   2a20910ea96efb538ec0c99ff25a540ed641f63f
SourceStamp 4c583e737e70
BuildID 20130927042200
Version 18.0

1. launch camera
2. hit the switch camera button to switch to the front camera

Expected: see the preview from the front camera
Actual: black screen

Note: 
1. bug 898326 fixed the crash.
2. OEM build of 09242013 will show the preview of the front camera and switches between the front and back just fine.

Comment 1

4 years ago
If you switch to video recording mode, the problem also happened.

Updated

4 years ago
blocking-b2g: --- → hd?
Two things to find out here:

1. Does this reproduce on a different production device (e.g. Buri)?
2. What's the last base image that this worked on? What's the first base image that this failed on?

Comment 3

4 years ago
Hi, all,

I found a ERROR while I switch to front-facing camera.
---------------------------------------------------------------------------------
E/GeckoConsole( 1884): [JavaScript Error: "TypeError: profiles.vga is undefined" {file: "app://camera.gaiamobile.org/js/camera.js" line: 1456}]
---------------------------------------------------------------------------------

I also found this bug was caused by latest vendor build.
If I use "latest" vendor build(20130924) with "latest" Gaia&Gecko,the bug can be reproduced.
But, if I use old vendor build(20130902) with "latest" Gaia&Gecko, the bug cannot be reproduced.

By the way, only helix had front-facing camera.

...one more thing, I submitted a related bug. FYI.
https://bugzilla.mozilla.org/show_bug.cgi?id=921936
This bug may need our partner's help.
Thanks!
Sounds like we have relatively know a regression window at this point by the base image. The next thing we need to know if this is device-specific or not.
Keywords: regressionwindow-wanted → qawanted
(In reply to Jason Smith [:jsmith] from comment #4)
> Sounds like we have relatively know a regression window at this point by the
> base image. The next thing we need to know if this is device-specific or not.

Actually, disregard. The fact it's being affected by the device image means it's a vendor issue.
Component: Gaia::Camera → Vendcom
Keywords: qawanted
Whiteboard: [POVB]

Comment 6

4 years ago
Hi, Jason,

Thanks for the suggestion and help! ^^
Yes, I agree with you. We need our partner to help on this case.
hd+'ing as it breaks front cam only on helix.

Lecky, 

Something you changed on the 0924 build is breaking the camera on our gecko/gaia, can you find out what you changed and let us know?
blocking-b2g: hd? → hd+
Flags: needinfo?(lecky.wanglei)

Updated

4 years ago
Depends on: 922014

Updated

4 years ago
Flags: needinfo?(lecky.wanglei) → needinfo?(zhaodawei03)

Comment 8

4 years ago
Hi all,

Thanks for your efforts.

We had found this bug and fixed it on the new version.
It was cased by the baseline upgraded.

Comment 9

4 years ago
Tested w/ parnter build released on 20131015 and gaia/gecko flashed

Gaia:     c829a2042594b6c3a4899ee27979799a0f301534
Gecko:    http://hg.mozilla.org/releases/mozilla-b2g18_v1_1_0_hd/rev/f7c657f6d019
BuildID   20131015042201
Version   18.0
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED

Updated

4 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.