When compiling ProxyObject.cpp: "Runtime.h:1434:17: warning: inline function 'bool JSRuntime::isAtomsZone(JS::Zone*)' used but never defined [enabled by default]"

RESOLVED FIXED in mozilla27

Status

()

Core
JavaScript Engine
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: dholbert, Assigned: Ehsan)

Tracking

(Blocks: 1 bug)

Trunk
mozilla27
x86_64
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Build warning noticed today, when compiling mozilla-inbound:
{
In file included from /mozilla-inbound/js/src/jscntxt.h:15:0,
                 from /mozilla-inbound/js/src/gc/Zone.h:13,
                 from /mozilla-inbound/js/src/jsgcinlines.h:12,
                 from /mozilla-inbound/js/src/vm/ProxyObject.cpp:9:
/mozilla-inbound/js/src/vm/Runtime.h:1434:17: warning: inline function 'bool JSRuntime::isAtomsZone(JS::Zone*)' used but never defined [enabled by default]
     inline bool isAtomsZone(JS::Zone *zone);
                 ^
}
hg bisect says this was introduced by:
{
changeset:   148911:5b35eb07b456
user:        Ehsan Akhgari <ehsan@mozilla.com>
date:        Thu Sep 26 18:34:54 2013 -0400
summary:     Bug 921130 - Minimize the #includes in js/src/jit; r=luke
}
http://hg.mozilla.org/mozilla-central/rev/5b35eb07b456
Blocks: 921130
(Assignee)

Comment 2

5 years ago
Created attachment 811341 [details] [diff] [review]
Patch (v1)
Assignee: nobody → ehsan
Status: NEW → ASSIGNED
Attachment #811341 - Flags: review?(luke)
(Assignee)

Updated

5 years ago
Duplicate of this bug: 921583
Comment on attachment 811341 [details] [diff] [review]
Patch (v1)

Review of attachment 811341 [details] [diff] [review]:
-----------------------------------------------------------------

::: js/src/jscompartment.h
@@ +20,5 @@
>  }
>  
> +namespace gc {
> +template<class Node> class ComponentFinder;
> +}

Is this necessary?  Maybe it avoids some bootlegging?  We generally don't worry about bootlegging much -- it's so hard to avoid -- but it's not a big deal either way.
Attachment #811341 - Flags: review?(luke) → review+
(Assignee)

Comment 6

5 years ago
(In reply to comment #5)
> Comment on attachment 811341 [details] [diff] [review]
>   --> https://bugzilla.mozilla.org/attachment.cgi?id=811341
> Patch (v1)
> 
> Review of attachment 811341 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> ::: js/src/jscompartment.h
> @@ +20,5 @@
> >  }
> >  
> > +namespace gc {
> > +template<class Node> class ComponentFinder;
> > +}
> 
> Is this necessary?  Maybe it avoids some bootlegging?  We generally don't worry
> about bootlegging much -- it's so hard to avoid -- but it's not a big deal
> either way.

I wrote several versions of this patch locally, and this was required in one of them.  It's kind of more correct to do the fwd declaration here since the header references ComponentFinder, so I'd prefer to leave it in.

At any rate, I'll land this patch if inbound ever reopens.
https://hg.mozilla.org/mozilla-central/rev/632e32739bc5
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla27
You need to log in before you can comment on or make changes to this bug.