[devhub] On -dev on Compatibility & Payments the checkbox for mexico flys off to the top-left corner of the screen

VERIFIED FIXED in 2013-10-01

Status

P2
normal
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: scolville, Assigned: scolville)

Tracking

2013-10-01
x86
Mac OS X
Points:
---

Details

(Whiteboard: [qa+])

This is a data discrepancy which should be fixed by looking at data for pricing. 

Because ALL_PAID_REGIONS is being used it's not matching up with the pricing data meaning there's a gap where there should be a placeholder.

Should be easy enough to fix.
Summary: On -dev checkbox for mexico flys off to the top-left corner of the screen → [devhub] On -dev on Compatibility & Paymenst the checkbox for mexico flys off to the top-left corner of the screen
Summary: [devhub] On -dev on Compatibility & Paymenst the checkbox for mexico flys off to the top-left corner of the screen → [devhub] On -dev on Compatibility & Payments the checkbox for mexico flys off to the top-left corner of the screen
Assignee: nobody → scolville
Priority: -- → P2
Target Milestone: --- → 2013-10-01
https://github.com/mozilla/zamboni/commit/57a637c59141d1aa0e263cbf18ee6d10363343ad

This commmit wasn't enough to fix the problem. The issue is that tier_zero hasn't been set-up for some of the countries that are used for other tiers. 

To prevent this causing a visible issue I'm going to cut a second branch which won't move the checkboxes if there's no placeholder. We should however watch out for this in how we setup the data for price tiers as this is fundamentally a data problem.
https://github.com/mozilla/zamboni/commit/18f7b9feae9efa0852836b1cb962468efaab7fd5 This prevent moving the checkbox at all if there's no placeholder.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Whiteboard: [qa+]

Comment 3

5 years ago
Things looks okay @ https://marketplace.allizom.org/developers/app/in-app-payment-tester/payments/ even with promotional pricing.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.