[Helix][1.1HD] T-Mobile SIM does not seem to find the operator network

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
5 years ago
9 months ago

People

(Reporter: nhirata, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:-)

Details

Attachments

(1 attachment)

Created attachment 811366 [details]
logcat.txt

Gaia   2a20910ea96efb538ec0c99ff25a540ed641f63f
SourceStamp 4c583e737e70
BuildID 20130927042200
Version 18.0
Helix

1. plug in T-Mobile Sim
2. reset the phone ; settings -> device info -> more info -> reset phone -> reset phone
3. wait until booted
Expected: T-Mobile network is found and you can see signals
Actual: no bars

Note:
1. AT&T SIMs will work
2. the SIM itself is detected in the Settings -> Cellular Data -> Data settings  ( it shows T-Mobile US )

Comment 1

5 years ago
From the log you attached, card can be detected.

card information can read, and state = ready.

09-27 13:52:16.019: I/Gecko(160): RIL Worker: Handling parcel as REQUEST_GET_SIM_STATUS
09-27 13:52:16.019: I/Gecko(160): RIL Worker: iccStatus: {"cardState":1,"universalPINState":0,"gsmUmtsSubscriptionAppIndex":0,"cdmaSubscriptionAppIndex":-1,"imsSubscriptionAppIndex":-1,"apps":[{"app_type":2,"app_state":5,"perso_substate":2,"aid":"a0000000871002ffffffff8906190000","app_label":"5553494d","pin1_replaced":0,"pin1":3,"pin2":1},{"app_type":0,"app_state":1,"perso_substate":0,"aid":"a0000000871004ffffffff8907030000","app_label":"","pin1_replaced":0,"pin1":0,"pin2":0},{"app_type":0,"app_state":1,"perso_substate":0,"aid":"a000000063504b43532d3135","app_label":"","pin1_replaced":0,"pin1":0,"pin2":0}]}


Signal quality is weak but exist.
Device couldn't register on network (radio reported NETWORK_CREG_STATE_SEARCHING. )

09-27 13:52:27.819: I/Gecko(160): -*- RadioInterfaceLayer: Received message from worker: {"rilMessageType":"networkinfochanged","operator":{"rilMessageType":"operatorchange","longName":null,"shortName":null,"mcc":null,"mnc":null}}
09-27 13:52:27.819: I/Gecko(160): -*- RILContentHelper: Received message 'RIL:VoiceInfoChanged': {"connected":false,"emergencyCallsOnly":true,"roaming":false,"network":{"rilMessageType":"operatorchange","longName":null,"shortName":null,"mcc":null,"mnc":null},"cell":null,"type":"gsm","signalStrength":-81,"relSignalStrength":51,"state":"registered"}

It looks more likly individual SIM's problem.
The issue I find is that I place the SIM in other devices and it can make calls correctly.  

With the latest OEM build, it can detect the SIM's pin.  It cannot get cell data/network connection.

Updated

5 years ago
blocking-b2g: --- → -

Comment 3

9 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 9 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.