Intermittent media/tests/crashtests/863929.html | Exited with code -1073741819 during test run | application crashed [@ ScanShape]

RESOLVED DUPLICATE of bug 920266

Status

()

RESOLVED DUPLICATE of bug 920266
5 years ago
5 years ago

People

(Reporter: RyanVM, Unassigned)

Tracking

({crash, intermittent-failure})

Trunk
x86
Windows 7
crash, intermittent-failure
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=28481631&tree=Mozilla-Inbound

Windows 7 32-bit mozilla-inbound opt test crashtest on 2013-09-27 12:46:01 PDT for push f691041334b8
slave: t-w732-ix-127

12:53:51     INFO -  REFTEST TEST-START | file:///C:/slave/test/build/tests/reftest/tests/dom/media/tests/crashtests/863929.html
12:53:51     INFO -  RESTORE PREFERENCE pref(media.navigator.permission.disabled,false)
12:53:51     INFO -  SET PREFERENCE pref(media.navigator.permission.disabled,true)
12:53:51     INFO -  REFTEST TEST-LOAD | file:///C:/slave/test/build/tests/reftest/tests/dom/media/tests/crashtests/863929.html | 614 / 2522 (24%)
12:53:51     INFO -  0[a0f140]: [main|PeerConnectionImpl] PeerConnectionImpl.cpp:401: sipcc::PeerConnectionImpl::PeerConnectionImpl: PeerConnectionImpl constructor for
12:53:51     INFO -  0[a0f140]: [main|CC_SIPCCCall] CC_SIPCCCall.cpp:36: Creating  CC_SIPCCCall 65554
12:53:51     INFO -  (ice/NOTICE) No STUN servers specified
12:53:51     INFO -  (ice/NOTICE) No TURN servers specified
12:53:51     INFO -  0[a11de0]: [CCAPP Task|def] ccapi.c:1163: SIPCC-CC_API: 1/18, cc_int_feature2: UI -> GSM: SETPEERCONNECTION
12:53:51     INFO -  (ice/ERR) ICE(PC:691294882cacb60d): All could not pair new trickle candidate
12:53:51     INFO -  (ice/ERR) ICE(PC:691294882cacb60d): All could not pair new trickle candidate
12:53:51     INFO -  (ice/ERR) ICE(PC:691294882cacb60d): All could not pair new trickle candidate
12:53:51     INFO -  (ice/ERR) ICE(PC:691294882cacb60d): All could not pair new trickle candidate
12:53:51     INFO -  (ice/ERR) ICE(PC:691294882cacb60d): All could not pair new trickle candidate
12:53:51     INFO -  (ice/ERR) ICE(PC:691294882cacb60d): All could not pair new trickle candidate
12:53:51     INFO -  0[a12320]: [GSM Task|def] dcsm.c:532: SIPCC-DCSM: dcsm_process_event: DCSM 22  :(DCSM_READY:SETPEERCONNECTION )
12:53:51     INFO -  0[a12320]: [GSM Task|fsm_sm] fsm.c:232: SIPCC-GSM_DBG_PTR: FSM 0   : fsm_get_fcb_by_call_id             : fcb= 04B80000
12:53:51     INFO -  0[a12320]: [GSM Task|fsm_sm] fsm.c:266: SIPCC-GSM_DBG_PTR: FSM 18  : fsm_get_new_fcb                    : fcb= 04B80000
12:53:51     INFO -  0[a12320]: [GSM Task|fsm_sm] fsm.c:232: SIPCC-GSM_DBG_PTR: FSM 0   : fsm_get_fcb_by_call_id             : fcb= 04B80020
12:53:51     INFO -  0[a12320]: [GSM Task|fsm_sm] fsm.c:266: SIPCC-GSM_DBG_PTR: FSM 18  : fsm_get_new_fcb                    : fcb= 04B80020
12:53:51     INFO -  0[a12320]: [GSM Task|fsm_sm] fsm.c:232: SIPCC-GSM_DBG_PTR: FSM 0   : fsm_get_fcb_by_call_id             : fcb= 04B80040
12:53:51     INFO -  0[a12320]: [GSM Task|fsm_sm] fsm.c:266: SIPCC-GSM_DBG_PTR: FSM 18  : fsm_get_new_fcb                    : fcb= 04B80040
12:53:51     INFO -  0[a12320]: [GSM Task|fsm_sm] fsm.c:232: SIPCC-GSM_DBG_PTR: FSM 0   : fsm_get_fcb_by_call_id             : fcb= 04B80060
12:53:51     INFO -  0[a12320]: [GSM Task|fsm_sm] fsm.c:266: SIPCC-GSM_DBG_PTR: FSM 18  : fsm_get_new_fcb                    : fcb= 04B80060
12:53:51     INFO -  0[a12320]: [GSM Task|fsm_sm] sm.c:46: SIPCC-FSM: sm_process_event: DEF 18  : 66732AEDx: sm entry: (IDLE:SETPEERCONNECTION)
12:53:51     INFO -  0[a12320]: [GSM Task|fsm_sm] fsmdef.c:3936: SIPCC-FSM: fsmdef_ev_setpeerconnection: Entered.
12:53:51     INFO -  0[a12320]: [GSM Task|fsm_sm] fsmdef.c:919: SIPCC-FSM: DEF 0   /0: fsmdef_get_dcb_by_call_id          : dcb= 08266000
12:53:51     INFO -  0[a12320]: [GSM Task|fsm_sm] fsmdef.c:1455: SIPCC-FSM: DEF 18  /0: fsmdef_get_new_dcb                 : dcb= 08266000
12:53:51     INFO -  0[a12320]: [GSM Task|fsm_sm] fsmdef.c:1301: SIPCC-FSM: 1/18, fsmdef_init_dcb: call_not_counted_in_mnc_bt = FALSE
12:53:51     INFO -  0[a12320]: [GSM Task|fsm_sm] fsm.c:157: SIPCC-GSM_DBG_PTR: FSM 18  : fsm_get_fcb_by_call_id_and_type    : fcb= 04B80000
12:53:51     INFO -  0[a12320]: [GSM Task|fsm_sm] fsm.c:157: SIPCC-GSM_DBG_PTR: FSM 18  : fsm_get_fcb_by_call_id_and_type    : fcb= 04B80020
12:53:51     INFO -  0[a12320]: [GSM Task|fsm_sm] fsm.c:157: SIPCC-GSM_DBG_PTR: FSM 18  : fsm_get_fcb_by_call_id_and_type    : fcb= 04B80040
12:53:51     INFO -  0[a12320]: [GSM Task|fsm_sm] fsm.c:157: SIPCC-GSM_DBG_PTR: FSM 18  : fsm_get_fcb_by_call_id_and_type    : fcb= 04B80060
12:53:51     INFO -  0[a12320]: [GSM Task|fsm_sm] fsmdef.c:3975: SIPCC-FSM: fsmdef_ev_setpeerconnection: Setting peerconnection handle for (1/18) to 691294882cacb60d
12:53:51     INFO -  0[a12320]: [GSM Task|def] fsm.c:346: SIPCC-FSM: 1/18, fsm_change_state: DEF: IDLE -> STABLE
12:53:51     INFO -  0[a12320]: [GSM Task|def] dcsm.c:397: SIPCC-DCSM: dcsm_update_gsm_state: 18 : DCSM_READY --> DCSM_READY
12:53:51     INFO -  0[a12320]: [GSM Task|def] sm.c:65: SIPCC-GSM: 1/18, sm_process_event: DEF   :(IDLE:SETPEERCONNECTION )
12:53:51     INFO -  (ice/ERR) ICE(PC:691294882cacb60d): All could not pair new trickle candidate
12:53:51     INFO -  (ice/ERR) ICE(PC:691294882cacb60d): All could not pair new trickle candidate
12:53:51     INFO -  (ice/ERR) ICE(PC:691294882cacb60d): All could not pair new trickle candidate
12:53:51     INFO -  (ice/ERR) ICE(PC:691294882cacb60d): All could not pair new trickle candidate
12:53:51     INFO -  (ice/ERR) ICE(PC:691294882cacb60d): All could not pair new trickle candidate
12:53:51     INFO -  (ice/ERR) ICE(PC:691294882cacb60d): All could not pair new trickle candidate
12:53:51     INFO -  0[a0f140]: [main|PeerConnectionImpl] PeerConnectionImpl.cpp:401: sipcc::PeerConnectionImpl::PeerConnectionImpl: PeerConnectionImpl constructor for
12:53:51     INFO -  0[a0f140]: [main|CC_SIPCCCall] CC_SIPCCCall.cpp:36: Creating  CC_SIPCCCall 65555
12:53:51     INFO -  (ice/NOTICE) No STUN servers specified
12:53:51     INFO -  (ice/NOTICE) No TURN servers specified
12:53:51     INFO -  0[a11de0]: [CCAPP Task|def] ccapi.c:1163: SIPCC-CC_API: 1/19, cc_int_feature2: UI -> GSM: SETPEERCONNECTION
12:53:51     INFO -  (ice/ERR) ICE(PC:d27892a86b42d76e): All could not pair new trickle candidate
12:53:51     INFO -  (ice/ERR) ICE(PC:d27892a86b42d76e): All could not pair new trickle candidate
12:53:51     INFO -  (ice/ERR) ICE(PC:d27892a86b42d76e): All could not pair new trickle candidate
12:53:51     INFO -  (ice/ERR) ICE(PC:d27892a86b42d76e): All could not pair new trickle candidate
12:53:51     INFO -  (ice/ERR) ICE(PC:d27892a86b42d76e): All could not pair new trickle candidate
12:53:51     INFO -  (ice/ERR) ICE(PC:d27892a86b42d76e): All could not pair new trickle candidate
12:53:51     INFO -  0[a12320]: [GSM Task|def] dcsm.c:532: SIPCC-DCSM: dcsm_process_event: DCSM 22  :(DCSM_READY:SETPEERCONNECTION )
12:53:51     INFO -  0[a12320]: [GSM Task|fsm_sm] fsm.c:232: SIPCC-GSM_DBG_PTR: FSM 0   : fsm_get_fcb_by_call_id             : fcb= 04B80080
12:53:51     INFO -  0[a12320]: [GSM Task|fsm_sm] fsm.c:266: SIPCC-GSM_DBG_PTR: FSM 19  : fsm_get_new_fcb                    : fcb= 04B80080
12:53:51     INFO -  0[a12320]: [GSM Task|fsm_sm] fsm.c:232: SIPCC-GSM_DBG_PTR: FSM 0   : fsm_get_fcb_by_call_id             : fcb= 04B800A0
12:53:51     INFO -  0[a12320]: [GSM Task|fsm_sm] fsm.c:266: SIPCC-GSM_DBG_PTR: FSM 19  : fsm_get_new_fcb                    : fcb= 04B800A0
12:53:51     INFO -  0[a12320]: [GSM Task|fsm_sm] fsm.c:232: SIPCC-GSM_DBG_PTR: FSM 0   : fsm_get_fcb_by_call_id             : fcb= 04B800C0
12:53:51     INFO -  0[a12320]: [GSM Task|fsm_sm] fsm.c:266: SIPCC-GSM_DBG_PTR: FSM 19  : fsm_get_new_fcb                    : fcb= 04B800C0
12:53:51     INFO -  0[a12320]: [GSM Task|fsm_sm] fsm.c:232: SIPCC-GSM_DBG_PTR: FSM 0   : fsm_get_fcb_by_call_id             : fcb= 04B800E0
12:53:51     INFO -  0[a12320]: [GSM Task|fsm_sm] fsm.c:266: SIPCC-GSM_DBG_PTR: FSM 19  : fsm_get_new_fcb                    : fcb= 04B800E0
12:53:51     INFO -  0[a12320]: [GSM Task|fsm_sm] sm.c:46: SIPCC-FSM: sm_process_event: DEF 19  : 66732AEDx: sm entry: (IDLE:SETPEERCONNECTION)
12:53:51     INFO -  0[a12320]: [GSM Task|fsm_sm] fsmdef.c:3936: SIPCC-FSM: fsmdef_ev_setpeerconnection: Entered.
12:53:51     INFO -  0[a12320]: [GSM Task|fsm_sm] fsmdef.c:919: SIPCC-FSM: DEF 0   /0: fsmdef_get_dcb_by_call_id          : dcb= 082661CC
12:53:51     INFO -  0[a12320]: [GSM Task|fsm_sm] fsmdef.c:1455: SIPCC-FSM: DEF 19  /0: fsmdef_get_new_dcb                 : dcb= 082661CC
12:53:51     INFO -  0[a12320]: [GSM Task|fsm_sm] fsmdef.c:1301: SIPCC-FSM: 1/19, fsmdef_init_dcb: call_not_counted_in_mnc_bt = FALSE
12:53:51     INFO -  0[a12320]: [GSM Task|fsm_sm] fsm.c:157: SIPCC-GSM_DBG_PTR: FSM 19  : fsm_get_fcb_by_call_id_and_type    : fcb= 04B80080
12:53:51     INFO -  0[a12320]: [GSM Task|fsm_sm] fsm.c:157: SIPCC-GSM_DBG_PTR: FSM 19  : fsm_get_fcb_by_call_id_and_type    : fcb= 04B800A0
12:53:51     INFO -  0[a12320]: [GSM Task|fsm_sm] fsm.c:157: SIPCC-GSM_DBG_PTR: FSM 19  : fsm_get_fcb_by_call_id_and_type    : fcb= 04B800C0
12:53:51     INFO -  0[a12320]: [GSM Task|fsm_sm] fsm.c:157: SIPCC-GSM_DBG_PTR: FSM 19  : fsm_get_fcb_by_call_id_and_type    : fcb= 04B800E0
12:53:51     INFO -  0[a12320]: [GSM Task|fsm_sm] fsmdef.c:3975: SIPCC-FSM: fsmdef_ev_setpeerconnection: Setting peerconnection handle for (1/19) to d27892a86b42d76e
12:53:51     INFO -  0[a12320]: [GSM Task|def] fsm.c:346: SIPCC-FSM: 1/19, fsm_change_state: DEF: IDLE -> STABLE
12:53:51     INFO -  0[a12320]: [GSM Task|def] dcsm.c:397: SIPCC-DCSM: dcsm_update_gsm_state: 19 : DCSM_READY --> DCSM_READY
12:53:51     INFO -  0[a12320]: [GSM Task|def] sm.c:65: SIPCC-GSM: 1/19, sm_process_event: DEF   :(IDLE:SETPEERCONNECTION )
12:53:54  WARNING -  TEST-UNEXPECTED-FAIL | file:///C:/slave/test/build/tests/reftest/tests/dom/media/tests/crashtests/863929.html | Exited with code -1073741819 during test run
12:53:54     INFO -  INFO | automation.py | Application ran for: 0:01:09.924000
12:53:54     INFO -  INFO | zombiecheck | Reading PID log: c:\users\cltbld\appdata\local\temp\tmp6s_fyppidlog
12:53:54     INFO -  mozcrash INFO | Downloading symbols from: http://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-inbound-win32/1380306818/firefox-27.0a1.en-US.win32.crashreporter-symbols.zip
12:54:10  WARNING -  PROCESS-CRASH | file:///C:/slave/test/build/tests/reftest/tests/dom/media/tests/crashtests/863929.html | application crashed [@ ScanShape]
12:54:10     INFO -  Crash dump filename: c:\users\cltbld\appdata\local\temp\tmptu2c_z.mozrunner\minidumps\2e26b8bd-f9cd-48b3-b723-7846a225d4ad.dmp
12:54:10     INFO -  Operating system: Windows NT
12:54:10     INFO -                    6.1.7601 Service Pack 1
12:54:10     INFO -  CPU: x86
12:54:10     INFO -       GenuineIntel family 6 model 30 stepping 5
12:54:10     INFO -       8 CPUs
12:54:10     INFO -  Crash reason:  EXCEPTION_ACCESS_VIOLATION_READ
12:54:10     INFO -  Crash address: 0x2e3fc174
12:54:10     INFO -  Thread 0 (crashed)
12:54:10     INFO -   0  mozjs.dll!ScanShape [Marking.cpp:f691041334b8 : 877 + 0x3b]
12:54:10     INFO -      eip = 0x6742e832   esp = 0x002bed24   ebp = 0x002bed34   ebx = 0x2e3fc174
12:54:10     INFO -      esi = 0x2e3fc0b0   edi = 0x00000010   eax = 0x2e303120   ecx = 0x00000031
12:54:10     INFO -      edx = 0x00000624   efl = 0x00210202
12:54:10     INFO -      Found by: given as instruction pointer in context
12:54:10     INFO -   1  mozjs.dll!js::GCMarker::processMarkStackTop(js::SliceBudget &) [Marking.cpp:f691041334b8 : 1471 + 0x74]
12:54:10     INFO -      eip = 0x6742f0d8   esp = 0x002bed3c   ebp = 0x002bed68
12:54:10     INFO -      Found by: call frame info
12:54:10     INFO -   2  mozjs.dll!js::GCMarker::drainMarkStack(js::SliceBudget &) [Marking.cpp:f691041334b8 : 1532 + 0x7]
12:54:10     INFO -      eip = 0x6742f360   esp = 0x002bed70   ebp = 0x002bed7c
12:54:10     INFO -      Found by: call frame info
12:54:10     INFO -   3  mozjs.dll!IncrementalCollectSlice [jsgc.cpp:f691041334b8 : 4352 + 0x1b]
12:54:10     INFO -      eip = 0x674d5479   esp = 0x002bed84   ebp = 0x002bedb0
12:54:10     INFO -      Found by: call frame info
12:54:10     INFO -   4  mozjs.dll!GCCycle [jsgc.cpp:f691041334b8 : 4511 + 0x10]
12:54:10     INFO -      eip = 0x674d5c09   esp = 0x002bedb8   ebp = 0x002bede0
12:54:10     INFO -      Found by: call frame info
12:54:10     INFO -   5  mozjs.dll!Collect [jsgc.cpp:f691041334b8 : 4652 + 0x1c]
12:54:10     INFO -      eip = 0x674d5dc9   esp = 0x002bede8   ebp = 0x002bee1c
12:54:10     INFO -      Found by: call frame info
12:54:10     INFO -   6  mozjs.dll!js::GCSlice(JSRuntime *,js::JSGCInvocationKind,JS::gcreason::Reason,__int64) [jsgc.cpp:f691041334b8 : 4688 + 0x12]
12:54:10     INFO -      eip = 0x674d5ee8   esp = 0x002bee24   ebp = 0x002bee3c
12:54:10     INFO -      Found by: call frame info
12:54:10     INFO -   7  mozjs.dll!JS::IncrementalGC(JSRuntime *,JS::gcreason::Reason,__int64) [jsfriendapi.cpp:f691041334b8 : 197 + 0x16]
12:54:10     INFO -      eip = 0x674c7fda   esp = 0x002bee44   ebp = 0x002bee58
12:54:10     INFO -      Found by: call frame info
12:54:10     INFO -   8  xul.dll!nsJSContext::GarbageCollectNow(JS::gcreason::Reason,nsJSContext::IsIncremental,nsJSContext::IsCompartment,nsJSContext::IsShrinking,__int64) [nsJSEnvironment.cpp:f691041334b8 : 1971 + 0x14]
12:54:10     INFO -      eip = 0x65fe32d4   esp = 0x002bee60   ebp = 0x002bee7c
12:54:10     INFO -      Found by: call frame info
Looks like a general JS GC failure; can happen in most any test I suspect
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 920266
You need to log in before you can comment on or make changes to this bug.