Poor formatting of JS errors in workers

RESOLVED FIXED in mozilla27

Status

()

Core
DOM: Workers
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: billm, Assigned: billm)

Tracking

unspecified
mozilla27
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Created attachment 811444 [details] [diff] [review]
fix-worker-error-handling

Every time I start up Firefox I get this error on stderr:

reference to undefined property exn.stack

There's no \n after it, so it gets mixed in with other stuff. It turns out a worker is generating it. This patch fixes the formatting of error printing on stderr for workers so we get a filename, line number, and a terminating \n.
Attachment #811444 - Flags: review?(bent.mozilla)
Comment on attachment 811444 [details] [diff] [review]
fix-worker-error-handling

Review of attachment 811444 [details] [diff] [review]:
-----------------------------------------------------------------

Yay, thanks!
Attachment #811444 - Flags: review?(bent.mozilla) → review+
Duplicate of this bug: 903672
Yay, thanks!  This has been irritating me for quite a while.  I didn't look in workers so I guess that's why I didn't find it.
It's so sad, that whole error reporting function is so elaborate and then I goofed the last printf...

Comment 6

4 years ago
https://hg.mozilla.org/mozilla-central/rev/717d363cbd7d
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla27
You need to log in before you can comment on or make changes to this bug.