Safaribooksonline site looks bad in Firefox for Android / shows mobile instead of touch version

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: Swarnava, Unassigned)

Tracking

Trunk
ARM
Android

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [website-compatibility] [tier1] [serversniff][country-all][contactready], URL)

(Reporter)

Description

5 years ago
There are several issues with GMail in Firefox for Android:

(1) m.safaribooksonline.com shows the simple version instead of the touch version
(2) When forced into the touch version (using Phony add-on set to "Android") the layout is really broken, icons are busted, which makes the page unusable.

Comment 1

5 years ago
Confirmed. Simple version instead of the touch.
So the simple version is working, if we want to go to ask for the touch version, we need to understand the issues before. 

It is not about "GMail in Firefox for Android" but Safaribooks :)
Whiteboard: [website-compatibility] → [website-compatibility] [tier1]
(Reporter)

Comment 2

5 years ago
sorry for. thetypo :P
Server side sniffing, with iOS getting redirected to the newer mobile site.

mtaylor at omg-2 in ~/dev/compat/commitgrep on relative-date-grep
$ http --print=Hh GET https://m.safaribooksonline.com/ User-Agent:"$FFOS"
GET / HTTP/1.1
Accept: */*
Accept-Encoding: gzip, deflate, compress
Host: m.safaribooksonline.com
User-Agent: Mozilla/5.0 (Mobile; rv:18.1) Gecko/18.1 Firefox/18.1

HTTP/1.1 302 Moved Temporarily
Connection: close
Content-Length: 0
Content-Type: text/plain; charset=UTF-8
Date: Fri, 01 Nov 2013 16:49:14 GMT
Location: https://m.safaribooksonline.com/hd/home
Server: Apache
Set-Cookie: JSESSIONID=6D383493051A784F53FDD2B010D24AD1.sm01; Path=/; Secure
Set-Cookie: JSESSIONID=6D383493051A784F53FDD2B010D24AD1.sm01; Path=/

mtaylor at omg-2 in ~/dev/compat/commitgrep on relative-date-grep
$ http --print=Hh GET https://m.safaribooksonline.com/ User-Agent:"$FFA"
GET / HTTP/1.1
Accept: */*
Accept-Encoding: gzip, deflate, compress
Host: m.safaribooksonline.com
User-Agent: Mozilla/5.0 (Android; Mobile; rv:25.0) Gecko/25.0 Firefox/25.0

HTTP/1.1 200 OK
Cache-Control: no-store, no-cache, must-revalidate
Cache-Control: post-check=0, pre-check=0
Connection: close
Content-Encoding: gzip
Content-Length: 981
Content-Type: text/html; charset=UTF-8
Date: Fri, 01 Nov 2013 16:49:18 GMT
Expires: Thu, 01 Jan 1970 00:00:00 GMT
Pragma: no-cache
Server: Apache
Set-Cookie: JSESSIONID=859199AE372DC0976162424CFC4920C6.sm01; Path=/; Secure
Set-Cookie: JSESSIONID=859199AE372DC0976162424CFC4920C6.sm01; Path=/

mtaylor at omg-2 in ~/dev/compat/commitgrep on relative-date-grep
$ http --print=Hh GET https://m.safaribooksonline.com/ User-Agent:"$IOS"
GET / HTTP/1.1
Accept: */*
Accept-Encoding: gzip, deflate, compress
Host: m.safaribooksonline.com
User-Agent: Mozilla/5.0 (iPhone; CPU iPhone OS 6_0 like Mac OS X) AppleWebKit/536.26 (KHTML, like Gecko) Version/6.0 Mobile/10A5376e Safari/8536.25

HTTP/1.1 302 Moved Temporarily
Connection: close
Content-Length: 0
Content-Type: text/plain; charset=UTF-8
Date: Fri, 01 Nov 2013 16:49:24 GMT
Location: https://m.safaribooksonline.com/hd/home
Server: Apache
Set-Cookie: JSESSIONID=716D3D83F9E31583E368817A9EBF3D8D.sm01; Path=/; Secure
Set-Cookie: JSESSIONID=716D3D83F9E31583E368817A9EBF3D8D.sm01; Path=/

Looking through the source of the HD site, they're using jQuery Mobile and all the CSS has the appropriate -moz- prefixes so just sending Firefox for Android and Firefox OS to the /hd/home site should basically just work™.
Whiteboard: [website-compatibility] [tier1] → [website-compatibility] [tier1] [serversniff][country-all][contactready]
(Reporter)

Comment 4

5 years ago
looks like Firefox is now showing Touch version!
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.