Closed Bug 921732 Opened 6 years ago Closed 6 years ago

Bookmarks widget has wrong icon in the palette and bigger font in the menu

Categories

(Firefox :: Toolbars and Customization, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 28

People

(Reporter: ge3k0s, Assigned: Gijs)

References

(Blocks 1 open bug)

Details

(Whiteboard: [Australis:M9][Australis:P2])

Attachments

(1 file)

Currently the bookmarks widget shows several icons when placed in the palette and a bigger font size when placed in the menu. It needs a proper icon and the font size should be adjusted.
Whiteboard: [Australis:M?][Australis:P4]
Summary: Bookmarks widget has no icon in the palette and has bigger font in the menu → Bookmarks widget has wrong icon in the palette and bigger font in the menu
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [Australis:M?][Australis:P4] → [Australis:M?][Australis:P2]
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
This fixes the full icon set (the dropmarker was being shown inadvertewn inadvertently), it fixes the icon size on OS X retina (too small because it didn't match any of the panel minsize stuff), and it fixes the text size.
Attachment #825559 - Flags: review?(mdeboer)
Comment on attachment 825559 [details] [diff] [review]
fix bookmarks widget icon and font,

Review of attachment 825559 [details] [diff] [review]:
-----------------------------------------------------------------

::: browser/themes/shared/customizableui/panelUIOverlay.inc.css
@@ -178,2 @@
>  toolbarpaletteitem[place="palette"] > toolbarbutton > .toolbarbutton-icon,
> -toolbarpaletteitem[place="palette"] > toolbaritem > toolbarbutton > .toolbarbutton-icon,

Was cleaning up these selectors also part of this bug?
Attachment #825559 - Flags: review?(mdeboer)
Comment on attachment 825559 [details] [diff] [review]
fix bookmarks widget icon and font,

Review of attachment 825559 [details] [diff] [review]:
-----------------------------------------------------------------

No, but those selectors were redundant, because those cases are already selected by the cui-areatype="menu-panel" selectors above it, and as I was editing this rule anyway, I removed them.
Attachment #825559 - Flags: review?(mdeboer)
Comment on attachment 825559 [details] [diff] [review]
fix bookmarks widget icon and font,

Review of attachment 825559 [details] [diff] [review]:
-----------------------------------------------------------------

Alright, I checked for possible regressions for toolbaritems, but there appear to be none, which is nize. Thanks!
Attachment #825559 - Flags: review?(mdeboer) → review+
https://hg.mozilla.org/projects/ux/rev/8980172a9d2f
Whiteboard: [Australis:M?][Australis:P2] → [Australis:M9][Australis:P2][fixed-in-ux]
https://hg.mozilla.org/mozilla-central/rev/8980172a9d2f
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [Australis:M9][Australis:P2][fixed-in-ux] → [Australis:M9][Australis:P2]
Target Milestone: --- → Firefox 28
You need to log in before you can comment on or make changes to this bug.