Multiple master password prompts with multiple Google CalDAV OAuth2 calendars

RESOLVED DUPLICATE of bug 901329

Status

RESOLVED DUPLICATE of bug 901329
5 years ago
5 years ago

People

(Reporter: mmecca, Assigned: mmecca)

Tracking

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
We currently use the password manager to store the refresh token for each OAuth2 calendar, but nsILoginManager.findLogins triggers the master password dialog if one is set and it hasn't been entered already. Since we asynchronously load the refresh token for all calendars at startup, we get a master password dialog for each calendar.
(Assignee)

Comment 1

5 years ago
Created attachment 811535 [details] [diff] [review]
Fix v1

This adds an asynchronous wrapper for passwordManagerGet, which queues the login requests to prevent subsequent lookups until the first one (and potential master password prompt) is complete.

In order to make this asynchronous I had to change the way the oauth refreshToken property getter works, do you think this could cause issues elsewhere?
Attachment #811535 - Flags: review?(philipp)
(Assignee)

Updated

5 years ago
Attachment #811535 - Flags: review?(philipp)
(Assignee)

Updated

5 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 901329
You need to log in before you can comment on or make changes to this bug.