Closed Bug 921770 Opened 7 years ago Closed 7 years ago

make: *** js/src: No such file or directory. Build failure with --with-libxul-sdk

Categories

(Firefox Build System :: General, defect)

x86_64
Linux
defect
Not set
normal

Tracking

(firefox26 fixed, firefox27 fixed)

RESOLVED FIXED
mozilla27
Tracking Status
firefox26 --- fixed
firefox27 --- fixed

People

(Reporter: glandium, Assigned: glandium)

References

Details

Attachments

(2 files)

No description provided.
Assignee: nobody → mh+mozilla
Status: NEW → ASSIGNED
Attached patch Patch for auroraSplinter Review
Attachment #811588 - Flags: review?(gps)
Attachment #811587 - Flags: review?(gps) → review+
Attachment #811588 - Flags: review?(gps) → review+
Comment on attachment 811588 [details] [diff] [review]
Patch for aurora

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 896797
User impact if declined: Build failures when building an app with --with-libxul-sdk.
Testing completed (on m-c, etc.): Tested on debian packaging.
Risk to taking this patch (and alternatives if risky): The patches only disables a few parts of Makefile.in when LIBXUL_SDK is defined, which it is not on normal builds.
String or IDL/UUID changes made by this patch: None.
Attachment #811588 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/4f64e01f2e98
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla27
Attachment #811588 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.