Closed Bug 921822 Opened 9 years ago Closed 9 years ago

standalone js's make install fails

Categories

(Firefox Build System :: General, defect)

x86_64
Linux
defect
Not set
normal

Tracking

(firefox26 fixed, firefox27 fixed)

RESOLVED FIXED
mozilla27
Tracking Status
firefox26 --- fixed
firefox27 --- fixed

People

(Reporter: glandium, Assigned: glandium)

References

Details

Attachments

(1 file)

These snippets from Makefile.in are what fails:

install:: $(EXPORTS)
        $(SYSINSTALL) $^ $(DESTDIR)$(includedir)/$(LIBRARY_NAME)

install:: $(EXPORTS_js)
        $(SYSINSTALL) $^ $(DESTDIR)$(includedir)/$(LIBRARY_NAME)/js

because since bug 896797, EXPORTS and EXPORTS_js are empty.

Those rules need to be replaced by something using the install manifest.
Attachment #811664 - Flags: review?(gps) → review+
Comment on attachment 811664 [details] [diff] [review]
Use existing install manifest for make install in js standalone builds

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 896797
User impact if declined: make install doesn't install the most important js headers in standalone js builds.
Testing completed (on m-c, etc.): Tested in debian packaging.
Risk to taking this patch (and alternatives if risky): NPOTB.
String or IDL/UUID changes made by this patch: None
Attachment #811664 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/3393dcd91694
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla27
Comment on attachment 811664 [details] [diff] [review]
Use existing install manifest for make install in js standalone builds

a=npotb :)
Attachment #811664 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.