[B2G][Helix][Display][wufumin]The phone displays white screen which standby for some time

RESOLVED WONTFIX

Status

P1
critical
RESOLVED WONTFIX
5 years ago
7 months ago

People

(Reporter: lecky.wanglei, Unassigned)

Tracking

unspecified

Firefox Tracking Flags

(blocking-b2g:-)

Details

(Whiteboard: [POVB])

Attachments

(22 attachments, 4 obsolete attachments)

546.70 KB, image/jpeg
Details
612.06 KB, image/jpeg
Details
359.14 KB, text/plain
Details
414.84 KB, text/plain
Details
1.58 MB, application/x-zip-compressed
Details
149.89 KB, image/png
Details
6.57 MB, application/x-rar
Details
8.58 MB, application/x-rar
Details
1.26 MB, application/x-zip-compressed
Details
1.74 MB, application/x-rar
Details
9.72 MB, application/x-rar
Details
9.72 MB, application/x-rar
Details
9.72 MB, application/x-rar
Details
8.58 MB, application/x-rar
Details
8.58 MB, application/x-rar
Details
8.58 MB, application/x-rar
Details
5.81 MB, application/x-rar
Details
4.90 KB, patch
Details | Diff | Splinter Review
243.81 KB, application/x-rar
Details
92.50 KB, text/plain
Details
1.48 MB, application/x-rar
Details
211.54 KB, text/plain
Details
(Reporter)

Description

5 years ago
User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; aff-kingsoft-ciba)

Steps to reproduce:

1.put the phone into sleep modem for time
2.wake up mobile




Actual results:

we can wake up success



Expected results:

1.sometimes,I only can see white screen,just like attachment.
(Reporter)

Updated

5 years ago
Severity: normal → blocker
blocking-b2g: --- → hd?
Priority: -- → P1
(Reporter)

Comment 1

5 years ago
My build info as following:
gaia:c0ea0a4943dc8d3751b07f5b5c5d3abe06364a14  
gecko:170f9e477571127cd40997fa2abe262ed43f0e4d
(Reporter)

Updated

5 years ago
Severity: blocker → critical
(Reporter)

Comment 2

5 years ago
from the log ,We can see some error as follow.

09-29 17:47:31.199: W/QCLOC(160): Seeking NTP time from time.gpsonextra.net
09-29 17:47:31.199: D/QCLOC(160): OnTransportStatus: 804b0003
09-29 17:47:31.199: D/QCLOC(160): OnInputStreamReady()
09-29 17:47:31.199: D/QCLOC(160): read 0 bytes (rv=804b0010)
09-29 17:47:31.199: W/QCLOC(160): NTP time download failed
09-29 17:47:31.199: W/QCLOC(160): NTP time download scheduled for 300s
09-29 17:42:11.619: E/libQcomUI(160): sfdump: [???]-Composition, Layer[0] SrcBuff[-1x-1] SrcCrop[0l, 0t, 480r, 800b] DispFrame[0l, 0t, 480r, 800b] Composition-type = Copybit, Format = None, Orientation = ROT_0, Flags = 
09-29 17:42:11.619: E/libQcomUI(160): sfdump: Layer[0] private-handle is invalid.
(Reporter)

Comment 3

5 years ago
For the log ,I explain it. I want grab dump by this way.

**************************************************
adb shell setprop debug.sf.dump.enable true 
adb shell setprop debug.sf.dump.png 10

**********************
If the normal screen ,we can grab success.but when display white screen ,we can not grab success.
I get touch with our engineer,If we can not grab success.It is some worry occurs in the upper layer.
(Reporter)

Comment 4

5 years ago
Created attachment 811681 [details]
unlockscreen1.jpg
(Reporter)

Comment 5

5 years ago
Created attachment 811682 [details]
lockscreen1.jpg
all the log info in comment 2 seems to be from bsp?

Vincent do you have any suggestions?
Also ni?diego
Flags: needinfo?(vlin)
Flags: needinfo?(dwilson)
Can you share the full log please?
Flags: needinfo?(dwilson)
(Reporter)

Comment 8

5 years ago
hi,I am sorry ,I don't save the full log.
becasue the problem can't repoduce 100. so only next time ,I can gvie you full log.

can you give me some possible causes.From the  phenomenon ,I can know the layer don't call up  hwc_set(hwc_composer_device_t *dev,
        hwc_display_t dpy,
        hwc_surface_t sur,
        hwc_layer_list_t* list)

why?
(Reporter)

Updated

5 years ago
Flags: needinfo?(dwilson)
(In reply to lecky from comment #8)
> hi,I am sorry ,I don't save the full log.
> becasue the problem can't repoduce 100. so only next time ,I can gvie you
> full log.
> 
> can you give me some possible causes.From the  phenomenon ,I can know the
> layer don't call up  hwc_set(hwc_composer_device_t *dev,
>         hwc_display_t dpy,
>         hwc_surface_t sur,
>         hwc_layer_list_t* list)
> 
> why?

There are many reasons why this could be happening. Unfortunately can't reproduce this on my hardware. Please make sure to collect logs the next time you see this issue.
Flags: needinfo?(vlin)
Flags: needinfo?(dwilson)
(Reporter)

Comment 10

5 years ago
Created attachment 813831 [details]
ddmslog.txt
(Reporter)

Comment 11

5 years ago
hi,
 I share the full log please.Please check it.
Flags: needinfo?(dwilson)
(Reporter)

Updated

5 years ago
Priority: P1 → P2
(Reporter)

Updated

5 years ago
Priority: P2 → P1
(Reporter)

Comment 12

5 years ago
hi, Diego Wilson 
what do you think abou this issue?
@vlin This seems like a layout issue to me. Do you know who can help out with this?
Flags: needinfo?(dwilson) → needinfo?(vlin)
The symptom and screenshots here are worth a hd+, looks pretty bad.

Diego, what clues did you see in the logs? so i can see who may be able to help if vlin doesnt know.
blocking-b2g: hd? → hd+
Flags: needinfo?(dwilson)
The only clue is this:

> 09-29 17:49:39.639: E/libQcomUI(160): sfdump: [???]-Composition, Layer[0] SrcBuff[-1x-1] SrcCrop[0l, 0t, 480r, 800b] DispFrame[0l, 0t, 480r, 800b] Composition-type = Copybit, Format = None, Orientation = ROT_0, Flags = 
09-29 17:49:39.639: E/libQcomUI(160): sfdump: Layer[0] private-handle is invalid.

I think that's supposed to mean there's a bad graphic buffer.
Flags: needinfo?(dwilson)

Comment 16

5 years ago
A duplicate case of 907155?
If not, please change the bug status.
Many thanks!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 907155

Comment 17

5 years ago
I have no idea about layout folks.
Flags: needinfo?(vlin)
Likely not a dupe. The phenomenon is different.

This bug shows white screen with notification bar intact while bug 907155 has nothing but the backlight on.

Tim, do you know who can help here?
Status: RESOLVED → UNCONFIRMED
Flags: needinfo?(timdream)
Resolution: DUPLICATE → ---
(Reporter)

Comment 19

5 years ago
Created attachment 818411 [details]
white—screen.txt
(Reporter)

Comment 20

5 years ago
yesterday   we find another device displays white screen which after monkey test .

from the log ,We can see some error log.please see the file of white—screen.txt 

01-06 15:55:37.139: E/GeckoConsole(159): [JavaScript Error: "can't access dead object" {file: "chrome://global/content/BrowserElementPanning.js" line: 474}]
01-06 15:55:37.419: E/GeckoConsole(159): [JavaScript Error: "can't access dead object" {file: "chrome://global/content/BrowserElementPanning.js" line: 474}]
01-06 15:55:37.659: E/GeckoConsole(159): [JavaScript Error: "can't access dead object" {file: "chrome://global/content/BrowserElementPanning.js" line: 474}]

I don't know why . I am not sure wheter the same root cause .
(Reporter)

Updated

5 years ago
Duplicate of this bug: 927386
An educated guess: the white screen is an app frame OOM'd in foreground. Somehow the app is OOM'd but (A) the window manager did not closed the frame properly upon receiving the mozbrowsererror fatal event, or (B) the event does not fire in System app at all.

Greg, could you try to reproduce and isolate the problem? Alive, could you help Greg doing that?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(timdream)
Flags: needinfo?(gweng)
Flags: needinfo?(alive)
So follow the guess, if I make a app OOM (I know at least one app would be), it may show the same symptom (?). I'll try it to see what would happen.
Flags: needinfo?(gweng)
There're many possibilities here.

Look like not a visibility issue to me.
If the app turns white, the statusbar would be there.
This could only happen when there's fullscreen app is foreground.

BTW, how to identify:
0) For Tim's guess, Dump in 'mozbrowserappclose' or 'mozbrowsererror' event handler in WindowManager.
1) Grep all setVisible calls in system. Now it should be grouped in AppWindow.setVisible, check if the visibility is turned on.
2) Dump http://mxr.mozilla.org/mozilla-central/source/dom/browser-element/BrowserElementParent.jsm#498
   this._frameLoader.visible is the finally check point.
3) It may also be nested visibility issue? check the system app's visibility is turned on when power button is clicked
   http://mxr.mozilla.org/mozilla-central/source/b2g/chrome/content/shell.js#464


Which gaia branch does this happen?
This is on the v1.1HD with 

(In reply to lecky from comment #1)
> My build info as following:
> gaia:c0ea0a4943dc8d3751b07f5b5c5d3abe06364a14  
> gecko:170f9e477571127cd40997fa2abe262ed43f0e4d
(Reporter)

Comment 26

5 years ago
yes ,this is  on the v1.1HD.
(Reporter)

Comment 27

5 years ago
If we find the issue.sometimes ,some screen display normal.for example.the homescreen and the the screen of set.
I guess some error about the app of homescreen.
(Reporter)

Comment 28

5 years ago
I am sorry. I make a mistake.
My means some some screen display normal.for example.the lockscreen and the screen of set.
Flags: needinfo?(alive)

Comment 29

5 years ago
(In reply to lecky from comment #28)
> I am sorry. I make a mistake.
> My means some some screen display normal.for example.the lockscreen and the
> screen of set.

What's "the screen of set"? Do you mean the pull down "quick setting"? (A dark background with five toggles: wifi, 3G, BT, airplane mode, and settings)

So are you trying to say: you think the problem is only on Homescreen (it becomes white), but other system screens like lockscreen and quick settings are good? (correct me if I misunderstand.)
Flags: needinfo?(lecky.wanglei)
(Reporter)

Comment 30

5 years ago
yes,If we pull down "quick setting",display normal.at the same time ,If we sleep the phone and wake up the phone ,we find the lockscreen display norma.

So we can find the issue only the homescreen.
Flags: needinfo?(lecky.wanglei)
(Reporter)

Updated

5 years ago
Flags: needinfo?(ehung)

Comment 31

5 years ago
I believe Greg is looking this issue. I was jumping in for clarifying comment 28.
Flags: needinfo?(ehung)
(Reporter)

Comment 32

5 years ago
hi,Greg
Do you look this issue?
(Reporter)

Updated

5 years ago
Flags: needinfo?(gweng)
(Reporter)

Comment 33

5 years ago
Do you need me add some log to help you analyse?
thanks

wufumin
I've encountered one similar issue which would happen in Settings occasionally. When you slide in and out the settings' subpages, it sometimes become blank but with the status bar. Arthur says the animation may be the root cause of the symptom. However, I think that this issue may be just with the same symptom, it can be irrelevant after all.

Beside that, I can't reproduce this problem on my phone. I need to borrow more devices to check this. Can lecky.wufumin provide more details in STR? Like waiting under what situation (lots of running but background apps? or only one heavy duty app like mem buster?), or how frequent this happened?
Flags: needinfo?(gweng)
(Reporter)

Comment 35

5 years ago
hi,Greg Weng 

you can try fllow way .

1.Monkey test. In the monkey test ,we find there devices.
2. Open storage mode, take pictures , sleep and wake up the phone.we find two devices.
(In reply to lecky from comment #35)
> hi,Greg Weng 
> 
> you can try fllow way .
> 
> 1.Monkey test. In the monkey test ,we find there devices.
> 2. Open storage mode, take pictures , sleep and wake up the phone.we find
> two devices.

We dont run monkey test.
Can you provide something else?
Flags: needinfo?(lecky.wanglei)
(Reporter)

Comment 37

5 years ago
I have no good way to repoduce the issue .But  you can give our some advice to analyse the issue.
Flags: needinfo?(lecky.wanglei)
(Reporter)

Updated

5 years ago
Flags: needinfo?(gweng)
It's still hard to reproduce. I follow the method to take picture and wait it to sleep, but nothing happened. If this would only happens on some specific build and even specific devices, it'll take me a long while to check the problem.
Flags: needinfo?(gweng)
(Reporter)

Comment 39

5 years ago
I plan to  increase the pressure test.Do you need me add some print log to help you analyse the problem.
What I need is a proper way to reproduce the bug. As I said, I've only encountered this in Settings, and it was not caused by sleeping. The second way to reproduce this by taking photos on a USB storage enabled device didn't work for me.

If this bug occurs on your devices frequently even in daily use or in some specific ways, that's good, and that means you may provide me a formal way to reproduce this with high enough successful rate. However if this bug is rare to be found, and it happens randomly, my best effort on this would be guessing what happened, breaking my device artificially with some programming tricks, and then hope the symptom it gives is exactly what we're looking for. That's the thing I'm going to do.
Keywords: qawanted
Set QA wanted to see if QA can help us with a substantial way to reproduce this.

Comment 42

5 years ago
Hi, all,

I cannot reproduce this bug on following builds.

* Test Build:
 + Mozilla Build:
 - Gaia:     366cb29c3ca9a25efcb95ed35d4395e613e099a5
 - Gecko:    http://hg.mozilla.org/releases/mozilla-b2g18_v1_1_0_hd/rev/369468c97d16
 - BuildID   20131029042204
 - Version   18.0
 => Cannot reproduce

 + Commercial Build:
 - Gaia:     1389e7b8f76c6b77b979799fafc3862f7c27028d
 - Gecko:   
 - BuildID   20131026030111
 - Version   18.0
 => Cannot reproduce

One more question, the build Lecky mentioned below is a very old build (3 months ago).
(In reply to lecky from comment #1)
> My build info as following:
> gaia:c0ea0a4943dc8d3751b07f5b5c5d3abe06364a14  
> gecko:170f9e477571127cd40997fa2abe262ed43f0e4d

This bug should become a potential issue or some patches fix it.
Could we request our partner to test it again with latest build to see if it still happen?
Many thanks!

Updated

5 years ago
Keywords: qawanted
Since it's not reproducible on our builds so far, set [POVB].
Whiteboard: [POVB]

Updated

5 years ago
Component: Gaia::System → Vendcom
(Reporter)

Comment 44

5 years ago
Hi,William Hsu

I will test again in our  latest version . If we have the same issue ,I will tell you .

but I want you give me some advice to add some log .From the log .we can solve the issue easily.

(In reply to William Hsu [:whsu] from comment #42)
> Hi, all,

I cannot reproduce this bug on following builds.

* Test Build:
 +
> Mozilla Build:
 - Gaia:     366cb29c3ca9a25efcb95ed35d4395e613e099a5
 -
> Gecko:   
> http://hg.mozilla.org/releases/mozilla-b2g18_v1_1_0_hd/rev/369468c97d16
 -
> BuildID   20131029042204
 - Version   18.0
 => Cannot reproduce

 +
> Commercial Build:
 - Gaia:     1389e7b8f76c6b77b979799fafc3862f7c27028d
 -
> Gecko:   
 - BuildID   20131026030111
 - Version   18.0
 => Cannot reproduce
> One more question, the build Lecky mentioned below is a very old build (3
> months ago).
(In reply to lecky from comment #1)
> My build info as
> following:
> gaia:c0ea0a4943dc8d3751b07f5b5c5d3abe06364a14  
>
> gecko:170f9e477571127cd40997fa2abe262ed43f0e4d

This bug should become a
> potential issue or some patches fix it.
Could we request our partner to test
> it again with latest build to see if it still happen?
Many thanks!
(Reporter)

Updated

5 years ago
Flags: needinfo?(whsu)

Comment 45

5 years ago
Hi, Greg,

Is it possible to add some debug logs to trace this issue?
Thanks!
Flags: needinfo?(whsu) → needinfo?(gweng)
(Reporter)

Comment 46

5 years ago
Hi,William Hsu
I find the issue again.I share the log again.
(Reporter)

Comment 47

5 years ago
Created attachment 828417 [details]
whitescreen.zip

Comment 48

5 years ago
Hi, Lecky,

Could you please provide the build information?
Gecko? Gaia?
Thanks!
Flags: needinfo?(lecky.wanglei)
As I said, I can't reproduce this bug, how can I get useful log for this?
All I can attach is the normal boot log.
Flags: needinfo?(gweng)
(Reporter)

Comment 50

5 years ago
Hi,William Hsu and Greg Weng

build information:
gaia:f601fe6e5edb7d5016c07abfad8f069af7354f7b
gecko:60d9e982e07e8d09e9d0e52bad6433c302c17f32
gonk-misc:ca9192d7ef6037016d4723647d86b72f7a410633

I have some questions.
first ,If we wake the phone from the sleep.the lockscreen display normal.I guess the issue has nothing to do with the lockscreen .
Second ,If we unlock screen,I only can see white screen which was supposed to be homescreen.
 so We use the adb shell b2g-info,we find  Homescre is ok.just like fllow.May be we can analsy the issue from the homescreen,what dou you think ? we need add some log from 
homescreen.js to display.next ,we will hold the reproduction method.


          NAME   PID NICE  USS  PSS  RSS VSIZE OOM_ADJ USER
           b2g   173    0 80.6 81.5 89.1 283.5       0 root
Preallocated a   504   18  7.8  8.3 13.9  64.0       6 root
Communications   737    0 32.4 33.2 40.5  98.5       1 app_737
    Homescreen 18790   18 15.4 16.1 23.4 146.6       2 app_18790
   Marketplace 20249   18 11.3 12.0 18.9  67.1       6 app_20249
      Messages 23257   18 14.4 15.2 22.7  86.2       2 app_23257
   AccuWeather 24597   18 14.9 15.7 23.0  77.5       2 app_24597
         Usage 27160   18  9.8 10.5 17.5  67.1       6 app_27160
      Settings 27210   18 30.3 31.2 38.7  93.5       6 app_27210
      Calendar 27471   18 15.2 16.0 23.4  72.2       6 app_27471
     HERE Maps 31417   18 14.5 15.2 22.5  74.2       6 app_31417
Flags: needinfo?(lecky.wanglei)
I am 99.99% sure homescreen won't be white. If visibility of homescreen is wrong then it just disappear(transparent).
The white you see must be something else, might be an app other than homescreen. Does pressing home button works?
(Reporter)

Comment 52

5 years ago
yes ,If we pressing home button ,the motor vibrate.
but we hold home button ,the white screen can not exit .
(In reply to lecky from comment #52)
> yes ,If we pressing home button ,the motor vibrate.
Do you mean only vibrate?
> but we hold home button ,the white screen can not exit .
Do you mean disappear and homescreen shows? is there a scaling animation?
(Reporter)

Comment 54

5 years ago
1.If we pressing home button ,only the motor vibrate.
2.If we hold home button ,we should see the scaling animation,just like the  attachment
Please just dump
document.getElementById('windows').innerHTML

when screen is unlocked.
(Reporter)

Comment 56

5 years ago
Created attachment 828549 [details]
device-2013-11-07-175210.png
(Reporter)

Comment 57

5 years ago
hi, thanks 

can you give move information about it.
Why ?and evey app should add the log?can you tell me where ?


Please just dump
document.getElementById('windows').innerHTML


(In reply to Alive Kuo [:alive][11/4-11/8 at SFO ww.] from comment #55)
> Please just dump
document.getElementById('windows').innerHTML

when screen
> is unlocked.
(Reporter)

Updated

5 years ago
Flags: needinfo?(alive)
Find out 'will-unlock' event handler in window_manager.js and
console.log(document.querySelector('.appWindow.active').outerHTML);
Flags: needinfo?(alive)
(Reporter)

Comment 59

5 years ago
hi,Alive Kuo
 if kill the  process of settings,we find that display  becomes normal.
I have some question.

1.why white screen can not exit ,if we we hold home button .
2. If we pull down "quick setting",display normal.but we kill the  process of settings,everything becomes normal.
(Reporter)

Updated

5 years ago
Flags: needinfo?(alive)
(Reporter)

Comment 60

5 years ago
hi,Alive Kuo
I think the problem  may occur in the setting.I don't know .
I guess the latency is often too long here. It seams UI thread can't digest the task in time or stop here.
(Reporter)

Comment 61

5 years ago
hi,Alive Kuo
I think the problem  may occur in the setting.
I guess the latency is often too long here. It seams UI thread can't digest the task in time or stop paint.
what do you think about this issue?
(Reporter)

Updated

5 years ago
Flags: needinfo?(alive) → needinfo?(timdream)
(Reporter)

Updated

5 years ago
Flags: needinfo?(gweng)
(Reporter)

Comment 62

5 years ago
if kill the  process of settings,we find that display  becomes normal.
I have some question.

1.why white screen can not exit ,if we we hold home button .
2. If we pull down "quick setting",display normal.but we kill the  process of settings,everything becomes normal.
(In reply to Tim Guan-tin Chien [:timdream] (MoCo-TPE) (please ni?) from comment #22)
> An educated guess: the white screen is an app frame OOM'd in foreground.
> Somehow the app is OOM'd but (A) the window manager did not closed the frame
> properly upon receiving the mozbrowsererror fatal event, or (B) the event
> does not fire in System app at all.

Greg, could you try to reproduce and
> isolate the problem? Alive, could you help Greg doing that?
I don't understand what is needed from me here.
Flags: needinfo?(timdream)

Comment 64

5 years ago
(In reply to lecky from comment #62)
> if kill the  process of settings,we find that display  becomes normal.
> I have some question.
> 
> 1.why white screen can not exit ,if we we hold home button .
> 2. If we pull down "quick setting",display normal.but we kill the  process
> of settings,everything becomes normal.

This is because "quick setting" is not part of Settings app, it belongs to System app.

So from your report, I can conclude the following points:
1. When you unlock screen, you see a white screen and it's possibly be Settings app, because if you kill the process of Settings app, the white screen is gone.
2. However, when you see the white screen, pressing home button won't take you back to homescreen, you still get stuck on the white screen.
3. in this case, "quick setting" still work as normal, you can see it when you pull it down from status bar.

So, in point 3, can you click the last button on "quick setting"?(the button looks like Settings app's icon) It should take you to Settings app, I'm wondering what happens. If the white screen is Settings app, you will see nothing happens. If it isn't, you will be taken to a real Settings app.

Let me know your result.
Flags: needinfo?(gweng) → needinfo?(lecky.wanglei)
(Reporter)

Comment 65

5 years ago
hi,Evelyn Hung 
I find the issue is related to not only  the setting,but also the other application.
but If the issue happen in Settings app,we will see nothing in Settings.We should kill the  process of settings,display become normal.
If the issue happen other application,such as communictions app.we only kill the  process of communictions.
but,sometimes we  only  statrt b2g, the white screen can disappear.

the issue may be has the same root cause with the bug 921829.

the question: 1. why white screen can not exit ,if we we hold home button?
              2. In either case,the quick setting still work as normal.
Flags: needinfo?(lecky.wanglei)
(Reporter)

Updated

5 years ago
Flags: needinfo?(ehung)
(Reporter)

Updated

5 years ago
Flags: needinfo?(alive)
(Reporter)

Comment 67

5 years ago
1. When you unlock screen, you see a white screen and it's possibly be Settings app, because if you kill the process of Settings app, the white screen is gone.

--> other app is also exist this problem, we used setting app as the example.

2. However, when you see the white screen, pressing home button won't take you back to homescreen, you still get stuck on the white screen.

--> press homekey, the phone will vibrate and can't go to home screen.

3. in this case, "quick setting" still work as normal, you can see it when you pull it down from status bar.

--> if setting app shows white background, now if you press setting icon in "quick setting", the screen is white background.
(In reply to lecky from comment #67)
> 1. When you unlock screen, you see a white screen and it's possibly be
> Settings app, because if you kill the process of Settings app, the white
> screen is gone.
> 
> --> other app is also exist this problem, we used setting app as the example.

If killing other apps can also recover this symptom, my question is when and why you will choose settings app to kill? Is settings app launched before you lock the screen or any other reasons?
Lecky, I recommend you to record a video when this issue occurs and you can do some actions at that time, like pressing (and long pressing) the home button, pull down the "quick setting", tapping the icons on "quick setting", trying to recover it, and so on. It might be useful for us to determine the root cause.

Updated

5 years ago
Flags: needinfo?(ehung) → needinfo?(lecky.wanglei)
(Reporter)

Comment 70

5 years ago
hi, Luke Chang
For the issue ,I tried  following methods to kill process 

1. pull it down the "quick setting", "quick setting" display normal.
2. adb shell b2g-info
3. we  can see processes running at that time,just as follow.

          NAME   PID NICE  USS  PSS  RSS VSIZE OOM_ADJ USER
           b2g   173    0 80.6 81.5 89.1 283.5       0 root
Preallocated a   504   18  7.8  8.3 13.9  64.0       6 root
Communications   737    0 32.4 33.2 40.5  98.5       1 app_737
    Homescreen 18790   18 15.4 16.1 23.4 146.6       2 app_18790
   Marketplace 20249   18 11.3 12.0 18.9  67.1       6 app_20249
      Messages 23257   18 14.4 15.2 22.7  86.2       2 app_23257
   AccuWeather 24597   18 14.9 15.7 23.0  77.5       2 app_24597
         Usage 27160   18  9.8 10.5 17.5  67.1       6 app_27160
      Settings 27210   18 30.3 31.2 38.7  93.5       6 app_27210
      Calendar 27471   18 15.2 16.0 23.4  72.2       6 app_27471
     HERE Maps 31417   18 14.5 15.2 22.5  74.2       6 app_31417

4. I kill processes  one by one in the list of processes. at the same time ,we watch the dispaly.

If we kill the processes ,display become normal.we think  the issue is related to the processes .

sometimes we kill process of settings, display  become normal. 
sometimes we  kill process of communction , display  become normal.

5. If we kill all processes  ,display still abnormal.We only can choose the start the b2g.

If we start b2g,display become normal.

(In reply to Luke Chang [:lchang] from comment #68)
> (In reply to lecky from comment #67)
> 1. When you unlock screen, you see a
> white screen and it's possibly be
> Settings app, because if you kill the
> process of Settings app, the white
> screen is gone.
> 
> --> other app is
> also exist this problem, we used setting app as the example.

If killing
> other apps can also recover this symptom, my question is when and why you
> will choose settings app to kill? Is settings app launched before you lock
> the screen or any other reasons?
Flags: needinfo?(lecky.wanglei)
(Reporter)

Comment 71

5 years ago
Created attachment 8335909 [details]
白屏2.part2.rar
(Reporter)

Comment 72

5 years ago
Created attachment 8335913 [details]
白屏2.part1.rar
(Reporter)

Updated

5 years ago
Flags: needinfo?(ehung)
(Reporter)

Comment 73

5 years ago
Created attachment 8335969 [details]
白屏-B006_H_screen_black_nsCategoryManager-9号机(2013.11.21_14_30~11.21_15_55).zip
(Reporter)

Comment 74

5 years ago
hi,we have shared the log when we find the white screen .

the white screen occurred at about 2:00 to 3:55 pm.
Created attachment 8337655 [details] [diff] [review]
0001-Bug-921829.patch

Hi Lecky,

Per offline discussion, this patch can print some additional logs that might be helpful. Please apply this patch and double click (within 1 sec) the "Volume Up" hardware button when this bug occurs and you'll see some logs that start with "921829:". Please attach those logs here and we can make further investigation.
Flags: needinfo?(ehung) → needinfo?(lecky.wanglei)
(Reporter)

Comment 76

5 years ago
Created attachment 8339689 [details]
white_log.rar
Flags: needinfo?(lecky.wanglei)
(Reporter)

Comment 77

5 years ago
hi,Luke Chang 

I have share the log applogcat-log.1 

from the log ,we can see follow log.please analyse 

1-29 01:53:34.589 I/GeckoDump(  177): 921829: (all iframes: 15) -------------------
11-29 01:53:34.589 I/GeckoDump(  177): 921829: iframe[0].src = app://costcontrol.gaiamobile.org/widget.html
11-29 01:53:34.589 I/GeckoDump(  177): 921829: iframe[0].appManifestURL = app://costcontrol.gaiamobile.org/manifest.webapp
11-29 01:53:34.589 I/GeckoDump(  177): 921829: iframe[1].src = app://communications.gaiamobile.org/dialer/index.html#keyboard-view
11-29 01:53:34.589 I/GeckoDump(  177): 921829: iframe[1].appManifestURL = app://communications.gaiamobile.org/manifest.webapp
11-29 01:53:34.589 I/GeckoDump(  177): 921829: iframe[2].src = http://m.facebook.com/
11-29 01:53:34.589 I/GeckoDump(  177): 921829: iframe[2].appManifestURL = http://m.facebook.com/openwebapp/manifest.webapp
11-29 01:53:34.589 I/GeckoDump(  177): 921829: iframe[3].src = app://communications.gaiamobile.org/contacts/index.html
11-29 01:53:34.589 I/GeckoDump(  177): 921829: iframe[3].appManifestURL = app://communications.gaiamobile.org/manifest.webapp
11-29 01:53:34.589 I/GeckoDump(  177): 921829: iframe[4].src = app://browser.gaiamobile.org/index.html
11-29 01:53:34.589 I/GeckoDump(  177): 921829: iframe[4].appManifestURL = app://browser.gaiamobile.org/manifest.webapp
11-29 01:53:34.599 I/GeckoDump(  177): 921829: iframe[5].src = app://email.gaiamobile.org/index.html
11-29 01:53:34.599 I/GeckoDump(  177): 921829: iframe[5].appManifestURL = app://email.gaiamobile.org/manifest.webapp
11-29 01:53:34.599 I/GeckoDump(  177): 921829: iframe[6].src = app://costcontrol.gaiamobile.org/index.html
11-29 01:53:34.599 I/GeckoDump(  177): 921829: iframe[6].appManifestURL = app://costcontrol.gaiamobile.org/manifest.webapp
11-29 01:53:34.599 I/GeckoDump(  177): 921829: iframe[7].src = app://settings.gaiamobile.org/index.html#root
11-29 01:53:34.599 I/GeckoDump(  177): 921829: iframe[7].appManifestURL = app://settings.gaiamobile.org/manifest.webapp
11-29 01:53:34.599 I/GeckoDump(  177): 921829: iframe[8].src = app://homescreen.gaiamobile.org/index.html#root1385652210930
11-29 01:53:34.599 I/GeckoDump(  177): 921829: iframe[8].appManifestURL = app://homescreen.gaiamobile.org/manifest.webapp
11-29 01:53:34.609 I/GeckoDump(  177): 921829: iframe[9].src = app://calendar.gaiamobile.org/index.html
11-29 01:53:34.609 I/GeckoDump(  177): 921829: iframe[9].appManifestURL = app://calendar.gaiamobile.org/manifest.webapp
11-29 01:53:34.609 I/GeckoDump(  177): 921829: iframe[10].src = app://fm.gaiamobile.org/index.html
11-29 01:53:34.609 I/GeckoDump(  177): 921829: iframe[10].appManifestURL = app://fm.gaiamobile.org/manifest.webapp
11-29 01:53:34.609 I/GeckoDump(  177): 921829: iframe[11].src = app://camera.gaiamobile.org/index.html
11-29 01:53:34.609 I/GeckoDump(  177): 921829: iframe[11].appManifestURL = app://camera.gaiamobile.org/manifest.webapp
11-29 01:53:34.609 I/GeckoDump(  177): 921829: iframe[12].src = app://sms.gaiamobile.org/index.html
11-29 01:53:34.609 I/GeckoDump(  177): 921829: iframe[12].appManifestURL = app://sms.gaiamobile.org/manifest.webapp
11-29 01:53:34.609 I/GeckoDump(  177): 921829: iframe[13].src = 
11-29 01:53:34.609 I/GeckoDump(  177): 921829: iframe[13].appManifestURL = app://settings.gaiamobile.org/manifest.webapp
11-29 01:53:34.609 I/GeckoDump(  177): 921829: iframe[14].src = app://keyboard.gaiamobile.org/index.html
11-29 01:53:34.619 I/GeckoDump(  177): 921829: iframe[14].appManifestURL = app://keyboard.gaiamobile.org/manifest.webapp
11-29 01:53:34.619 I/GeckoDump(  177): 921829: (runningApps: 13) --------------------
11-29 01:53:34.619 I/GeckoDump(  177): 921829: runningApps[app://communications.gaiamobile.org/dialer/index.html#keyboard-view].iframe.src = app://communications.gaiamobile.org/dialer/index.html#keyboard-view
11-29 01:53:34.619 I/GeckoDump(  177): 921829: runningApps[app://communications.gaiamobile.org/dialer/index.html#keyboard-view].iframe.appManifestURL = app://communications.gaiamobile.org/manifest.webapp
11-29 01:53:34.619 I/GeckoDump(  177): 921829: runningApps[http://m.facebook.com].iframe.src = http://m.facebook.com/
11-29 01:53:34.619 I/GeckoDump(  177): 921829: runningApps[http://m.facebook.com].iframe.appManifestURL = http://m.facebook.com/openwebapp/manifest.webapp
11-29 01:53:34.619 I/GeckoDump(  177): 921829: runningApps[app://communications.gaiamobile.org/contacts/index.html].iframe.src = app://communications.gaiamobile.org/contacts/index.html
11-29 01:53:34.629 I/GeckoDump(  177): 921829: runningApps[app://communications.gaiamobile.org/contacts/index.html].iframe.appManifestURL = app://communications.gaiamobile.org/manifest.webapp
11-29 01:53:34.629 I/GeckoDump(  177): 921829: runningApps[app://browser.gaiamobile.org].iframe.src = app://browser.gaiamobile.org/index.html
11-29 01:53:34.629 I/GeckoDump(  177): 921829: runningApps[app://browser.gaiamobile.org].iframe.appManifestURL = app://browser.gaiamobile.org/manifest.webapp
11-29 01:53:34.629 I/GeckoDump(  177): 921829: runningApps[app://email.gaiamobile.org].iframe.src = app://email.gaiamobile.org/index.html
11-29 01:53:34.629 I/GeckoDump(  177): 921829: runningApps[app://email.gaiamobile.org].iframe.appManifestURL = app://email.gaiamobile.org/manifest.webapp
11-29 01:53:34.629 I/GeckoDump(  177): 921829: runningApps[app://costcontrol.gaiamobile.org].iframe.src = app://costcontrol.gaiamobile.org/index.html
11-29 01:53:34.629 I/GeckoDump(  177): 921829: runningApps[app://costcontrol.gaiamobile.org].iframe.appManifestURL = app://costcontrol.gaiamobile.org/manifest.webapp
11-29 01:53:34.629 I/GeckoDump(  177): 921829: runningApps[app://settings.gaiamobile.org].iframe.src = app://settings.gaiamobile.org/index.html#root
11-29 01:53:34.639 I/GeckoDump(  177): 921829: runningApps[app://settings.gaiamobile.org].iframe.appManifestURL = app://settings.gaiamobile.org/manifest.webapp
11-29 01:53:34.639 I/GeckoDump(  177): 921829: runningApps[app://homescreen.gaiamobile.org].iframe.src = app://homescreen.gaiamobile.org/index.html#root1385652210930
11-29 01:53:34.639 I/GeckoDump(  177): 921829: runningApps[app://homescreen.gaiamobile.org].iframe.appManifestURL = app://homescreen.gaiamobile.org/manifest.webapp
11-29 01:53:34.639 I/GeckoDump(  177): 921829: runningApps[app://calendar.gaiamobile.org].iframe.src = app://calendar.gaiamobile.org/index.html
11-29 01:53:34.639 I/GeckoDump(  177): 921829: runningApps[app://calendar.gaiamobile.org].iframe.appManifestURL = app://calendar.gaiamobile.org/manifest.webapp
11-29 01:53:34.639 I/GeckoDump(  177): 921829: runningApps[app://fm.gaiamobile.org].iframe.src = app://fm.gaiamobile.org/index.html
11-29 01:53:34.639 I/GeckoDump(  177): 921829: runningApps[app://fm.gaiamobile.org].iframe.appManifestURL = app://fm.gaiamobile.org/manifest.webapp
11-29 01:53:34.639 I/GeckoDump(  177): 921829: runningApps[app://camera.gaiamobile.org].iframe.src = app://camera.gaiamobile.org/index.html
11-29 01:53:34.639 I/GeckoDump(  177): 921829: runningApps[app://camera.gaiamobile.org].iframe.appManifestURL = app://camera.gaiamobile.org/manifest.webapp
11-29 01:53:34.639 I/GeckoDump(  177): 921829: runningApps[app://sms.gaiamobile.org].iframe.src = app://sms.gaiamobile.org/index.html
11-29 01:53:34.649 I/GeckoDump(  177): 921829: runningApps[app://sms.gaiamobile.org].iframe.appManifestURL = app://sms.gaiamobile.org/manifest.webapp
11-29 01:53:34.649 I/GeckoDump(  177): 921829: runningApps[app://gallery.gaiamobile.org].iframe.src = app://gallery.gaiamobile.org/index.html
11-29 01:53:34.649 I/GeckoDump(  177): 921829: runningApps[app://gallery.gaiamobile.org].iframe.appManifestURL = app://gallery.gaiamobile.org/manifest.webapp
(Reporter)

Updated

5 years ago
Flags: needinfo?(lchang)
Created attachment 8339844 [details] [diff] [review]
0001-Bug-921829.patch

Lecky, please apply this updated patch and record the logs by doing the same work as comment 75. Maybe we can narrow down the scope.
Assignee: nobody → lchang
Attachment #8337655 - Attachment is obsolete: true
Status: NEW → ASSIGNED
Flags: needinfo?(lchang)
Created attachment 8340266 [details] [diff] [review]
Workaround Patch

This is just a workaround patch and I can't guarantee that it is effective or stable enough.
Created attachment 8340269 [details] [diff] [review]
Workaround Patch

Sorry, please ignore the patch above. I've updated here.
Attachment #8340266 - Attachment is obsolete: true
(Reporter)

Comment 81

5 years ago
Created attachment 8341472 [details]
黑屏(可以进锁屏界面,但解锁后屏幕全黑,背光灯是亮的)-B007_L_screen_black_and_white-1号机(2013.12.2_21_00~12.3_9_30).rar
(Reporter)

Comment 82

5 years ago
Created attachment 8341477 [details]
黑屏(可以进锁屏界面,但解锁后屏幕全黑,背光灯是亮的).rar
(Reporter)

Comment 83

5 years ago
Created attachment 8341480 [details]
黑屏(可以进锁屏界面,但解锁后屏幕全黑,背光灯是亮的).rar
(Reporter)

Comment 84

5 years ago
Created attachment 8341483 [details]
状态栏图标消失-B007_L_screen_black_and_white-4号机(2013.12.2_21_00~12.3_9_30).part1.rar
(Reporter)

Comment 85

5 years ago
Created attachment 8341485 [details]
状态栏图标消失-B007_L_screen_black_and_white-4号机(2013.12.2_21_00~12.3_9_30).part2.rar
(Reporter)

Comment 86

5 years ago
Created attachment 8341486 [details]
状态栏图标消失-B007_L_screen_black_and_white-4号机(2013.12.2_21_00~12.3_9_30).part3.rar
(Reporter)

Comment 87

5 years ago
Created attachment 8341487 [details]
状态栏图标消失-B007_L_screen_black_and_white-4号机(2013.12.2_21_00~12.3_9_30).part4.rar
(Reporter)

Comment 88

5 years ago
hi,Luke Chang 
for the issue ,We have mearged the 0001-Bug-921829.patch and  attachment 8340269 [details] [diff] [review] patch.We test about 20 hour.but we find another issue.
we have share the log and video .please see attachment.

1.we wake up and unlock the phone, the screen display black. you can see the attachment (黑屏(可以进锁屏界面,但解锁后屏幕全黑,背光灯是亮的).
2.we find the status bar disappears.you can see the attachment (状态栏图标消失-B007_L_screen_black_and_white 1-4号机).

for the two Phenomenon.we still can see the iframe[5].appManifestURL is Empty.


I don't know why ,can you give me some advice.
(Reporter)

Updated

5 years ago
Flags: needinfo?(lchang)
If it's a different issue please file a different bug. Let's focus on the original bug here.
(Reporter)

Comment 90

5 years ago
hi,Wayne Chang
for the different issue ,I think the patch which luke give lead to some new problem.

thanks 
wufumin
Created attachment 8342265 [details] [diff] [review]
0001-Bug-921829.patch

Hi Lecky,

It appears that the patch in comment 80 doesn't fix this issue so I recommend you to revert it first.

This patch tries to monitor the pairs of iframes and "RunningApps". Please apply it and observe when we lose the reference of iframes in "RunningApps".
Attachment #8339844 - Attachment is obsolete: true
Attachment #8340269 - Attachment is obsolete: true
Flags: needinfo?(lchang)
(Reporter)

Comment 92

5 years ago
Created attachment 8342891 [details]
白屏-BOO8_path_for_grqp-10号机(2013.12.5_12_00~12.5_14_00).rar
(Reporter)

Updated

5 years ago
Flags: needinfo?(lchang)
(Reporter)

Comment 93

5 years ago
hi,Luke
I have shared the log.
from the log ,the number of iframe is 9,but the number of runningApps is 7.
at the same time ,the iframe[8].src = app://keyboard.gaiamobile.org/index.html.but we can't see runningApps.

I don't know why.

the issue begin from the 12.00 to 14.00.
you can see the log from the attachment.
(In reply to lecky from comment #93)
> at the same time ,the iframe[8].src =
> app://keyboard.gaiamobile.org/index.html.but we can't see runningApps.

Yes, that's because we don't use runningApps to track "keyboard" and neither does "costcontrol".

I will check your log soon. Thanks.
Flags: needinfo?(lchang)
(Reporter)

Comment 95

5 years ago
Created attachment 8342948 [details]
ddms_log_1.txt
(Reporter)

Comment 96

5 years ago
hi,Luke Chang 
I find there is some error in the wlanacname.there is another  device.

10-29 02:56:08.879: I/GeckoDump(183): 921829: runningApps[http://221.176.1.140:8080/wlan/index.php?wlanacname=1135.0027.270.00&wlanuserip=10.87.73.149&ssid=CMCC].iframe.getAttribute("mozapp") = null
may be the information can help you.
(Reporter)

Updated

5 years ago
Flags: needinfo?(lchang)
(In reply to lecky from comment #96)
> hi,Luke Chang 
> I find there is some error in the wlanacname.there is another  device.
> 10-29 02:56:08.879: I/GeckoDump(183): 921829:
> runningApps[http://221.176.1.140:8080/wlan/index.php?wlanacname=1135.0027.
> 270.00&wlanuserip=10.87.73.149&ssid=CMCC].iframe.getAttribute("mozapp") =
> null
> may be the information can help you.

It's normal case.
The "mozapp" attribute of the iframe launched from the bookmark on homescreen will always be null.
Flags: needinfo?(lchang)
(Reporter)

Comment 98

5 years ago
hi,Luke Chang 
1. from the log,can you  get some help information.
2. Do you rember the bug 929863.When we  mearge the patch, the probability of this problem become smaller.
(Reporter)

Updated

5 years ago
Flags: needinfo?(lchang)
(Reporter)

Comment 99

5 years ago
Created attachment 8343514 [details]
白屏-BOO8_path_for_grqp-2号机(2013.12.5_12_00~12.6_9_30).rar
(Reporter)

Comment 100

5 years ago
hi,I find  another device .I have share the log.
(Reporter)

Updated

5 years ago
Flags: needinfo?(lchang)
(Reporter)

Comment 101

5 years ago
hi,luke
for the issue ,I have some quesiton.
1.when wake up  phone ,why we still can see the screen of lock and display noraml.but ,if we unlock sceeen , display become white.
we can kill  process or start b2g ,display become normal.
2.we can pull down the quick setting.and the quick setting display normal.

so .I guess ,some process stay and can't quit.

If there is some problem about the iframe .when we wake up the phone ,there will be a recovery process.but why ths issue can't disappear.

I don't how to analyse. may be we can add some log about the process of display.
Or we can get some help information from the  bug 929863.

what do you think about the issue?
(Reporter)

Comment 102

5 years ago
hi,luke
If you think the log which don't include you need information.can you tell me where should add log.
After further discussion on this, triage decides not blocking the release on this given:
1. it reproduces only on partner build
2. only found with monkey tests, it has not been reproduced by hand
3. it is recoverable with rebooting device, and power key shut down menu functions correctly when problem is hit
blocking-b2g: hd+ → -
(Reporter)

Comment 104

5 years ago
hi, Wayne Chang 

for the issue ,we and luke  have do many works.at the same  we have find some suspicious point.
I think you and me solve this problem together.If we stop now,I can't understand.

If you have a moible,The phone displays white screen and we can't do anything.what dou you think about the phone.
Although  we only find  monkey tests, but the issue  impact performance.so we think the issue is very import.
(Reporter)

Comment 105

5 years ago
Created attachment 8345176 [details]
white.txt
(Reporter)

Updated

5 years ago
Flags: needinfo?(lchang) → needinfo?(wchang)
(In reply to lecky from comment #104)
> hi, Wayne Chang 
> 
> for the issue ,we and luke  have do many works.at the same  we have find
> some suspicious point.
> I think you and me solve this problem together.If we stop now,I can't
> understand.
> 
> If you have a moible,The phone displays white screen and we can't do
> anything.what dou you think about the phone.
> Although  we only find  monkey tests, but the issue  impact performance.so
> we think the issue is very import.

thanks for your comment.
Flags: needinfo?(wchang)
As Wayne said, this bug will suspend until any manual reproducible steps are found.
Flags: needinfo?(lchang)
Assignee: lchang → nobody

Comment 108

7 months ago
Firefox OS is not being worked on
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago7 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.