[app manager] Stopping the profiler is very slow

RESOLVED DUPLICATE of bug 1160522

Status

P1
normal
RESOLVED DUPLICATE of bug 1160522
5 years ago
3 months ago

People

(Reporter: paul, Unassigned)

Tracking

Trunk
x86
All

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
Stopping the profiler recording does nothing for few seconds.

My guess is that getting the profile takes time, and while the profile is being retrieved, the UI just looks like the recording failed. It's very confusing. We should show a throbber.
(Reporter)

Comment 1

5 years ago
Anton, how do I fix that? Just a throbber until the profile has been downloaded?
Flags: needinfo?(anton)
I assume that the problem is in profiler/panel.js:308. We update the UI only after stopProfiling called a callback but that doesn't happen until we get all the data. I'd update the UI (and also include some kind of a loading indicator) before calling stopProfiling and show an error if stopProfiling fails.
Flags: needinfo?(anton)
(Reporter)

Updated

5 years ago
Priority: P1 → P2
(Reporter)

Updated

5 years ago
Priority: P2 → P1
(Reporter)

Updated

5 years ago
Assignee: nobody → paul
Filter on 86b7095e-2bd0-499e-a704-d00f2524aeef / PAUL STOP SETTING QA CONTACT TO THE DEVTOOLS COMPONENT'S WATCHERS EMAIL FOR BUGS YOU FILE :)
QA Contact: developer.tools
(Reporter)

Comment 4

3 years ago
Jordan, is this still a problem?
Assignee: paul → nobody
Flags: needinfo?(jsantell)
I don't believe so, but we have another one tracking this under performance to follow up.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(jsantell)
Resolution: --- → DUPLICATE
Duplicate of bug: 1160522

Updated

3 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.