Enhancements to using the order parameter in Bug.search

RESOLVED DUPLICATE of bug 918443

Status

()

Bugzilla
WebService
RESOLVED DUPLICATE of bug 918443
5 years ago
5 years ago

People

(Reporter: Simon Green, Unassigned)

Tracking

Details

(Reporter)

Description

5 years ago
Two enhancements. Since they are related, I'm creating a single bug.

1) Document that the order value can be passed to Bug.search to specify the order that the bugs are returned in

2) Run the array through map_fields (like we do with the parameters). Currently, if I want to order by the summary, I need to specify { order => 'short_desc }, not { order => 'summary' } (short_desc is the column name in the bug table, summary is the value we give the user in Bug.search)

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 918443
You need to log in before you can comment on or make changes to this bug.