[wasabi] Unable to launch E-mail app completely.

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: echu, Unassigned)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 811806 [details]
logcat, around 11:30 to 11:33, 9/30

Once open E-Mail app, it will only stay in a white and empty screen without normal UI for user to use. Previous wasabi build works(but maybe back to 9/11), so this is a regression issue.

* Build Number                
Gaia:     1e9470b9b6df630eddf1c4c8b25b3170ee786b0e
Gecko:    e73e0786029b584737d7767f43a58643f3725dd7
BuildID   20130930033052
Version   26.0a2

* Reproduce Steps
Open E-Mail.

* Expected Result
App is launched correctly.

* Actual Result
White empty screen.

* Occurrence rate
100%
(Reporter)

Comment 1

5 years ago
Found on Wasabi device, not on Buri.
blocking-b2g: --- → koi?
Keywords: regression
Whiteboard: [FT:RIL]
(Reporter)

Comment 2

5 years ago
Following build has no such bug.
20130924150811
There is no indication of the e-mail app logic ever triggering.  Given that there's been reports of e-mail app build failures resulting in the app not actually being present, I think that may be what's happening here.  Unfortunately, I am unable to locate where the wasabi builds live.

Questions:
1) In this build is the icon for the e-mail app the right icon, or the default gray icon?
2) In the email app's zip file, is there actually anything in there?

If you can point us at the location of the build and ideally an accompanying build log, we can take a deeper look.
Flags: needinfo?(echu)
(Reporter)

Comment 4

5 years ago
Hi Andrew,

(In reply to Andrew Sutherland (:asuth) from comment #3)
> There is no indication of the e-mail app logic ever triggering.  Given that
> there's been reports of e-mail app build failures resulting in the app not
> actually being present, I think that may be what's happening here. 
> Unfortunately, I am unable to locate where the wasabi builds live.
> 
> Questions:
> 1) In this build is the icon for the e-mail app the right icon, or the
> default gray icon?
I will attach the video and you'll see that icon is correct, after launching it a page with small icon in the central shows first, then go to white page.

> 2) In the email app's zip file, is there actually anything in there?
> If you can point us at the location of the build and ideally an accompanying
> build log, we can take a deeper look.
Can you access the link of TW QA jenkins link? We build wasabi there. http://release1-qa.corp.tpe1.mozilla.com:8080/view/B2G.v1.2.0/job/B2G.v1.2.0.wasabi/

I check the gaia.zip, under /gaia/profile/webapps/email.gaiamobile.org, seems to be files there. But I am not so familiar with the file structure, please let me know how should I check it to provide correct information.

Thanks.
Flags: needinfo?(echu)
(Reporter)

Comment 5

5 years ago
Created attachment 812462 [details]
video
Hm, yeah, it looks like the build process should be fine then.  This suggests some type of gecko/platform issue with Wasabi then, since I don't believe we're seeing any problems on other platforms.  It sounds like you have the nightly regression range, so you should be able to bisect on gecko/gonk builds?  I don't see anything obvious we can do on the e-mail app side of things.
triage: not shipping wasabi for 1.2, pushing this to 1.3
blocking-b2g: koi? → 1.3?
Nexus 4 v1.2 has the same issue.

Gaia:     1e9470b9b6df630eddf1c4c8b25b3170ee786b0e
Gecko:    31cc146c80e45d87211c647c5601b3cd7b6234f8

Comment 9

5 years ago
It's not telephony issue. remove [FT:RIL]
Whiteboard: [FT:RIL]
Enpei, can you try rebuilding this build without using make -j?   The developer thinks this could be a build issue that happened in bug 931550.   Please renom for blockingb2g=1.3? again if you can reproduce after a more recent production make.
blocking-b2g: 1.3? → ---
Flags: needinfo?(echu)
Keywords: qawanted
(Reporter)

Comment 11

5 years ago
Hi Tony,

I tried to reproduce the bug today with latest v1.2 build, there is no such issue now but we didn't change any build setting. So I will close the bug first.

Gaia:     8ff13cf43d185104a000bab68f5eef589b5d8684
Gecko:    41e8c46cb1b8b9b3058b1cbf6525c020bebfc4f0
BuildID   20131120031537
Version   26.0
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(echu)
Resolution: --- → WORKSFORME
Nexus-4 v1.2
Gaia:     8ff13cf43d185104a000bab68f5eef589b5d8684
Gecko:    59d46a4dc738742b52ca201db9a34333d52ab202
BuildID   20131119063037
Version   28.0a1

WFM, too
(In reply to Askeing Yen[:askeing] from comment #12)
> Nexus-4 v1.2
Gaia:     8ff13cf43d185104a000bab68f5eef589b5d8684
Gecko:    41e8c46cb1b8b9b3058b1cbf6525c020bebfc4f0
BuildID   20131120030037
Version   26.0

WFM, too

(comment 12 do not replace the gecko.)

Updated

5 years ago
Keywords: qawanted
You need to log in before you can comment on or make changes to this bug.