Dns stops resolving names in mail

VERIFIED DUPLICATE of bug 162871

Status

MailNews Core
Networking
VERIFIED DUPLICATE of bug 162871
17 years ago
10 years ago

People

(Reporter: Francisco León, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2) Gecko/20010721
BuildID:    2001072104

From bug 84580
Hmm... this may be what happens with all those connection refused modal windows
i get when checking mail. After some time, i always get that, and manually
hitting the get message button automatically displays a connection refused
window. Mozilla CANT know that fast if my server is up or down, but the server
is up and after hitting lots of times the get mail button it finally downloads mail



Reproducible: Sometimes
Steps to Reproduce:
1.Let mozilla download mail automatically



Actual Results:  Connection refused errors sometimes. Clicking on get mail
automatically says the same, without even checking

Expected Results:  The opposite

Comment 1

16 years ago
Francisco: Still seeing this?

Comment 2

16 years ago
I have a possible additional description (If it is the same bug...)

My ISP's pop server resolves to two A records in DNS. One day, one IP address
(The first one) stopped accepting connections. Mozilla mail was popping up the
"Connection Refused " warning dialog as described in this bug.

So I did "telnet pop.myisp.com 110"  I got back:

telnet pop.myisp.com 110
Trying ss.vv.nn.xx...
telnet: connect to address ss.vv.nn.xx: Connection refused
Trying qq.ww.ee.rr...
Connected to pop.myisp.com.

So, when Round robin DNS (If correct term) is implemented, Mozilla mail 
doesn't try the second IP address if the first one is failing.

Cheers, 
Michael

 

Updated

15 years ago
QA Contact: huang → gchan

Comment 3

15 years ago
please reopen if you disagree.

*** This bug has been marked as a duplicate of 162871 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 4

15 years ago
VERIFIED/dupe.
Status: RESOLVED → VERIFIED
QA Contact: gchan → benc
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.