Defect - tap-drag on nav bar input invokes scroll of content

RESOLVED FIXED in Firefox 28

Status

defect
P2
normal
RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: jimm, Assigned: jimm)

Tracking

Trunk
Firefox 28
x86_64
Windows 8.1
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [block28] feature=defect c=tbd u=tbd p=1)

Assignee

Description

6 years ago
STR:

1) bring up the nav bar on a web page that scrolls
2) tap down on the nav bar and drag away from the input

result: content scrolls
expected: nothing should happen

We should be canceling apz here, but this doesn't appear to be working.

http://mxr.mozilla.org/mozilla-central/source/browser/metro/base/content/input.js#325
Summary: tap-drag on nav bar input invokes scroll of content → Defect - tap-drag on nav bar input invokes scroll of content
Whiteboard: [triage] feature=defect c=tbd u=tbd p=0
Assignee

Updated

6 years ago
Blocks: metro-apzc
Assignee

Updated

6 years ago
Whiteboard: [triage] feature=defect c=tbd u=tbd p=0 → feature=defect c=tbd u=tbd p=0
The "nav bar" is the URL bar at the bottom of the screen, right? If so then I can't reproduce this. Doing a drag from the URL bar into the content area doesn't make the content scroll for me.
Assignee

Comment 2

6 years ago
STR: 

Use a system without a physical keyboard.

1) open a page of text that can be scrolled
2) scroll the page down just a bit
3) tap on the urlbar to bring up the soft keyboard
4) touch down on the navbar edit and slide your finger up

result: page scrolls

may take a few tries to get it to happen.

Chrome should be calling preventDefault in input.js on this input since the target is chrome content. My guess is something in our detection of chrome targeting is getting messed up.
Assignee

Comment 3

6 years ago
Note we have a similar problem with context menus in bug 927239.
Assignee

Comment 4

6 years ago
The bug only reproduces when after the tap both touch monocles display on text in the url bar.
Assignee

Updated

6 years ago
Depends on: 931763
Assignee

Updated

6 years ago
Assignee: nobody → jmathies
Assignee

Updated

6 years ago
Whiteboard: feature=defect c=tbd u=tbd p=0 → [blocker] feature=defect c=tbd u=tbd p=0
Hey Jim, can you provide a point estimate.
Blocks: metrov1it18
No longer blocks: metrov1backlog
Status: NEW → ASSIGNED
Flags: needinfo?(jmathies)
Priority: -- → P2
QA Contact: jbecerra
Whiteboard: [blocker] feature=defect c=tbd u=tbd p=0 → [block28] feature=defect c=tbd u=tbd p=0
Assignee

Updated

6 years ago
Flags: needinfo?(jmathies)
Whiteboard: [block28] feature=defect c=tbd u=tbd p=0 → [block28] feature=defect c=tbd u=tbd p=1
Assignee

Comment 6

6 years ago
fixed in 10-31 nightly.
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 28
OS: Windows 8 Metro → Windows 8.1
You need to log in before you can comment on or make changes to this bug.