Closed Bug 922137 Opened 6 years ago Closed 6 years ago

Downloads failed if you update Aurora 25 to 26 while downloading

Categories

(Toolkit :: Downloads API, defect)

x86_64
Windows 7
defect
Not set

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: mihai.morar, Unassigned)

References

Details

I found this issue while testing Download Manager functionalities:

OS: Windows 7 x64

1. Install Aurora 25 (2013/08/30)
2. Start these 2 downloads: http://www.softpedia.com/dyn-postdownload.php?p=84329&t=4&i=1 and 
http://www.softpedia.com/dyn-postdownload.php?p=177073&t=4&i=1
3. While downloading those 2 files, Go to Help -> About Aurora and Update to Latest Aurora version.
4. When updates are done Restart FF (those 2 downloads started in step 2 must not be completed).
5. Open Download Manager

Actual Results:
After step 5 both downloads started in step 2 are FAILED.

Expected Results:
After step 5 both downloads must continue in terms of which remained after step 4.



Using Latest Nightly 27 (2013/09/30) for same steps, after step 5 a Dialog Box is open with 2 buttons:
1. Don't exit
2. Cancel the 2 Downloads

If a press "Don't exit" option and then Close FF, after Restart both downloads from step 2 continue in terms of which remained after step 4. 

If I press "Cancel the 2 Downloads" I get same results as if I choose "Don't exit"
Depends on: 851466
QA Contact: mihai.morar
No longer depends on: 851466
I followed the steps to reproduce in this bug, and it seemed to affect the profile I used for testing. Then, I retried with a new profile and the problem did not appear. Probably, the profile I used for testing had already had the "browser.download.useJSTransfer" preference switched before, meaning that "browser.download.importedFromSqlite" might have already been set. This would have prevented the migration from happening.

Mihai, can you verify this on a new profile, or a profile that has never been updated to Aurora 26 or touched the "useJSTransfer" preference before?

Felipe, while testing the downloads in comment 0 on the new profile case, I observed a strange behavior. The migration seemed to happen, but when I tried to cancel the new in-progress downloads after the migration, they were only paused at first, and I had to click again on the button to actually cancel. Do you think it might have something to do with the migration code?
Blocks: 907082
Flags: needinfo?(felipc)
Using a new profile on Aurora 26 and STR from Comment 0, after STR 4 I am asked before restarting FF if I want or not no stop the downloads. I think "browser.download.useJSTransfer" preference was switched before as you said Paolo. Thanks for helping. I am closing for now as WFM this bug.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WORKSFORME
(In reply to Mihai Morar, QA (:MihaiMorar) from comment #2)
> I am closing for now as WFM this bug.

Sorry I did not want to close it seeing the behavion Paolo mentioned in Comment 1.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
I talked to Paolo on IRC to make sure I understood comment 1, and I've been trying to reproduce it on my machine but I can't. (fwiw osx 10.7).

Here are my STR. I'm using Firefox 24 (release) and 27 (Nightly) to test it:

- Launch Firefox 24 with brand new profile (or make sure browser.download.importedFromSqlite is false)
- Start download http://www.softpedia.com/dyn-postdownload.php?p=84329&t=4&i=1
- Quit Firefox before download finishes (don't pause the download)
- Launch Firefox 27
- Wait for Download manager to be initialized, download will auto-resume
- Click the cancel button

Is there anything that I'm doing differently that would cause it to behave differently too?
Flags: needinfo?(felipc)
(In reply to :Felipe Gomes from comment #4)
> Is there anything that I'm doing differently that would cause it to behave
> differently too?

I just executed the same steps again, except I used Aurora 25 on Windows and restarted from the About dialog after the automatic update. This time, the problem did not appear at first, but I had that intermittently after I restarted the same download and tried to stop it again.

I tried with a new download of the same file and I had the same issue, thus the problem is not apparently related to migration, differently from what I thought.

I've filed bug 929067 for this new issue. Thanks Felipe for looking into this!
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.