If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Intermittent test_peerConnection_bug834153.html | application crashed [@ mozalloc_abort(char const * const)] after "Assertion failed: index < attrct, file media/mtransport/third_party/nICEr/src/ice/ice_media_stream.c, line 193"

RESOLVED DUPLICATE of bug 922068

Status

()

Core
WebRTC
RESOLVED DUPLICATE of bug 922068
4 years ago
a year ago

People

(Reporter: RyanVM, Unassigned)

Tracking

({assertion, crash, intermittent-failure})

Trunk
x86
Windows XP
assertion, crash, intermittent-failure
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [sg:dupe 922068])

(Reporter)

Description

4 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=28561271&tree=Mozilla-Central

Windows XP 32-bit mozilla-central debug test mochitest-3 on 2013-09-30 08:53:26 PDT for push 5a49762ee832
slave: t-xp32-ix-015

09:00:34     INFO -  (ice/ERR) ICE(PC:bf4c402c8e5e7fb6): All could not pair new trickle candidate
09:00:34     INFO -  0[cfb1d10]: [CCAPP Task|def] ccapi.c:1235: SIPCC-CC_API: 1/29, send_message_helper: UI -> GSM: CREATEOFFER
09:00:34     INFO -  0[be76788]: [GSM Task|def] dcsm.c:532: SIPCC-DCSM: dcsm_process_event: DCSM 18  :(DCSM_READY:CREATEOFFER )
09:00:34     INFO -  0[be76788]: [GSM Task|fsm_sm] sm.c:46: SIPCC-FSM: sm_process_event: DEF 29  : 03811254x: sm entry: (STABLE:CREATEOFFER)
09:00:34     INFO -  0[be76788]: [GSM Task|fsm_sm] fsmdef.c:3173: SIPCC-FSM: fsmdef_ev_createoffer: Entered.
09:00:34     INFO -  0[be76788]: [GSM Task|sdp_config] sdp_config.c:105: SDP: Initialized config pointer: 0C629A08 (magic=0xABCDABCD)
09:00:34     INFO -  Assertion failed: index < attrct, file e:/builds/moz2_slave/m-cen-w32-d-000000000000000000/build/media/mtransport/third_party/nICEr/src/ice/ice_media_stream.c, line 193
09:00:34     INFO -  (ice/ERR) ICE(PC:bf4c402c8e5e7fb6): All could not pair new trickle candidate
09:00:34     INFO -  ###!!! ABORT: CRT ERROR R6010
09:00:34     INFO -  - abort() has been called
09:00:34     INFO -  Hit MOZ_CRASH() at e:/builds/moz2_slave/m-cen-w32-d-000000000000000000/build/memory/mozalloc/mozalloc_abort.cpp:30
09:00:34     INFO -  0[cfb1d10]: [CCAPP Task|def] ccapi.c:1163: SIPCC-CC_API: 1/29, cc_int_feature2: UI -> GSM: FOUNDICECANDIDATE
09:00:34     INFO -  nsStringStats
09:00:34     INFO -   => mAllocCount:         384258
09:00:34     INFO -   => mReallocCount:        38540
09:00:34     INFO -   => mFreeCount:          365103  --  LEAKED 19155 !!!
09:00:34     INFO -   => mShareCount:         536871
09:00:34     INFO -   => mAdoptCount:          30496
09:00:34     INFO -   => mAdoptFreeCount:      30493  --  LEAKED 3 !!!
09:00:34     INFO -  (ice/ERR) ICE(PC:bf4c402c8e5e7fb6): All could not pair new trickle candidate
09:00:34     INFO -  (ice/ERR) ICE(PC:bf4c402c8e5e7fb6): All could not pair new trickle candidate
09:00:34     INFO -  INFO | runtests.py | exit 2147483651
09:00:34     INFO -  INFO | runtests.py | Application ran for: 0:02:29.193000
09:00:34     INFO -  INFO | zombiecheck | Reading PID log: c:\docume~1\cltbld~1.t-x\locals~1\temp\tmpkw4e_kpidlog
09:00:34     INFO -  ==> process 3852 launched child process 3172 ("C:\slave\test\build\application\firefox\plugin-container.exe" --channel=3852.a2f9d30.1654640188 -greomni "C:\slave\test\build\application\firefox\omni.ja" -appomni "C:\slave\test\build\application\firefox\browser\omni.ja" -appdir "C:\slave\test\build\application\firefox\browser" - 3852 "\\.\pipe\gecko-crash-server-pipe.3852" tab)
09:00:34     INFO -  ==> process 3852 launched child process 596 ("C:\slave\test\build\application\firefox\plugin-container.exe" --channel=3852.6da1a80.1418649646 -greomni "C:\slave\test\build\application\firefox\omni.ja" -appomni "C:\slave\test\build\application\firefox\browser\omni.ja" -appdir "C:\slave\test\build\application\firefox\browser" - 3852 "\\.\pipe\gecko-crash-server-pipe.3852" tab)
09:00:34     INFO -  ==> process 3852 launched child process 716 ("C:\slave\test\build\application\firefox\plugin-container.exe" --channel=3852.10e2b3c0.1567290010 -greomni "C:\slave\test\build\application\firefox\omni.ja" -appomni "C:\slave\test\build\application\firefox\browser\omni.ja" -appdir "C:\slave\test\build\application\firefox\browser" - 3852 "\\.\pipe\gecko-crash-server-pipe.3852" tab)
09:00:34     INFO -  ==> process 3852 launched child process 2176 ("C:\slave\test\build\application\firefox\plugin-container.exe" --channel=3852.a420b40.1410757318 -greomni "C:\slave\test\build\application\firefox\omni.ja" -appomni "C:\slave\test\build\application\firefox\browser\omni.ja" -appdir "C:\slave\test\build\application\firefox\browser" - 3852 "\\.\pipe\gecko-crash-server-pipe.3852" tab)
09:00:42  WARNING -  PROCESS-CRASH | /tests/dom/media/tests/mochitest/test_peerConnection_bug834153.html | application crashed [@ mozalloc_abort(char const * const)]
09:00:42     INFO -  Crash dump filename: c:\docume~1\cltbld~1.t-x\locals~1\temp\tmph0oehg\minidumps\a9e56021-e0d3-427c-a6a8-fe473be6898b.dmp
09:00:42     INFO -  Operating system: Windows NT
09:00:42     INFO -                    5.1.2600 Service Pack 3
09:00:42     INFO -  CPU: x86
09:00:42     INFO -       GenuineIntel family 6 model 30 stepping 5
09:00:42     INFO -       8 CPUs
09:00:42     INFO -  Crash reason:  EXCEPTION_BREAKPOINT
09:00:42     INFO -  Crash address: 0x3f1245
09:00:42     INFO -  Thread 0 (crashed)
09:00:42     INFO -   0  mozalloc.dll!mozalloc_abort(char const * const) [mozalloc_abort.cpp:5a49762ee832 : 30 + 0x2c]
09:00:42     INFO -      eip = 0x003f1245   esp = 0x00126424   ebp = 0x0012642c   ebx = 0x0c766bbc
09:00:42     INFO -      esi = 0x10261440   edi = 0x10260670   eax = 0x00000000   ecx = 0x19309589
09:00:42     INFO -      edx = 0x10361f48   efl = 0x00000216
09:00:42     INFO -      Found by: given as instruction pointer in context
09:00:42     INFO -   1  xul.dll!MSCRTReportHook [nsAppRunner.cpp:5a49762ee832 : 1390 + 0x8]
09:00:42     INFO -      eip = 0x0220d069   esp = 0x00126434   ebp = 0x00126438
09:00:42     INFO -      Found by: call frame info
09:00:42     INFO -   2  MSVCR100D.dll + 0x11babc
09:00:42     INFO -      eip = 0x1031babd   esp = 0x00126440   ebp = 0x0012e4d0
09:00:42     INFO -      Found by: call frame info
09:00:42     INFO -   3  MSVCR100D.dll + 0x114661
09:00:42     INFO -      eip = 0x10314662   esp = 0x0012e4d8   ebp = 0x0012e4f0
09:00:42     INFO -      Found by: previous frame's frame pointer
09:00:42     INFO -   4  MSVCR100D.dll + 0x11461a
09:00:42     INFO -      eip = 0x1031461b   esp = 0x0012e4f8   ebp = 0x0012e518
09:00:42     INFO -      Found by: previous frame's frame pointer
09:00:42     INFO -   5  MSVCR100D.dll + 0x489ed
09:00:42     INFO -      eip = 0x102489ee   esp = 0x0012e520   ebp = 0x0012e754
09:00:42     INFO -      Found by: previous frame's frame pointer
09:00:42     INFO -   6  MSVCR100D.dll + 0x12433d
09:00:42     INFO -      eip = 0x1032433e   esp = 0x0012e75c   ebp = 0x0012e764
09:00:42     INFO -      Found by: previous frame's frame pointer
09:00:42     INFO -   7  MSVCR100D.dll + 0x115646
09:00:42     INFO -      eip = 0x10315647   esp = 0x0012e76c   ebp = 0x0012f21c
09:00:42     INFO -      Found by: previous frame's frame pointer
09:00:42     INFO -   8  xul.dll!nr_ice_media_stream_get_attributes [ice_media_stream.c:5a49762ee832 : 193 + 0x1c]
09:00:42     INFO -      eip = 0x039ae8b6   esp = 0x0012f224   ebp = 0x0012f244
09:00:42     INFO -      Found by: previous frame's frame pointer
09:00:42     INFO -   9  xul.dll!mozilla::NrIceMediaStream::GetCandidates() [nricemediastream.cpp:5a49762ee832 : 355 + 0x12]
09:00:42     INFO -      eip = 0x03793a70   esp = 0x0012f24c   ebp = 0x0012f350
09:00:42     INFO -      Found by: call frame info
09:00:42     INFO -  10  xul.dll!vcmRxAllocICE_m [VcmSIPCCBinding.cpp:5a49762ee832 : 533 + 0xb]
09:00:42     INFO -      eip = 0x037bc665   esp = 0x0012f358   ebp = 0x0012f3e4
09:00:42     INFO -      Found by: call frame info
09:00:42     INFO -  11  xul.dll!mozilla::runnable_args_nm_10_ret<short (*)(unsigned short,unsigned short,unsigned short,unsigned int,char const *,unsigned short,char * *,int *,char * * *,int *),unsigned short,unsigned short,unsigned short,unsigned int,char const *,unsigned short,char * *,int *,char * * *,int *,int>::Run() [runnable_utils_generated.h:5a49762ee832 : 961 + 0x2b]
09:00:42     INFO -      eip = 0x037b7c5a   esp = 0x0012f3ec   ebp = 0x0012f418
09:00:42     INFO -      Found by: call frame info
09:00:42     INFO -  12  xul.dll!mozilla::SyncRunnable::Run() [SyncRunnable.h:5a49762ee832 : 70 + 0x10]
09:00:42     INFO -      eip = 0x037b8752   esp = 0x0012f420   ebp = 0x0012f428
09:00:42     INFO -      Found by: call frame info

Updated

4 years ago
Group: media-core-security
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 922068
Group: media-core-security → core-security
Whiteboard: [sg:dupe 922068]

Updated

2 years ago
Group: core-security → core-security-release
Group: core-security-release
You need to log in before you can comment on or make changes to this bug.