csb_PL.utf8 throwing xml.parsers.expat.ExpatError when running via mozmill

RESOLVED DUPLICATE of bug 832060

Status

()

RESOLVED DUPLICATE of bug 832060
5 years ago
4 years ago

People

(Reporter: tompelka, Unassigned)

Tracking

17 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

981 bytes, text/javascript
Details
(Reporter)

Description

5 years ago
Created attachment 812548 [details]
test.js

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:17.0) Gecko/20130912 Firefox/17.0 (Nightly/Aurora)
Build ID: 20130913055614

Steps to reproduce:

LC_ALL=csb_PL.utf8 mozmill -a /usr/lib/firefox/langpacks/langpack-csb@firefox.mozilla.org.xpi -t test.js --show-all -D


Actual results:

Traceback (most recent call last):
  File "./test.py", line 29, in <module>
    _mozmill.run()
  File "/usr/lib/python2.6/site-packages/mozmill-1.5.21-py2.6.egg/mozmill/__init__.py", line 776, in run
    runner = self.create_runner()
  File "/usr/lib/python2.6/site-packages/mozrunner-2.5.15-py2.6.egg/mozrunner/__init__.py", line 642, in create_runner
    addons=self.addons)
  File "/usr/lib/python2.6/site-packages/mozmill-1.5.21-py2.6.egg/mozmill/__init__.py", line 752, in get_profile
    profile = jsbridge.CLI.get_profile(self, *args, **kwargs)
  File "/usr/lib/python2.6/site-packages/jsbridge-2.4.17-py2.6.egg/jsbridge/__init__.py", line 115, in get_profile
    profile = mozrunner.CLI.get_profile(self, *args, **kwargs)
  File "/usr/lib/python2.6/site-packages/mozrunner-2.5.15-py2.6.egg/mozrunner/__init__.py", line 655, in get_profile
    return self.profile_class(binary, profile, addons, preferences)
  File "/usr/lib/python2.6/site-packages/mozrunner-2.5.15-py2.6.egg/mozrunner/__init__.py", line 162, in __init__
    self.install_addon(addon)
  File "/usr/lib/python2.6/site-packages/mozrunner-2.5.15-py2.6.egg/mozrunner/__init__.py", line 240, in install_addon
    addon_id = Profile.addon_id(addon)
  File "/usr/lib/python2.6/site-packages/mozrunner-2.5.15-py2.6.egg/mozrunner/__init__.py", line 203, in addon_id
    doc = minidom.parse(os.path.join(addon_path, 'install.rdf')) 
  File "/usr/lib/python2.6/site-packages/_xmlplus/dom/minidom.py", line 1915, in parse
    return expatbuilder.parse(file)
  File "/usr/lib/python2.6/site-packages/_xmlplus/dom/expatbuilder.py", line 926, in parse
    result = builder.parseFile(fp)
  File "/usr/lib/python2.6/site-packages/_xmlplus/dom/expatbuilder.py", line 207, in parseFile
    parser.Parse(buffer, 0)
xml.parsers.expat.ExpatError: XML or text declaration not at start of entity: line 2, column 0


Expected results:

Happen only on csb_PL.utf8, other locales are just fine.

mozmill  1.5.20

Updated

4 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 832060
You need to log in before you can comment on or make changes to this bug.