'My Makes' overlay/saving on Thimble

RESOLVED DUPLICATE of bug 912696

Status

RESOLVED DUPLICATE of bug 912696
5 years ago
5 years ago

People

(Reporter: james, Assigned: pomax)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 812560 [details]
Screen Shot 2013-10-01 at 11.14.23.png

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_8_4) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/28.0.1500.71 Safari/537.36

Steps to reproduce:

I was creating a Thimble, and wasn't sure if it was saved automatically as I went along, even though it wasn't ready to publish. To see if it was being saved somewhere, I alt-clicked (Mac) the "My Makes" button to open it in a new tab.


Actual results:

A pop-up appeared over my Thimble, saying I had no saved thimbles (see screenshot). My Thimble was still visible beneath it, but I couldn't get back to it. Pressing the back button took me back to the Webmaker homepage, and I seem to have lost the thimble I was working on.


Expected results:

Thimble should be auto-saved, or there should be a save button, so work in progress is not lost. "Publish" should not be the only option.

Also "open in new tab" should function as expected.

Updated

5 years ago
Assignee: nobody → pomax
(Assignee)

Comment 1

5 years ago
You can get rid of the "my makes" panel by clicking "my makes" again, but I agree that this is poor UX and we need to fix this so that clicking outside the makes panel makes it disappear again (https://bugzilla.mozilla.org/show_bug.cgi?id=887136). We also are working on adding a save feature in addition to the publish function at the moment (https://bugzilla.mozilla.org/show_bug.cgi?id=912696).

I'm going to mark this bug a duplicate since we have separate bugs already for the issues you flagged, but thank you for letting us know!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 912696
You need to log in before you can comment on or make changes to this bug.