[wasabi][CDMA][Call waiting] Since CDMA has limitation to distinguish current on hold and active call, suggest to remove caller ID and number below Switch button in case to confuse user.

VERIFIED FIXED in Firefox OS v1.2

Status

VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: echu, Assigned: gsvelto)

Tracking

unspecified
1.2 C3(Oct25)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:koi+, b2g18 unaffected, b2g-v1.1hd unaffected, b2g-v1.2 verified)

Details

(Whiteboard: [FT:RIL])

Attachments

(4 attachments, 1 obsolete attachment)

(Reporter)

Description

5 years ago
Created attachment 812582 [details]
IMG_0002.jpg

Since CDMA has limitation to distinguish current on hold and active call, suggest to remove caller ID and number below Switch button in case to confuse user. When either one call is ended and another call dialed in and established, it's weird to keep seeing the previous caller ID under Switch button.

Gaia:     1e9470b9b6df630eddf1c4c8b25b3170ee786b0e
Gecko:    31cc146c80e45d87211c647c5601b3cd7b6234f8
BuildID   20131001031552
Version   26.0a2
http://release1-qa.corp.tpe1.mozilla.com:8080/view/B2G.v1.2.0/job/B2G.v1.2.0.wasabi/
(Reporter)

Updated

5 years ago
Whiteboard: [FT:RIL]

Comment 1

5 years ago
hi Neo,

it seems that the current UX design is in conflict with our original agreement. while call waiting under CDMA NW, the caller ID shouldn't be shown.
Assignee: nobody → nhsieh
blocking-b2g: --- → koi+
(Reporter)

Updated

5 years ago
Blocks: 890807

Comment 2

5 years ago
Created attachment 813015 [details]
CallWaiting_1.2_20131002.zip

We already updated, please check the attached file.  Thanks

Updated

5 years ago
Assignee: nhsieh → echu
(Reporter)

Comment 3

5 years ago
Hi Ken,

Can you help to assign owner? Thank you.
Assignee: echu → nobody
Flags: needinfo?(kchang)

Comment 4

5 years ago
Gabriele, we need to change a little UX for the call waiting.
Assignee: nobody → gsvelto
Flags: needinfo?(kchang)
(Assignee)

Comment 5

5 years ago
Right, this is a bug on my part. I thought I had removed the number already but now that I'm looking at the code I can see where the problem is. I'll fix this according to spec.
Target Milestone: --- → 1.2 C3(Oct25)
(Assignee)

Comment 6

5 years ago
Hsin-Yi, can you help me out debugging this? In theory my code should correctly hide the phone number of the caller and replace it with "Switch calls", this happens here:

https://github.com/mozilla-b2g/gaia/blob/master/apps/communications/dialer/js/calls_handler.js#L506

... and here:

https://github.com/mozilla-b2g/gaia/blob/master/apps/communications/dialer/js/handled_call.js#L133

Could you verify if this code is being called correctly?
Flags: needinfo?(htsai)
(In reply to Gabriele Svelto [:gsvelto] from comment #6)
> Hsin-Yi, can you help me out debugging this? In theory my code should
> correctly hide the phone number of the caller and replace it with "Switch
> calls", this happens here:
> 
> https://github.com/mozilla-b2g/gaia/blob/master/apps/communications/dialer/
> js/calls_handler.js#L506
> 
> ... and here:
> 
> https://github.com/mozilla-b2g/gaia/blob/master/apps/communications/dialer/
> js/handled_call.js#L133
> 
> Could you verify if this code is being called correctly?

I'll try this patch this afternoon.
Flags: needinfo?(htsai)
Gabriele,

The code works as expected. I see 'Switch calls.' :)
However, the UI still confuses me a bit... I thought I should "slide" to switch because the icon displays a two-way arrow. The truth is I need to press the icon. :( But anyway, all functions perfectly!
(Assignee)

Comment 9

5 years ago
(In reply to Hsin-Yi Tsai  [:hsinyi] from comment #8)
> The code works as expected. I see 'Switch calls.' :)
> However, the UI still confuses me a bit... I thought I should "slide" to
> switch because the icon displays a two-way arrow. The truth is I need to
> press the icon. :( But anyway, all functions perfectly!

Thank you for checking! I think I realized what is the problem. Switch calls appears correctly but the existing number is not hidden as per spec, I'll fix that. Thank you again.
(Assignee)

Comment 10

5 years ago
Created attachment 817154 [details] [diff] [review]
[PATCH] Remove the caller number when entering switch-calls mode

This is a one-line patch that removes the caller number when we enter switch-calls mode. I've also added a unit-test to verify this behavior.
Attachment #817154 - Flags: review?(etienne)
Comment on attachment 817154 [details] [diff] [review]
[PATCH] Remove the caller number when entering switch-calls mode

Review of attachment 817154 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks for the test! :)

But what happens if the initial call had contact infos, you get a second call, then you open the oncall keypad, type something, and close the keypad?
I think handledCall.restoreAdditionalContactInfo() might put back the initial info you got rid off earlier.

Emptying |this._cachedAdditionalInfo| should do the trick.

Note that in order to test this you'll need to go through restoreAdditionalContactInfo() since we don't want to touch the internals (_cachedAdditionalInfo) of the handledCall from the tests.
Attachment #817154 - Flags: review?(etienne)
(Assignee)

Comment 12

5 years ago
Created attachment 817780 [details] [diff] [review]
[PATCH v2] Remove the caller number when entering switch-calls mode

(In reply to Etienne Segonzac (:etienne) from comment #11)
> But what happens if the initial call had contact infos, you get a second
> call, then you open the oncall keypad, type something, and close the keypad?
> I think handledCall.restoreAdditionalContactInfo() might put back the
> initial info you got rid off earlier.
> 
> Emptying |this._cachedAdditionalInfo| should do the trick.

Good point, I've updated the patch to do just that.

> Note that in order to test this you'll need to go through
> restoreAdditionalContactInfo() since we don't want to touch the internals
> (_cachedAdditionalInfo) of the handledCall from the tests.

I've modified the test (and the other switch-calls test too) so that the handled call is created first without the second number being present. This ensures that the additional contact info is populated. Then the second number is added and HandledCall.updateCallNumber() is called just like in the regular code flow and only afterwards I check if the visible number and additional info has been adjusted correctly.
Attachment #817154 - Attachment is obsolete: true
Attachment #817780 - Flags: review?(etienne)
Comment on attachment 817780 [details] [diff] [review]
[PATCH v2] Remove the caller number when entering switch-calls mode

Review of attachment 817780 [details] [diff] [review]:
-----------------------------------------------------------------

All good, thanks!
Attachment #817780 - Flags: review?(etienne) → review+
(Assignee)

Comment 14

5 years ago
Created attachment 818382 [details]
[PULL REQUEST] Remove the caller number when entering switch-calls mode

Pointer to Github pull-request
(Assignee)

Updated

5 years ago
Attachment #818382 - Attachment description: Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/12913/files → [PULL REQUEST] Remove the caller number when entering switch-calls mode
(Assignee)

Comment 15

5 years ago
Thanks for the review, landed on gaia/master e2b15164dddb23804d3ee7832eebeb71ce808562 and gaia/v1.2 38189297e5956eedcf5354cf96298bc7137fd002
Status: NEW → RESOLVED
Last Resolved: 5 years ago
status-b2g18: --- → unaffected
status-b2g-v1.1hd: --- → unaffected
status-b2g-v1.2: --- → fixed
Resolution: --- → FIXED
(Reporter)

Comment 16

5 years ago
Verified on Wasabi

Gaia:     922de46ad5e4a8b513b24233a7f3bc54b93e9612
Gecko:    f28b860ef7a9fb9e0960b2aabaee55a42d17633b
BuildID   20131018170959
Version   26.0a2
Status: RESOLVED → VERIFIED
status-b2g-v1.2: fixed → verified
You need to log in before you can comment on or make changes to this bug.