Mail filters seem to have broken with this build (action: Delete Message)

VERIFIED FIXED

Status

--
major
VERIFIED FIXED
17 years ago
10 years ago

People

(Reporter: zevious, Assigned: naving)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.2+)
Gecko/20010725
BuildID:    2001072503

Filters were working with earlier build but not this one..

Reproducible: Always
Steps to Reproduce:




Actual Results:  Filter is not working.

Expected Results:  Filter to work..

Comment 1

17 years ago
Please elaborate on what isn't working, what type mail account, what kind of
filters, etc.  Thanks.

Using july 25 commercial branch 0.9.2 filters are working in general for me,
win98.  Existing filters and newly added ones.

Comment 2

17 years ago
I won't be getting to any trunk build today, so maybe someone else can confirm
for trunk.
(Reporter)

Comment 3

17 years ago
I have a filter set up to look for a sending containing 'MAILER-DAEMON' or
Subject contains 'failure notice'. If found, drop the message in the trash. This
worked up until this build. Now it just goes to the Inbox.
(Assignee)

Comment 4

17 years ago
It worksforme; make sure that the folder exists. 
(Reporter)

Comment 5

17 years ago
I have it set to 'Delete the message'..
(Reporter)

Comment 6

17 years ago
I changed the "perform action" to "Move to Trash" and the filter works now.
Seems to be an issue with "Delete Message" option..

Comment 7

17 years ago
Delete message action works fine for me with the branch, will try on the trunk
when I get a chance.
(Assignee)

Comment 8

17 years ago
accepting, I messed up in checking in last night because I had several
changes in my tree. I will checkin the correct fix to 41720 and that 
should fix this also. sorry for the regression caused.
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true

Updated

17 years ago
Summary: Mail filters seem to have broken with this build → Mail filters seem to have broken with this build (action: Delete Message)
(Assignee)

Comment 9

17 years ago
The remainig part of the fix for 41720 was checked in. 
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 10

17 years ago
OK for IMAP and POP using commercial trunk builds:

Comment 11

17 years ago
OK for IMAP and POP using commercial trunk builds:

2001-08-15-14 linux rh6.2

Comment 12

17 years ago
Hmm, something seems to be wrong with CR in bug forms. OK 2001-08-16-03 win98 &
2001-08-17-08 mac OS 9.0
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.