investigate more OutdatedDataErrors on balrog

VERIFIED FIXED

Status

Release Engineering
General
VERIFIED FIXED
4 years ago
7 months ago

People

(Reporter: bhearsum, Assigned: bhearsum)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

4 years ago
I thought we'd gotten rid of these with bug 851585, but it seems they're still occuring. Not a huge critical issue because of client side retries, but we should look into it sooner rather than later.
(Assignee)

Comment 1

4 years ago
Created attachment 816024 [details] [diff] [review]
don't let OutdatedDataErrors bubble up

I realized today that we're still getting these on Sentry because we're not catching these errors anywhere, so they bubble up as ISE 500. Since these are a type of failure that the user can correct, they should return 400s instead of 500s.
Assignee: nobody → bhearsum
Status: NEW → ASSIGNED
Attachment #816024 - Flags: review?(nthomas)
Comment on attachment 816024 [details] [diff] [review]
don't let OutdatedDataErrors bubble up

lgtm
Attachment #816024 - Flags: review?(nthomas) → review+

Comment 3

4 years ago
Commit pushed to master at https://github.com/mozilla/balrog

https://github.com/mozilla/balrog/commit/6e7d13f7d54baf13c3e37c5ea672e2b755191b9e
bug 922625: investigate more OutdatedDataErrors on balrog. r=nthomas
(Assignee)

Updated

4 years ago
Attachment #816024 - Flags: checked-in+
(Assignee)

Updated

4 years ago
Depends on: 926947
(Assignee)

Comment 4

4 years ago
Rolled out in production in bug 926947. I marked the traceback as resolved in Sentry so it'll be easy to see if it continues to be an issue tomorrow. Anyone with access can look at https://errormill.mozilla.org/Releng/ to watch for it.
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Assignee)

Comment 5

4 years ago
Most nightlies for today have finished and we haven't seen any more instances of this. I'll keep an eye a bit longer, but this is strong confirmation of fixedness.
Status: RESOLVED → VERIFIED
(Assignee)

Updated

4 years ago
Duplicate of this bug: 887872
Component: Tools → General
Product: Release Engineering → Release Engineering
You need to log in before you can comment on or make changes to this bug.