Cannot edit themes

VERIFIED FIXED in 2013-10-21

Status

addons.mozilla.org Graveyard
Public Pages
P3
normal
VERIFIED FIXED
5 years ago
2 years ago

People

(Reporter: amyt, Assigned: ngoke)

Tracking

unspecified
2013-10-21
x86
Mac OS X

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
We have a user who cannot edit his themes. Please see this thread: https://forums.mozilla.org/addons/viewtopic.php?f=30&t=14938&sid=ef9d4741a5f14b4b81059a0dc30f61e1

Since I have admin rights, I tried to change the license on https://addons.mozilla.org/firefox/addon/tetons-leigh-lake/ to All Rights Reserved. However, after saving and going to View Listing, it still says Some Rights Reserved. 

Same thing with the tag. I tried to delete "jacobson" and add "wyoming", but the changes were also not saved.

I can edit my own themes just fine. Not sure if this is happening to anyone else, so far Brian Z is the only one who has reported this.
(Assignee)

Updated

5 years ago
Assignee: nobody → kngo
The theme description is failing validation and preventing the form submission. Seems that it's just too long, but the validation error isn't being displayed.

Comment 2

5 years ago
Thanks for reporting & finding the problem.  In the process of fixing this bug, would it be possible to simply change the number for the character limit from "250" back to "500" as it was previously (I think)?  This would avoid requiring a lot of unnecessary editing work by many designers who would need to repeatedly revise and recount their descriptions, then resubmit for re-approval, even if they just want to make a simple change like selecting the correct copyright status.  250 is rather stingy anyway, IMO.  I have something like 45 themes that would require editing, and I'm just one designer with not all that many themes.   Just for testing purposes though, shortening my description to less than 250 characters did appear to fix my immediate issue, after which it displayed a "Changes Submitted Successfully" notice that I had not seen before.

Comment 3

5 years ago
Well, that first one I tried to edit was successfully changed, but on the next one I tried I did not receive any "Changes Submitted Successfully" notice on the editing page like the first time, yet my edited description only contained 247 characters.

Another suggestion:  Can you add a built-in character counter that is displayed in real time while editing the description?
(Assignee)

Comment 4

5 years ago
Forgot to link this PR from last week: https://github.com/mozilla/zamboni/pull/1223

Bumps the limit to 500, adds a character counter.
(Assignee)

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Priority: -- → P3
Resolution: --- → FIXED
Target Milestone: --- → 2013-10-14

Comment 5

5 years ago
The character counter says '5 Characters left' but the form submission fails with 'Ensure this value has at most 500 characters (it has 504).'
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 6

5 years ago
Created attachment 815109 [details]
charcater counter incorrect.png
(Assignee)

Comment 7

5 years ago
@krupa: I think this was reproduced by:

1. Submitting a 504 character description.
2. Deleting 9 characters.
3. Seeing the counter goes to 5 characters remaining, but the error still saying 504.

This would be acceptable since the counter is dynamic and the error message is static.

If this isn't how this was reproduced, then do you have STR? It works for me.
Flags: needinfo?(krupa.mozbugs)

Comment 8

5 years ago
STR:

1. Enter a description which has > 500 chs so that the counter goes negative
2. Delete characters until the counter is at 500
3. Save changes

observed behavior:
Form submission fails.
Flags: needinfo?(krupa.mozbugs)

Comment 9

5 years ago
Created attachment 815126 [details]
form submission failure
(Assignee)

Comment 10

5 years ago
Was due to line breaks.

https://github.com/mozilla/zamboni/pull/1237
(Assignee)

Comment 11

5 years ago
https://github.com/mozilla/zamboni/pull/1239
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
Target Milestone: 2013-10-14 → 2013-10-21

Comment 12

5 years ago
verified fixed @ https://addons-dev.allizom.org/en-US/developers/theme/snowae/edit
Status: RESOLVED → VERIFIED

Comment 13

5 years ago
It appears to be working for me now.  Thanks to all for the fix!  Having a counter is very handy - thanks for adding that, even if it does charge you for carriage returns.  Maybe you should have made the limit a binarily even 512 to help make up for that, then you wouldn't have to add a CR counter for the counter.  Thanks again.
(Assignee)

Comment 14

5 years ago
No problem, thanks a lot for filing this bug. I think we'll be okay with 12 less characters, though I'll keep that in mind. 512 is a nice number.
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.